Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

no internet access and not getting dhcp on 2848 with inner vlan routing

unassassinable
Occasional Visitor

no internet access and not getting dhcp on 2848 with inner vlan routing

I have 2 problems: I can't access the internet on any of my vlans. And my vlan 15 (LAN) hosts are not getting DHCP from vlan 10 (Servers). Here is my network topology:

(Internet)
|
|
|
|<=static ip address assigned by ISP
[Endian Firewall]
|<=192.168.56.1/24
|
|
|<=192.168.56.2/24
[Procurve 2848 Switch]
| | |
| | |vlan 5 (DMZ) Unused at the moment.
| |
| |vlan 10 (Servers) <=192.168.10.1
| - Win 2003 Server (AD, DHCP, DNS) <=192.168.10.3
|
|vlan 15 (LAN) <=192.168.15.1
-laptop, plugged in through ethernet, configured for dhcp
-desktop, configured statically <=192.168.15.10

As is, my laptop (plugged into any of the untagged ports on vlan 15 (LAN) cannot get dhcp from the dhcp server (192.168.10.3). The scope is set from 192.168.15.100-200 on the server and is active. The desktop, set with a static IP address can ping his gateway (192.168.15.1), can ping the Server's gateway (192.168.10.1), and can ping the server itself (192.168.10.3). He can also ping 192.168.56.2, which is the Outbound vlan that connects to my firewall, but cannot ping 192.168.56.1 (the firewall itself).


So, here is my config:

; J4904A Configuration Editor; Created on release #I.08.98

hostname "swi-2848"
time timezone -420
interface 48
name "Outbound"
exit
sntp server 192.168.10.3
ip routing
timesync sntp
sntp unicast
snmp-server community "public" Unrestricted
vlan 1
name "Outbound"
untagged 45-48
ip address 192.168.56.2 255.255.255.0
no untagged 1-44
exit
vlan 10
name "Servers"
untagged 7-12
ip address 192.168.10.1 255.255.255.0
exit
vlan 5
name "DMZ"
untagged 1-6
exit
vlan 15
name "LAN"
untagged 13-44
ip address 192.168.15.1 255.255.255.0
ip helper-address 192.168.10.3
exit
ip route 0.0.0.0 0.0.0.0 192.168.56.1

The switch routing table is attached as an image. Is there anyone that can help me out?

Rich
3 REPLIES
unassassinable
Occasional Visitor

Re: no internet access and not getting dhcp on 2848 with inner vlan routing

A quick update...I disabled windows firewall on the dhcp server and can get dhcp leases now...thought I turned that off!

Also I added routes to each of my vlans on the endian firewall and can now access the firewall, but still cannot connect to the internet. If I unplug from the vlan 15 and plug into port 44, 45, or 46 I can get on the internet. But neither the server on vlan 10, or hosts on vlan 15 can access the internet.

Rich
Jeff Carrell
Honored Contributor

Re: no internet access and not getting dhcp on 2848 with inner vlan routing

unassassinable said: "But neither the server on vlan 10, or hosts on vlan 15 can access the internet."

Does your router at 192.168.56.1 have static routes for those 2 vlans pointing back to the switch?

192.168.10.0/24 --> 192.168.56.2
192.168.15.9/24 --> 192.168.56.2

hth...Jeff
unassassinable
Occasional Visitor

Re: no internet access and not getting dhcp on 2848 with inner vlan routing

I found the problem was related to a known bug in Endian Firewall:

http://bugs.endian.com/view.php?id=1132

I added the routes manually, tested and it works fine.

Thanks for the replies!

Rich