Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

route between VLANs 2610

Mime_1
Occasional Visitor

route between VLANs 2610

Hi my name is Daniel I am very new to the vlan concept
And I need help to accomplish this configuration on procurve 2610

I need to create 3 vlans

Vlan 2 IP 192.168.2.1
Vlan 2 IP 192.168.3.1
Vlan 4 IP 192.168.4.1

Vlan 3 needs to talk to all vlans

But vlan 2 – 4 donut see each other

I have create 3 vlans

Vlan 1 default with all ports

Vlan 2 with ports 2-6
Vlan 3 with ports 7-13
Vlan 4 with ports 14-20
Help needed thanks Daniel
6 REPLIES
Olaf Borowski
Respected Contributor

Re: route between VLANs 2610

Daniel,
By creating VLANs, you have created logical layer 2 domains. By default, they don't talk to each other because the VLANs are different subnet. You need a router to do that.
Simple fix: turn on "ip routing" on the 2610 and the subnets will talk to each other.

Olaf

Mime_1
Occasional Visitor

Re: route between VLANs 2610

Hi thanks for the reply

Mime_1
Occasional Visitor

Re: route between VLANs 2610

now i need to create ACL
to accomplish this configuration

vlan 1
untagged 1 21-24
IP 192.168.1.1

vlan 2
untagged 2-6
IP 192.168.2.1

vlan 3
untagged 7-13
IP 192.168.3.1

vlan 4
untagged 14-20
IP 192.168.4.1

IP Routing Enabled

Vlan 3 can talk to all vlans

but Vlans 1 2 4 cennot see each other

my question is do i need to create ACL
Or Extended ACL

in my understanding ALC Aply only on a port but nut the All ports within a Vlan

Help needed thanks Daniel



RicN
Valued Contributor

Re: route between VLANs 2610


Is your wish still just to get all VLANs to be able to communicate between them or do you now want to restrict traffic movement between some of the VLANs?
Mime_1
Occasional Visitor

Re: route between VLANs 2610

restrict traffic movement between
vlan 1 2 and vlan 4 donut see each other
But Vlan 3 needs to talk to all vlans

Mime_1
Occasional Visitor

Re: route between VLANs 2610

This is what I want in the and result
1.Vlan 3 can see vlan2
2.Vlan 4 can see vlan 2
3.Vlan 3 and 4 donut see each other
in my config I m ending with this result
ther is no traffic between the vlan
what am I doing wrong

Startup configuration:

; J9085A Configuration Editor; Created on release #R.11.07

hostname "Kanat"
ip access-list standard "1"
deny 172.10.4.1 0.0.0.255
permit 172.10.3.1 0.0.0.255
exit
ip access-list standard "2"
permit 172.10.2.1 0.0.0.255
permit 172.10.4.1 0.0.0.255
exit
ip access-list standard "3"
deny 172.10.2.1 0.0.0.255
permit 172.10.3.1 0.0.0.255
exit
interface 2
access-group "1" in
exit
interface 3
access-group "1" in

exit
interface 4
access-group "1" in
exit
interface 5
access-group "2" in
exit
interface 6
access-group "2" in
exit
interface 7
access-group "2" in
exit
interface 8
access-group "2" in
exit
interface 9
access-group "3" in
exit
interface 10
access-group "3" in
Exit
interface 11
access-group "3" in
exit
interface 12
access-group "3" in
exit
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "Lan"
untagged 1,13-28
ip address 172.10.1.1 255.255.255.0
no untagged 2-12
exit
vlan 2
name "Kanat_Vlan"
untagged 2-4
ip address 172.10.2.1 255.255.255.0
exit
vlan 3
name "Storege_vlan"
untagged 5-8
ip address 172.10.3.1 255.255.255.0
exit
vlan 4
name "Wan_Vlan"
untagged 9-12
ip address 172.10.4.1 255.255.255.0
exit
ip authorized-managers 172.10.1.2
ip authorized-managers 172.10.4.2

Kanat#