Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

routing problem

SOLVED
Go to solution
Stefan Harrington-Palme
Occasional Visitor

routing problem

Hi guys and girls(maybe)....

I have a question.

We have a pile of switches around out side with two 5304's in the middle (192.168.99.1 and 99.2).

We also have a BT MPLS box(192.168.99.218) joining our country offices together.

From the CORE switches I am able to ping the MPLS box.

From the non-core switches I am unable to ping the MPLS box or (obviously) anything beyond it, in this case 192.168.10.11.

We have the default VLAN (1) and a management VLAN (99)

I AM able to ping 192.168.10.11 from the core switches.

We use 4 different subnets for users. 192.168.1.x, 2.x, 4.x, 5.x - Only people who are on the 192.168.1.x subnet and using 192.168.1.67 as their default gateway are able to use the MPLS to talk to our other offices.

If someone is on 192.168.2.x etc there is no response for the MPLS. They CAN however talk to any other subnet internally.


If anyone could point me in the right direction that'd be great or if I can clarify anything please let me know.

Stefan








CORE1 Config:
; J4850A Configuration Editor; Created on release #E.11.10

hostname "CAB-A-HP5304xl-CORE-1"
max-vlans 16
module 3 type J4907A
module 1 type J4820A
module 2 type J4820A
module 4 type J4907A
interface C1
no lacp
exit
interface C2
no lacp
exit
trunk C1-C2 Trk1 Trunk

ip default-gateway 192.168.1.21
ip routing
vlan 1
name "DEFAULT_VLAN"
untagged A1-A24,B1-B24,C3-C12,D1-D16
ip address 192.168.1.67 255.255.255.0
ip address 192.168.2.1 255.255.255.0
ip address 192.168.4.1 255.255.255.0
ip address 192.168.5.1 255.255.255.0
tagged C13-C16,Trk1
exit
vlan 99
name "MANAGEMENT"
ip address 192.168.99.1 255.255.255.0
tagged C13-C16,Trk1
exit
xrrp
xrrp trap state-change
xrrp trap master-transition
xrrp trap authentication-failure
xrrp inf-failback
xrrp instance 1 1
xrrp instance 1 99
xrrp instance 2 1 ip 192.168.1.68 255.255.255.0
xrrp instance 2 1 ip 192.168.2.2 255.255.255.0
xrrp instance 2 1 ip 192.168.4.2 255.255.255.0
xrrp instance 2 1 ip 192.168.5.2 255.255.255.0
xrrp instance 2 99 ip 192.168.99.2 255.255.255.0
ip route 192.168.17.0 255.255.255.0 192.168.1.218
ip route 10.0.0.0 255.255.255.0 192.168.1.218
ip route 192.168.10.0 255.255.255.0 192.168.1.218
ip route 0.0.0.0 0.0.0.0 192.168.1.21
ip route 10.14.1.0 255.255.255.0 192.168.1.218
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree priority 0












Another switch unable use the MPLS:
; J4900B Configuration Editor; Created on release #H.10.74

hostname "CAB-E-2626-TOP"
ip default-gateway 192.168.99.1
vlan 1
name "DEFAULT_VLAN"
untagged 1-24
no ip address
tagged 25-26
exit
vlan 99
name "VLAN 99"
ip address 192.168.99.12 255.255.255.0
tagged 25-26
exit
spanning-tree
5 REPLIES
Pieter 't Hart
Honored Contributor
Solution

Re: routing problem

I havn't read the config's in detail but...
does the MPLS box function as a router ?
or is it transparent at Layer-2?

if it does routing and the other subnets are added later to an initial setup, then you may need your provider of the mpls-network to add routes for the new subnets.
Stefan Harrington-Palme
Occasional Visitor

Re: routing problem

That's a damn good point. I believe it routes. I'll look into that now.
Stefan Harrington-Palme
Occasional Visitor

Re: routing problem

That was it, I have spoken to BT and there was only a .1 route set up. Thanks! :)
Pieter 't Hart
Honored Contributor

Re: routing problem

glad to be able to give the right pointer.
thanks for the points.
Pieter
Stefan Harrington-Palme
Occasional Visitor

Re: routing problem

Routing for our additional subnets had not been set up. Problem had nothing to do with the switches.