Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

software update from PCM+ 1.6 to switches does not work

Stefan Wusowski
Frequent Advisor

software update from PCM+ 1.6 to switches does not work

Hello,i try to update the software from some switches but it doesn't work. I select the switches, then the scan for current state is starting but i get a time out error. The normal scan work. The management station is a authorized manager. Any Ideas? Logfile to look?

;-)
Thanks
9 REPLIES
Les Ligetfalvy
Esteemed Contributor

Re: software update from PCM+ 1.6 to switches does not work

I think the update uses up a telnet connection of which there are a limited number. Always make sure that you properly logoff from all telnet sessions before trying the update. If you have hung telnet sessions, you may need to kill them.

How many switches are there to update? I prefer to telnet to them and use the COPY TFTP command.
Mohamed Hamedi
Respected Contributor

Re: software update from PCM+ 1.6 to switches does not work

I would suggest you check the telnet password.
Try using the CLI wizard or the Config Manager, if that works then you can eliminate Telnet issue.

What device are you trying to update?
Stefan Wusowski
Frequent Advisor

Re: software update from PCM+ 1.6 to switches does not work

Hello, I try to update 2 x 53xx, 9x 26xx and one 25xx. You are right the CLI Wizard does also not work. The error message there is:
< 10.1.1.91=""> Failed>
CLI Timeout: CLI Timeout: Termination Prompt not found

This happend on all Switches. The Management Station is autorized. The username in Perference is empty only the passwort is set.

Do you meen kill the telnet session on PCM System?

Today I update the Software manually with COPY TFTP.
But I need a solution for this problem, more for the CLI Wizard then for the software update.

;-))
Thanks
Les Ligetfalvy
Esteemed Contributor

Re: software update from PCM+ 1.6 to switches does not work

Looks like the telnet creds are not setup correctly in PCM. Check your preferences if you don't have them set on each switch individually.

If it fails on all 12 switches, I doubt it is hung telnet sessions at all the switches. I only mentioned the hung sessions in case you were only testing on one or two switches and perhaps inadvertently left a telnet session without logging off. I know, because it happened to me. IIRC, the hung sessions will clear themselves given time.
Mohamed Hamedi
Respected Contributor

Re: software update from PCM+ 1.6 to switches does not work

Do all the devices have the same telnet password?

Try going to a specific device and manually setting the telnet password, leave the user blank blank.

Then quickly try the CLI wizard.
Stefan Wusowski
Frequent Advisor

Re: software update from PCM+ 1.6 to switches does not work

Hello,
yes the telnet password is on all switches the same. This problem is still happened after reboot the switches (powerless).

Is there a cmd to see telnet sessions and the status?

;-)
Stefan
Mohamed Hamedi
Respected Contributor

Re: software update from PCM+ 1.6 to switches does not work

Can you actually telnet to the device from CMD prompt?
Because all PCM does really is to call Telnet.exe.
Mohamed Hamedi
Respected Contributor

Re: software update from PCM+ 1.6 to switches does not work

Oh one more brain wave, make sure that the deafult telnet on the devie does NOT default to the menu.

So in other words make sure it is on command line.
Stefan Wusowski
Frequent Advisor

Re: software update from PCM+ 1.6 to switches does not work

Hello,
thanks to anyone who replies. Yes the problem was the "logon default". It must be "CLI" not "menu"

;-)
Stefan Wusowski