Switches, Hubs, and Modems
1748180 Members
3856 Online
108759 Solutions
New Discussion юеВ

Re: tagged VoIP VLAN: HP<=> Cisco

 
MullT
Frequent Advisor

tagged VoIP VLAN: HP<=> Cisco

Hi,

my setup will be as followed:

IP phones <==> HP 5400zl <==> HP 6200yl <==> Cisco 3550 <==> Cisco 3550 <==> VoIP-Server with its own DHCP-Server

Basically I want a tagged and priorized VLAN between all to pass the IP traffic between the VoIP-Server and the IP phones.


So, there┬┤s my default VLAN, well also part of my core network:


==HP 5400zl ==

vlan 1
name "DEFAULT_VLAN"
untagged A1-A20,
ip address 10.10.200.13 255.255.255.0
no untagged G1-G24
exit
vlan 300
name "VoIP"
qos priority 6
voice
no ip address
exit


== 6200yl ==

vlan 1
name "DEFAULT_VLAN"
untagged 1-7
ip address 10.10.200.2 255.255.255.0
no untagged 8,11-13
exit
vlan 300
name "VoIP"
qos priority 6
voice
no ip address
exit

== Cisco 3550 Nr. 1 ==

interface GigabitEthernet0/1 ##Uplink
switchport access vlan 200
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/2##Downlink
switchport access vlan 200
switchport mode access
spanning-tree portfast

interface Vlan200
ip address 10.10.200.4 255.255.255.0

== Cisco 3559 Nr. 2 ==

interface GigabitEthernet0/1 ##Uplink
switchport access vlan 200
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/2##Downlink
switchport access vlan 200
switchport mode access
spanning-tree portfast

interface Vlan200
ip address 10.10.200.5 255.255.255.0

interface Vlan300 #the new VoIP VLAN
ip address 10.10.30.230 255.255.252.0
ip helper-address 10.10.30.231#The IP address of the VoIP-Server with its own DHCP enabled



So, how can I make a working tagged 802.1Q VLAN between all switches?
7 REPLIES 7
MullT
Frequent Advisor

Re: tagged VoIP VLAN: HP<=> Cisco

For HP it├В┬┤s easy, just tag the port

vlan 300
name "VoIP"
qos priority 6
tagged 1
voice
no ip address
exit


But what about Cisco? I can├В┬┤t find any example with "default VLAN untagged" ports AND "tagged ports"
EckerA
Respected Contributor

Re: tagged VoIP VLAN: HP<=> Cisco

Hi,
i have never done it but try this:

interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 1 ##untagged vlan
switchport trunk allowed vlan 2,3,4 ## tagged vlan
switchport mode trunk

hth
alex
Pieter 't Hart
Honored Contributor

Re: tagged VoIP VLAN: HP<=> Cisco

Ecker is on the right track.
with HP you assign ports tagged or untaged to a vlan
with cisco you designate a port as untagged only :
- switchport mode access
- switchport access vlan )
or tagged aware specifying vlans
- switchport trunk encapsulation dot1q
- switchport trunk native vlan 1 ##untagged vlan
- switchport trunk allowed vlan 2,3,4 ## tagged vlan (default is alow all vlan's)
-switchport mode trunk ## this is the oposite from mode access

NB! Cisco's trunk means "vlan aware" while HP's trunk is etherchannel.
MullT
Frequent Advisor

Re: tagged VoIP VLAN: HP<=> Cisco

Hi,

thanks for your information.
Now it looks as followed:

interface GigabitEthernet0/1
switchport access vlan 1
switchport trunk encapsulation dot1q
switchport trunk native vlan 1
switchport trunk allowed vlan 3
switchport mode access
speed nonegotiate
spanning-tree portfast


You probably see the "switchport mode access". Without it I lost connection.
My first attempt was with "switchport mode trunk". I do not know whether it will work. Seems I have to put a DHCP server providing IPs for the tagged VLANs.







Pieter 't Hart
Honored Contributor

Re: tagged VoIP VLAN: HP<=> Cisco

Hello,
its one at a time, not both
switchport mode access | trunk

so either an access port (no vlans):
switchport access vlan 1
switchport mode access
spanning-tree portfast

or a vlan-trunk port:
switchport trunk encapsulation dot1q
switchport trunk native vlan 1
switchport trunk allowed vlan 3
switchport mode trunk

- if you configure "mode access" then "mode trunk" is removed; the other three "trunk" lines will be ignored and better be removed too, to keep the config clear.
- portfast does not work on vlan-trunkports, instead you may try uplinkfast

Cisco wants to negotioate a trunkport with the other switch
maybe you need an extra line
- switchport nonegotiate
to put the port in vlan-trunking mode to the HP-switch

you better not use "speed nonegotioate" on its own, better set speed and duplex
If both ports are gigabit, my experience is to better leave it to "auto".

resulting in :
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 1
switchport trunk allowed vlan 3
switchport mode trunk
switchport nonegotiate



MullT
Frequent Advisor

Re: tagged VoIP VLAN: HP<=> Cisco

Hi,

I just tried:

interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 1
switchport trunk allowed vlan 3
switchport mode trunk
switchport nonegotiate


I still loose connection to the next switch which is behind interface GigabitEthernet0/1 and which belongs (here in this posting/example) to vlan 1

When I remove "switchport trunk allowed vlan 3", I can ping it afterwards. When I enter afterwards "switchport trunk allowed vlan 3" I loose connection.

Something is really going wrong



Pieter 't Hart
Honored Contributor

Re: tagged VoIP VLAN: HP<=> Cisco

it's a list, not addition
so
change : switchport trunk allowed vlan 3
to : switchport trunk allowed vlan 1,3
else the native vlan (1) is not passed.

Pieter