Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

tagging kicking me in the head

Sean201
Occasional Contributor

tagging kicking me in the head

I have two switches (5412zl and a 5406zl). One is in a DC and the other is in our office. There are multiple VLANs on each but they are the same name and VID. Only one VLAN has an IP assigned to it.

 

My problem is each vlan has a series of ports assigned to them (they are port based VLANs) as untagged. I have a private LAN-E running between them connecting them. I have added the ports it is connected to as untagged ports to one VLAN and then added the same ports to the other VLANs as a tagged port but I am not getting communications across the link.

 

The untagged ports this LAN-E is on is in the Primary VLAN. I don't have a management VLAN configured.

 

Everything I've read says it shoudl work but it doesn't so far. Is there another setting I should be looking at or enabling to get this to work?

1 REPLY
showneek
Respected Contributor

Re: tagging kicking me in the head

Hi, not sure if I fully understand what you mean about private LAN-E running between switches.

 

But generally, if you want L2 communication in certain VLAN(s) between these switches, just assign on both switches client/access ports as untagged in this VLAN(s) and uplink/interconnect ports as tagged members of this VLAN(s) (in one VLAN the uplink ports can be untagged)... and the communication within the VLAN(s) has to work.

 

If you want communication between VLANs you have to assign ip addresses on these VLANs on one of them switches and enable ip routing in global configuration context.

 

If you want to have dedicated VLAN between switches, in other words you want to create L3 link. You have to assign interconnect ports only to this VLAN as tagged or untagged and on both switches you have to assign ip addresses to this VLAN (in the same subnet), different IP address ranges on both switches for all others VLANs, enable ip routing and configure RIP/OSPF/static routing to route between these two switches.

 

So hope this will help you. If not, maybe attache some picture of what you want to achieve and output of your configs too.

 

Regards

Jan