Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

trauble config vlan HP9304

Alexey Klochko
Occasional Visitor

trauble config vlan HP9304

Dear colleagues,
I`m trying to built VLAN for our company using following equipment:
1. HP9304
2. HP2650
3. HP4108
HP2650 (port 50) works into port 4/8 (192.168.11.1) hp9304

HP4108 (A1) works into port 3/1 (192.168.4.1) hp9304

I can`t made the following VLAN configuration :


Port 31,32 HP2650 and ports B1 -B3 hp4108 should belonge to one IP net (80.250.66.16 mask 255.255.255.248)

I`m asking for your help.

Awaiting for your replay,
With best regards,
Alexey
9 REPLIES
Ron Kinner
Honored Contributor

Re: trauble config vlan HP9304

Create VLAN2 on each device.

Place 31, 32 into VLAN2 untagged
Place B1 - B3 into VLAN2 untagged.

Place 50, 4/8, 3/1 into VLAN 2 tagged. Place same ports into VLAN1 untagged. Make sure you are using 802.1q tagging.

All the rest of the ports should be in VLAN1 (the default) untagged.

Assign an IP in the range 80.250.66.16 255.255.255.248 to VLAN2 on the 9304. I assume this one is doing some routing so you will need to tell all of the devices in VLAN2 that the default route should point to the IP address you assign on the 9304.

If you need help with the commands let me know and I will look them up for you.

Ron
Arnaud_9
Valued Contributor

Re: trauble config vlan HP9304

Hello,

Note you may need to use the "dual mode" for have both tagged VLAN 2 and untagged default-VLAN on the same port on your 9304. (OS version 07.5.04 or later)
Look at page 53 :
ftp://ftp.hp.com/pub/networking/software/59903041_ch07.pdf

I think it is not good idea to mix IP address on physical port, and on a virtual interface.
(I am not sure that it can work on the same port on HP routing switch).
For me it is better to remove ip address on both physical interfaces, and create a virtual interface in the default vlan, then assign previous IP addresses on this ve.

I think you should get something like this :
interface e 3/1
dual-mode
interface e 4/8
dual-mode
vlan 1
untagged ethe 3/1 ethe 4/8 ...
router-interface ve 1
vlan 2
tagged ethe 3/1 ethe 4/8 ...
router-interface ve 2
interface ve 1
ip address 192.168.11.1 255.255.255.0
ip address 192.168.4.1 255.255.255.0
interface ve 2
ip address 80.250.66.XX 255.255.255.248

Hope this will help you.
Arnaud
Alexey Klochko
Occasional Visitor

Re: trauble config vlan HP9304

Dear Arnaud,
thank you for the prompt replay. I`d like to ask you to clarify some details.
My configuration is following:
Each interface is specifyed it`s own ip net. Also parament "UDP helper" is defined.
Will UDP helper work with "virtual interfaces"?

Thank you in advance,
Best regards, Alexey Klochko


--------------------------------------------------------------------------------------------
ver 07.6.01bT53
!
module 1 8-port-gig-copper-module
module 3 8-port-gig-copper-module
module 4 8-port-gig-m4-management-module
!
!
!
netbios-proto
!
enable telnet password 8 ....
enable super-user-password 8 .....
enable read-only-password 8 .....
ip directed-broadcast
ip dns domain-name vester.ru
ip dns server-address 192.168.4.35 192.168.4.33
ip route 0.0.0.0 0.0.0.0 192.168.4.35
!
ip router-id 192.168.1.1
logging 192.168.9.2
telnet timeout 5
username xxxxxx password 8 ......
password-change any
cdp run
snmp-server community 0 public ro
snmp-server community 0 xxxxxxx rw
snmp-server contact 353979, 353738
snmp-server location room 414
snmp-server host 192.168.9.2 1 .....
clock summer-time
clock timezone gmt GMT+02
sntp server 192.168.4.33 3
sntp server 192.168.4.35 3
sntp poll-interval 720
snmp-client 192.168.9.2
web client 192.168.9.2
web client 192.168.11.20
!
interface ethernet 1/1
ip address 192.168.5.1 255.255.255.0
!
interface ethernet 1/2
ip address 192.168.6.1 255.255.255.0
!
interface ethernet 1/3
ip address 192.168.7.1 255.255.255.0
!
interface ethernet 1/4
ip address 192.168.8.1 255.255.255.0
!
interface ethernet 1/5
ip address 192.168.9.1 255.255.255.0
!
interface ethernet 1/6
ip address 192.168.10.1 255.255.255.0
!
interface ethernet 3/1
ip address 192.168.4.1 255.255.255.0
!
interface ethernet 3/2
ip address 192.168.3.1 255.255.255.0
ip helper-address 1 192.168.4.35
!
interface ethernet 3/3
ip address 192.168.2.1 255.255.255.0
ip helper-address 1 192.168.4.35
!
interface ethernet 3/4
ip address 192.168.1.1 255.255.255.0
ip helper-address 1 192.168.4.35
!
interface ethernet 4/4
ip address 192.168.16.1 255.255.255.0
ip helper-address 1 192.168.4.35
!
interface ethernet 4/5
ip address 192.168.15.1 255.255.255.0
ip helper-address 1 192.168.4.35
!
interface ethernet 4/6
ip address 192.168.14.1 255.255.255.0
ip helper-address 1 192.168.4.35
!
interface ethernet 4/7
ip address 192.168.12.1 255.255.255.0
ip helper-address 1 192.168.4.35
!
interface ethernet 4/8
port-name Tcenter
ip address 192.168.11.1 255.255.255.0
ip helper-address 1 192.168.4.35
!
!
!
!
!
end
--------------------------------------------------------------------------------------------
Arnaud_9
Valued Contributor

Re: trauble config vlan HP9304

Sorry for my previous answer, I didn't understand what you wanted to do.

So Yes, UDP helper will work on virtual interfaces.
(Standard IP parameters should works like on physical interfaces)

In your config, without "route-only" command, the 9304 should switch all non-IP packet.
Do need switch IPX, Appletalk, or other protocol ?
I hope the answer is No (If yes it is more complicated, and more informations are needed).

If I were you, I first make sure if the 9304 support both virtual and physical interfaces Globally. If you have an unused port, try this :
#conf t
#vlan 100
#untag eth [unused_port]
#router-interface ve 100
#int ve 100
#ip address [non_used_subnet].1

then try to connect a PC with an IP [non_used_subnet].10 & GW .1, and check if you can get other networks.

I hope it is allright. If it don't work, you will have to move all IP addresses to
virtual interfaces in one time.

You can use VLAN ID 101 for network 192.168.1.x, 102 for network 192.168.2.x, and so on.
This allow you to keep the segment number, and to keep the default VLAN on the ID 1.
If you need to convert other physical segments into VLAN, you will keep a good VLAN numbering.
VLAN 2 can be used for the 80.250.66.16/255.255.255.248.

The config should be something like :
vlan 2
tagged ethe 3/1 ethe 4/8
router-interface ve 2
vlan 104
tagged ethe 3/1
router-interface ve 101
vlan 111
tagged ethe 4/8
router-interface ve 111
interface ve 2
ip address 80.250.66.XX 255.255.255.248
interface ve 104
ip address 192.168.4.1 255.255.255.0
interface ve 111
port-name Tcenter
ip address 192.168.11.1 255.255.255.0
ip helper-address 1 192.168.4.35

Note that ports 3/1 and 4/8 have to be tagged on both VLAN, on the 9304's port, and on remote switches, because the Dual-mode can only to untag the One Default VLAN.

Goog Luck,
Please, let know how if works or fail.
Alexey Klochko
Occasional Visitor

Re: trauble config vlan HP9304

Hi Arnaud
You wrote:
....then try to connect a PC with an IP [non_used_subnet].10 & GW .1, and check if you can get other networks.

This don't work.


If i move all et ports ( to virtual interfaces), then ip helper include all this ports (e 1/1 to e 4/8) in one IP subnet.

Can i give different network on everyone ethernet ports?

Sincerelly, Alexey
Arnaud_9
Valued Contributor

Re: trauble config vlan HP9304

Hello Alexey,

You said the test doesn't work : There was an error when you entered one config command ?
or the PC cannot ping other Networks ?
I would like to be sure we are talking about the same test : Please Look at the joined pdf, on top [I have problems with visio's jpg filter].
If it really doesn't work, you must look for a full VLAN config, and no ip address on physical ports.

Your question :
>If i move all et ports ( to virtual interfaces), then ip helper include all this ports (e 1/1 to e 4/8) in one IP subnet.

Yes, if you put all eth port in the same VLAN and one virtual interface, the ip helper should include all port in the same IP subnet, but you don't have to do that.

At this time, you have some physical networks (broadcast domains), and a router which have one physical interface in each networks.
If you move to a VLAN and Virtual interfaces architecture, you will have one VLAN for each broadcast domain, and one virtual interface in each VLAN, to act has the physical interface of a router.
So you will have different network on every ethernet port, has you have now.

Your architecture should look like the joined pdf (bottom) "VLANs and Virtual Interfaces architecture"
In the config, you should have for each of your networks, (except for network 192.168.4.0, 192.168.11.0 and 80.250.66.16 : for them you can use my previous sample config - June 26, 2003 15:45) :

vlan 1xx
untag eth x
router-interface ve 1xx

interface ve 1xx
ip address 192.168.x.1 255.255.255.0
ip helper 1 xxxxx


Arnaud
Arnaud_9
Valued Contributor

Re: trauble config vlan HP9304

I have just see again your first graph : Do you need the 9304 to have an IP address in the network 80.250.66.x ?
If not, you shouldn't have to change a lot of things. Try a config like, from the config you post :

interface e 3/1
dual-mode
interface e 4/8
dual-mode
vlan 2
tagged ethe 3/1 ethe 4/8

then, on your 2650 and 4108 :
* 2650 :
vlan 2
tag 50
untag 31-32

*4108 :
vlan 2
tag A1
untag B1-B3


and everthing should work.

Arnaud
Alexey Klochko
Occasional Visitor

Re: trauble config vlan HP9304

Hello Arnaud
(sorry for my bad English)
You wrote...
>I have just see again your first graph : Do >you need the 9304 to have an IP address in >the network 80.250.66.x ?

Hp9304 not need network 80.250.66.x

>If not, you shouldn't have to change a lot of >things. Try a config like, from the config >you post :

telnet@HP9304(config)#int e 3/1
telnet@HP9304(config-if-e1000-3/1)#dual-mode
error - cannot set untagged port 3/1 to dual mode



telnet@HP9304(config)#vlan 2
telnet@HP9304(config-vlan-2)#tagged e 3/1
error - IP routing was configured on ports 3/1

Config other devices (4108 and 2650) - i don't made (while hp9304 not configured)



Alexey
Arnaud_9
Valued Contributor

Re: trauble config vlan HP9304

Now, there is no doubts, You have to move all the config to VLANs and Virtuals Interfaces.

I was wrong with my last statement.

Look at my sample config on June 26, 2003 15:45 message, try to make it for your needs.

You also have official HP samples configs here :
http://www.hp.com/rnd/support/config_examples/portbase.pdf

Arnaud.