Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

troubles with cisco catalyst 2950 and broadcom netxtreme gigabit

Jesús_2
Occasional Visitor

troubles with cisco catalyst 2950 and broadcom netxtreme gigabit

Hi!
I have several pc's and those that has a Broadcom NetXtreme Gigabit NIC don't connect to lan across a Cisco Catalyst 2950 Swicht.
If I make any change in the configuration, like netcard speed or IP adress, the card makes a reconnectiona and begins to work.
When I reboot the pc, tha matter appears again.
I've heared that there's some Cisco devices that have any trouble with broadcom netcards.
Is there anybody who nows something about it.
Thanks!
2 REPLIES
SCOOTER
Esteemed Contributor

Re: troubles with cisco catalyst 2950 and broadcom netxtreme gigabit

Ola,

Have you called Cisco support, and what do they say?
To me it sounds that there is no problem with the Cisco but with your PC. When it reboots it takes the old or default values again and then you need to set them manually. Waht speed is the cisco set to and what speed is the 'Nic set to by default when it does not work and what speeddo you set it to when it works?

Regards,

SCOOTER
kbyrd0
Occasional Visitor

Re: troubles with cisco catalyst 2950 and broadcom netxtreme gigabit

Make sure both the 2950 switchport and the server are set to autonegotiate - assuming you are plugged into one of the 10/100 ports and not one of the GigE uplink ports. Alternatively, you should hardcode both speed and duplex on both the 2950 switchport and the NIC driver. If for some reason the server's NIC "forgets" it's setting, it sounds like a driver update from Broadcom would fix that bug.