Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

trying to set up NAT/DHCP server

SOLVED
Go to solution
Tanaka Mushi
Occasional Visitor

trying to set up NAT/DHCP server

A satellite-based ethernet connection goes in eth 0/2 and is used by my field station with unmanaged switches connecting to eth 0/1. the procurve 7102dl is supposed to act as the router, dhcp server, and NAT for the one incoming connection so everyone can use it.

I've got the outside connection set up, the dhcp server working, but i don't understand how to link the two ports (and have http traffic flow from the network to the outside world and back). Looks like a firewall or routing issue, but i can't figure out the right settings. Help? Config attached, many thanks!
6 REPLIES
Matt Hobbs
Honored Contributor

Re: trying to set up NAT/DHCP server

Double check your default route, I'd expect it to be the next hop IP address. Currently it looks to be the same as your eth 0/2 ip address.
Tanaka Mushi
Occasional Visitor

Re: trying to set up NAT/DHCP server

Sorry, does 'next hop' mean something before eth 0/2 for outgoing traffic?

ip route 0.0.0.0 0.0.0.0 X.X.182.40 20

Many thanks for your rapid reply!
Matt Hobbs
Honored Contributor
Solution

Re: trying to set up NAT/DHCP server

I'd expect it to be something like:

ip route 0.0.0.0 0.0.0.0 X.X.182.41 20

You should check with your ISP.
Tanaka Mushi
Occasional Visitor

Re: trying to set up NAT/DHCP server

had a halfway success with:
ip route 0.0.0.0 0.0.0.0 X.X.182.33 20

the "halfway" part is traceroutes to external ip addresses now work, but domain names do not resolve - added the ISPs DNS servers, added local DNS servers... no luck. is there a trick to that too?
Matt Hobbs
Honored Contributor

Re: trying to set up NAT/DHCP server

What I have in my config is:

ip domain-proxy
ip domain-name "whatever.com"
ip name-server

I then have my clients set to use the 7102dl as their DNS server and it works well.

If you're not having luck, maybe try some of the debugging options:

ProCurveSR7102dl#debug ip dns-proxy
ProCurveSR7102dl#debug ip dns-client

Tanaka Mushi
Occasional Visitor

Re: trying to set up NAT/DHCP server

sorry for the long delay here - I figured it was time to figure things out so I read the basic config manual in detail.

i think a number of things solved the problem:
1. correct route as suggested
2. dns server info in the right places (i put external dns server info in the dhcp config area and that really did the trick) - putting dns info in just the regular config area did not help.
3. correct firewall config - the wizard did just fine.

i've attached my final config for the perusal of others - thanks again to matt for the help!