Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

vlan trunk

SOLVED
Go to solution
clarkma
Occasional Visitor

vlan trunk

I have to configure a network with a hp2650 and cisco 4506
fiber optics conneted(4506 gi3/1 to hp 2650 port 49)
I am trying the right configuration to be able to configure the vlan and trunk?
share vlan17 ,18,19 in two device

This is show run in 2650
hostname "ProCurve Switch 2650"
ip default-gateway 192.168.12.254
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 37-48,50
ip address 192.168.12.253 255.255.255.0
no untagged 1-36
tagged 49
exit
vlan 17
name "vlan17"
untagged 1-12

tagged 49
exit
vlan 18
name "vlan18"
untagged 13-22

tagged 49
exit
vlan 19
name "vlan19"
untagged 23-36

tagged 49
exit


4506 show run
R4506#show run
Building configuration...

Current configuration : 6313 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service compress-config
!
hostname R4506
!
boot-start-marker
boot-end-marker
!
enable password 7 0822455D0A16
!
no aaa new-model
ip subnet-zero
no ip domain-lookup


ip dhcp pool vlan17
network 192.168.17.0 255.255.255.0
default-router 192.168.17.254
dns-server 61.177.7.1
!
ip dhcp pool vlan19
network 192.168.19.0 255.255.255.0
default-router 192.168.19.254
dns-server 61.177.7.1
!
ip dhcp pool vlan18
network 192.168.18.0 255.255.255.0
default-router 192.168.18.254
dns-server 61.177.7.1
!
ip dhcp-server 192.168.10.100

no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
power redundancy-mode redundant
!
!
!
vlan internal allocation policy ascending
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface GigabitEthernet3/1
switchport trunk encapsulation dot1q
switchport mode trunk

interface Vlan18
ip address 192.168.18.254 255.255.255.0
!
interface Vlan19
ip address 192.168.19.254 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.10.1
ip http server



Thanks

9 REPLIES
cenk sasmaztin
Honored Contributor

Re: vlan trunk

hi Clarkma
very succesfully config each switch for vlan trunk
what is your problem?
cenk

clarkma
Occasional Visitor

Re: vlan trunk

Hi
my problem is on cisco 4506
ping 192.168.12.253(HP 2650 manegement) is time out

R4506#show run
Building configuration...

Current configuration : 7038 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service compress-config
!
hostname R4506
!
boot-start-marker
boot-end-marker
!
enable password 7 0822455D0A16
!
no aaa new-model
ip subnet-zero
no ip domain-lookup
!
ip dhcp pool vlan12
network 192.168.12.0 255.255.255.0
default-router 192.168.12.254
dns-server 61.177.7.1
lease 7
!

!
ip dhcp pool vlan11
network 192.168.11.0 255.255.255.0
default-router 192.168.11.254
dns-server 192.168.10.200
!
ip dhcp pool vlan16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.254
dns-server 61.177.7.1
!
ip dhcp pool vlan17
network 192.168.17.0 255.255.255.0
default-router 192.168.17.254
dns-server 61.177.7.1
!
ip dhcp pool vlan19
network 192.168.19.0 255.255.255.0
default-router 192.168.19.254
dns-server 61.177.7.1
!
ip dhcp pool vlan18
network 192.168.18.0 255.255.255.0
default-router 192.168.18.254
dns-server 61.177.7.1
!
ip dhcp-server 192.168.10.200
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
power redundancy-mode redundant
!
!
!
vlan internal allocation policy ascending
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface GigabitEthernet3/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet3/2
switchport access vlan 13
switchport mode access
!
interface GigabitEthernet3/3

interface GigabitEthernet3/4
!
interface GigabitEthernet3/5
!
interface GigabitEthernet3/6
!
interface GigabitEthernet5/1
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet5/2
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet5/3
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet5/4
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet5/5
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet5/6
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet5/7
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet5/8
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet5/9
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet5/10
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet5/11
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet5/12
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet5/13
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet5/14
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet5/15
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet5/16
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet5/17
description INTERNET
switchport mode access
speed 100
duplex full
!
interface GigabitEthernet5/18
description INTERNET
switchport access vlan 12
switchport mode access
!
interface GigabitEthernet5/19
description INTERNET
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet5/20
description INTERNET
switchport access vlan 18
switchport mode access
!
interface GigabitEthernet5/21

!
interface GigabitEthernet5/22
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet5/23

interface GigabitEthernet5/24
switchport access vlan 10
switchport mode access
!
interface Vlan1
ip address 192.168.100.254 255.255.255.0
!
interface Vlan10
ip address 192.168.10.254 255.255.255.0
!

interface Vlan12
ip address 192.168.12.254 255.255.255.0
!
interface Vlan13
ip address 192.168.13.254 255.255.255.0
!
interface Vlan14
ip address 192.168.14.254 255.255.255.0
ip access-group 114 in
!

interface Vlan17
ip address 192.168.17.254 255.255.255.0
!
interface Vlan18
ip address 192.168.18.254 255.255.255.0
!
interface Vlan19
ip address 192.168.19.254 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.10.1
ip http server



and for ping
R4506# ping 192.168.12.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.12.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms


R4506#ping 192.168.12.253

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.12.253, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)


GigabitEthernet3/1 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet Port, address is 0019.e8dc.a93a (bia 0019.e8dc.a9
3a)
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseSX
input flow-control is off, output flow-control is off
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 3000 bits/sec, 6 packets/sec
219366451 packets input, 225825860193 bytes, 0 no buffer
Received 54690 broadcasts (50399 multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
109350918 packets output, 7672967219 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out




i don't know how to config who can help
thanks
cenk sasmaztin
Honored Contributor

Re: vlan trunk

hi please test for me

vlan 1
name "DEFAULT_VLAN"
untagged 37-48,50
ip address 192.168.12.253 255.255.255.0
no untagged 1-36
tagged 49******************
exit


2650(config)#vlan 1
2650config-vlan1)#untag 49

vlan 1
name "DEFAULT_VLAN"
untagged 37-48,49,50***********
ip address 192.168.12.253 255.255.255.0
no untagged 1-36
exit

after retest ping

cenk
cenk

clarkma
Occasional Visitor

Re: vlan trunk

It seems not worked

here is my show run

hostname "ProCurve Switch 2650"
ip default-gateway 192.168.12.254
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-48,50
ip address 192.168.12.253 255.255.255.0
tagged 49
exit

ProCurve Switch 2650(config)# ping 192.168.12.254
Target did not respond.
cenk sasmaztin
Honored Contributor

Re: vlan trunk

hi Clarkma

interface 49 on procurve must be vlan 1 untag member


config(vlan1)#untagged 49 enter.....


cenk
cenk

cenk sasmaztin
Honored Contributor

Re: vlan trunk

hi
cisco switch vlan 1 network address 192.168.10.0
procurve switch vlan 1 ip address must be same network

for example:192.168.100.253/24

please look be carefully below config and make test

cisco switch vlan config

interface Vlan1
ip address 192.168.100.254 255.255.255.0
!
interface Vlan10
ip address 192.168.10.254 255.255.255.0
!

interface Vlan12
ip address 192.168.12.254 255.255.255.0
!
interface Vlan13
ip address 192.168.13.254 255.255.255.0
!
interface Vlan14
ip address 192.168.14.254 255.255.255.0
ip access-group 114 in
!

interface Vlan17
ip address 192.168.17.254 255.255.255.0
!
interface Vlan18
ip address 192.168.18.254 255.255.255.0
!
interface Vlan19
ip address 192.168.19.254 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.10.1

cisco uplink port to procurve switch
interface GigabitEthernet3/1
switchport trunk encapsulation dot1q
switchport mode trunk
!

*****************************************

procurve vlan config

vlan 1
name "DEFAULT_VLAN"
untagged 37-48,49,50
ip address 192.168.100.253 255.255.255.0
no untagged 1-36
exit

vlan 17
name "vlan17"
untagged 1-12
tagged 49
exit

vlan 18
name "vlan18"
untagged 13-22
tagged 49
exit

vlan 19
name "vlan19"
untagged 23-36
tagged 49
exit

int 49 procurve uplink port to cisco switch
********************************************



cenk

cenk sasmaztin
Honored Contributor

Re: vlan trunk

soryy alittle correction
************************

hi
cisco switch vlan 1 network address 192.168.100.0*****
procurve switch vlan 1 ip address must be same network

for example:192.168.100.253/24

please look be carefully below config and make test

cisco switch vlan config

interface Vlan1
ip address 192.168.100.254 255.255.255.0
!
interface Vlan10
ip address 192.168.10.254 255.255.255.0
!

interface Vlan12
ip address 192.168.12.254 255.255.255.0
!
interface Vlan13
ip address 192.168.13.254 255.255.255.0
!
interface Vlan14
ip address 192.168.14.254 255.255.255.0
ip access-group 114 in
!

interface Vlan17
ip address 192.168.17.254 255.255.255.0
!
interface Vlan18
ip address 192.168.18.254 255.255.255.0
!
interface Vlan19
ip address 192.168.19.254 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.10.1

cisco uplink port to procurve switch
interface GigabitEthernet3/1
switchport trunk encapsulation dot1q
switchport mode trunk
!

*****************************************

procurve vlan config

vlan 1
name "DEFAULT_VLAN"
untagged 37-48,49,50
ip address 192.168.100.253 255.255.255.0
no untagged 1-36
exit

vlan 17
name "vlan17"
untagged 1-12
tagged 49
exit

vlan 18
name "vlan18"
untagged 13-22
tagged 49
exit

vlan 19
name "vlan19"
untagged 23-36
tagged 49
exit
cenk

clarkma
Occasional Visitor

Re: vlan trunk

Now it works

the some French people remote config
This is show run

hostname "ProCurve Switch 2650"
ip default-gateway 192.168.100.254
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 37-48
tagged 49
ip address 192.168.100.253 255.255.255.0
no untagged 1-36
exit
vlan 17
name "vlan17"
untagged 1-12
ip address 192.168.17.254 255.255.255.0
tagged 49
exit
vlan 18
name "vlan18"
untagged 13-22
ip address 192.168.18.254 255.255.255.0
tagged 49
exit
vlan 19
name "vlan19"
untagged 23-36
ip address 192.168.19.254 255.255.255.0
tagged 49
exit

gvrp



I think gvrp is key command in this issue
cenk sasmaztin
Honored Contributor
Solution

Re: vlan trunk

hi Clarkma
noting gvrp key command
gvrp command for dynamic vlan on switch
gvrp command unnecessary this configuration

you omit test my config

my config desciribe int 49 vlan 1 untag member on procurve switch

please read this guide very ideal for you

http://www.tecnocael.it/ftp/docs/ProCurve_Cisco.pdf
cenk