Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

vlans and static routes 2610

aaronneedshelp
Occasional Visitor

vlans and static routes 2610

Hello There,

i am trying to create 2 vlans(one for data and one for voice) on a hp 2610 switch so both networks can access the internet. i am using a snapgear SG310 router for internet access. i so far have the following config:

Startup configuration:

; J9086A Configuration Editor; Created on release #R.11.25

hostname "ProCurve Switch 2610-24/12PWR"
ip default-gateway 192.168.50.1
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-12,25-28
ip address 192.168.50.90 255.255.255.0
no untagged 13-24
exit
vlan 2
name "Voice"
untagged 13-24
ip address 192.168.0.10 255.255.255.0
exit

data network is 192.168.50.0/24
voice network is on 192.168.0.0/24
internet router is 192.168.50.1/24

i just want to be able to ping 192.168.50.1 from any ip address in the 192.168.0.0/24 range

i have created static routes within the router, but just cant seem to ping 192.168.50.1.

ip route 192.168.0.0/24 192.168.50.1, this one didnt work so i tried
ip route 192.168.0.0/24 192.168.50.90, but still no luck.

thank you for you time.
Aaron
4 REPLIES
Mark Wibaux
Trusted Contributor

Re: vlans and static routes 2610

What gateway do you have your devices on the 192.168.0.0 network set to? They should be set to 192.168.0.10.

On the switch you will also have to set a default route (default-gateway is not the same thing).

ip route 0.0.0.0 0.0.0.0 192.168.50.1

Your router will need only a route for the 192.168.0.0 network and this will be
ip route 192.168.0.0/24 192.168.50.90
which tells it to get to the voice network via the HP switch.

The other things to check is does you router allow pings to its IP address. Can you ping it from the switch?
aaronneedshelp
Occasional Visitor

Re: vlans and static routes 2610

yep, all devices on 192.168.0.0/24 have GW 192.168.0.10

i added the static route of 0.0.0.0 0.0.0.0 192.168.50.1 into my hp switch

added static route in router 192.168.0.0/24 192.168.90.50

for some reason i still cant ping between networks.I can ping 192.168.50.90. but cant ping any other ip address on the 192.168.50.90 network.
Shadow13
Respected Contributor

Re: vlans and static routes 2610

can you ping the devices on the other vlan ont the switch ??

if yes, if the pinging is down between one client on once vlan to a client on the other vlan then it's a router configuration issue.


Then what configuration did you do on the router, did you make sub-interfaces for each vlan on the router ?
try to configure sub-interfaces on the router for each vlan and assing ip address to these interfaces from the vlans, then make sure that these ip addresses are the default gatways for these vlans.
Mark Wibaux
Trusted Contributor

Re: vlans and static routes 2610

As you now have a default route in your switch, set a device on your data network to have a default gateway of the switch (192.168.50.90). This will eliminate your router from the equation. Now try ping from the voice network to the device you changed the gateway on (and also the other way round).
If this works then you have a problem with your router and need to investigate its configuration OR bypass the router all together and set all your devices to use the switch as the default gateway.