Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

what to add in Guest Internet to access the network?

SOLVED
Go to solution
jwc1972
Advisor

what to add in Guest Internet to access the network?

hello All

I have been asked to set up a Guest Internet access for Visiter
No logs for the netgear, It must be the switch, on the Vlan for guest vlan 172.16.8.1 /25 This set manually. So i take it you need to use an ip address 172.16.8.1./25 In that Range for port 41-47. Is that correct? So i used 172.16.8.10 /25 for the AP Then enable dchp on the AP.

Lan | DHCP/Bootp 192.168.1.221 255.255.255.0 No
Voip | Manual 192.168.42.1 255.255.255.0 No
Up Lan | Manual 10.22.30.1 255.255.255.0 No
Guest Internet | Manual 172.16.8.1 255.255.255.128 No

ip routing
vlan 1
name "Lan"
untagged 1-12
ip address dhcp-bootp
tagged 48
no untagged 13-47
exit
vlan 100
name "Guest Internet"
untagged 37-47
ip address 172.16.8.1 255.255.255.128
tagged 48
exit
vlan 20
name "Voip"
untagged 13-24
ip address 192.168.42.1 255.255.255.0
exit
vlan 30
name "up Lan"
untagged 25-36
ip address 10.22.30.1 255.255.255.0
exit
interface 40
monitor
exit

Do i need to add anything in the Guest Internet to access the network? Port 1-12 All seem to work nicely. I enable Ip routing at the begining of the config

6 REPLIES
Pieter 't Hart
Honored Contributor
Solution

Re: what to add in Guest Internet to access the network?

the dhcp-scope must specify 172.16.8.1 as the default-gateway to the guest clients.

- each vlan on the switch has an ip adress
- ip routing is enabled

but you miss a "route 0.0.0.0 0.0.0.0 " statement on the switch

clients in the guest vlans should be able to reach your other hosts on the local vlans (if they also point to the switch as default-gateway).
jwc1972
Advisor

Re: what to add in Guest Internet to access the network?

Hello Peter

Cheers for replying. That a bit over my head

so I need to insert

vlan 100
name "Guest Internet"
untagged 37-47
ip address 172.16.8.1 255.255.255.128
route 0.0.0.0 0.0.0.0 192.168.1.1(that our gateway to the outside world)
tagged 48
exit
Pieter 't Hart
Honored Contributor

Re: what to add in Guest Internet to access the network?

Hi there,
no this :
>>>
vlan 100
name "Guest Internet"
untagged 37-47
ip address 172.16.8.1 255.255.255.128
route 0.0.0.0 0.0.0.0 192.168.1.1(that our gateway to the outside world)
tagged 48
exit
<<<
is not correct

the route statement must lay outside the vlan config
>>>
vlan 100
name "Guest Internet"
untagged 37-47
ip address 172.16.8.1 255.255.255.128
tagged 48
exit
route 0.0.0.0 0.0.0.0 192.168.1.1
<<<

By the way the switch has no ip-adress in the same subnet (192.168.1.x) !!!!!!
so the switch cannot reach this router.
(or there must be another router in the path to 192.168.1.1)
=> add an address (probably on vlan-1?) like 192.168.1.2 to the switch


furthermore the dhcp-server supplies to it's clients
- ip-adress
- subnetmask (possibly this is 255.255.255.0 ?)
- default-gateway
- dns-servers
(- maybe some other options also)
in this dhcp config for this subnet you must specify 172.16.8.1 as default gateway.

So if the client wants to connect an adress outsude the 172.16.8.1-172.168.8.254 range, packets will be sent to the switch
and the switch forwards this to it's own default gateway wich is 192.168.1.1.

NB this router must know that packets with destination the guest vlan is reachable using the switch (192.168.1.2 as above added)
so add on the router
"route 172.16.8.0 255.255.255.128 192.168.1.2"
jwc1972
Advisor

Re: what to add in Guest Internet to access the network?

Hi Pieter

Sorry to bother you again, Before i Crash the switch this is the full config I have.
On vlan one i add the switch mac address to our windows server 2003 dchp server, what disp out our ip address in the 192.168.1.* range
Running configuration:

; J9147A Configuration Editor; Created on release #W.14.38

hostname "Switchoffice"
module 1 type J9147A
mirror-port 1
ip routing
vlan 1
name "Default Lan"
untagged 1-12
ip address dhcp-bootp
tagged 48
no untagged 13-47
exit
vlan 100
name "Guest Internet"
untagged 37-47
ip address 172.16.8.1 255.255.255.128
tagged 48
exit
vlan 20
name "Voip"
untagged 13-24
ip address 192.168.42.1 255.255.255.0
exit
vlan 30
name "UP Lan"
untagged 25-36
ip address 10.22.30.1 255.255.255.0
exit
interface 40
monitor
exit
banner motd "This is a private system maintained by the Corporation"
snmp-server community "public" unrestricted

Does it matter where i insert 0.0.0.0 0.0.0.0 192.168.1.1 ?
Pieter 't Hart
Honored Contributor

Re: what to add in Guest Internet to access the network?

>>>
Does it matter where i insert 0.0.0.0 0.0.0.0 192.168.1.1 ?
<<<
you can only add this at the global level.
jwc1972
Advisor

Re: what to add in Guest Internet to access the network?

Thanks

Sorry I thought you might need to put a new route in each vlan to get back to 192.168.1.*