Switching and Routing
1753792 Members
7586 Online
108799 Solutions
New Discussion

Re: 2920f vxlan

 
buas
Occasional Visitor

2920f vxlan

I have two switch JL260A (2930F) on two site. Configure vxlan:

configure vxlan on switch A:
vxlan enable
vxlan tunnel 1 overlay-vlan 333
interface tunnel 1
tunnel name "VXLAN_Tunnel02"
tunnel mode vxlan
tunnel source 10.11.0.4
tunnel destination 10.5.0.3
exit
vlan 333
name "VLAN333"
ip address 172.17.17.1 255.255.255.0
exit
virtual-network 1000333 333 "VirtualNetwork1000333"

and on switch B:
vxlan enable
vxlan tunnel 1 overlay-vlan 333
interface tunnel 1
tunnel name "VXLAN_Tunnel03"
tunnel mode vxlan
tunnel source 10.5.0.3
tunnel destination 10.11.0.4
exit
vlan 333
name "VLAN333"
ip address 172.17.17.2 255.255.255.0
exit
virtual-network 1000333 333 "VirtualNetwork1000333"


SwitchA# ping 172.17.17.2
172.17.17.2 is alive, time = 181 ms
SwitchA# show mac-address

Status and Counters - Port Address Table

MAC Address Port VLAN
----------------- ------------------------------- ----
...
64e881-12b8cb VXLAN_Tunnel02 333

Then connect via ssh :
SwitchA# ssh 172.17.17.2
+-------------------------------------------------------------------+
| WARNING |
| ------- |
| This system is solely for the use of authorized users for official|
| purposes.... |
+-------------------------------------------------------------------+

Enter admin@172.17.17.2's password: ***************
Press any key to continue
Your previous successful login (as manager) was on 2021-xx-xx xx:xx:xx
from 10.x.x.x
There have been 2 unsuccessful login attempts since your previous login,
most recently on 2021-xx-xx xx:xx:xx

SwitchB#

type show logging "Enter" and wheris no answer from switch. Connection close for timeout.
What am I doing wrong.
Why my pings pass but the traffic does not go normally through the vxlan tunnel?
Please help me.

3 REPLIES 3
akg7
HPE Pro

Re: 2920f vxlan

Hello @buas,

Can you share below commands output from both devices?

 

show version
show vxlan
show ip
show interfaces tunnel 1
show interfaces tunnel type vxlan statistics <take tunnel number from previous comamnd output>

 

 

Thanks!

Note: While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the companyAccept or Kudo
buas
Occasional Visitor

Re: 2920f vxlan

Hello.

Spoiler
SwitchA# show vxlan

  VXLAN Tunnel Information

  Status              : Enabled
  UDP Port            : 4789

SwitchA#
SwitchA# show ip

 Internet (IP) Service

  IP Routing : Enabled


  Default TTL     : 64
  Arp Age         : 20
  Domain Suffix   :
  DNS server      :

                       |                                            Proxy ARP
  VLAN                 | IP Config  IP Address      Subnet Mask     Std  Local
  -------------------- + ---------- --------------- --------------- ----------
  DEFAULT_VLAN         | Disabled
  Mngmt                | Disabled
  Mngmt-ilo            | Disabled
  transport-static-... | Manual     10.11.12.54     255.255.255.252  No    No
  VLAN333              | Manual     172.17.17.1     255.255.255.0    No    No



                                         Loopback Interface

  Loopback     | IP Config    IP Address      Subnet Mask
  ------------ + ------------ --------------- ---------------
           lo0 | Manual              10.11.0.4 255.255.255.255


SwitchA#
SwitchA#
SwitchA# show interfaces tunnel 1

 Tunnel Configuration :

  Tunnel               : 251658893
  Tunnel Name          : VXLAN_Tunnel02
  Tunnel Status        : Enabled
  Source Address       : 10.11.0.4
  Destination Address  : 10.5.0.3
  Mode                 : VXLAN Tunnel
  TOS                  : -1
  TTL                  : 64
  IPv6                 : n/a
  MTU                  : 1450


 Current Tunnel Status :

  Tunnel State              : Up
  Destination Address Route : 0.0.0.0/0
  Next Hop IP               : 10.11.12.53
  Next Hop Interface        : vlan-98
  Next Hop IP Link Status   : Up
  Source Address            : 10.11.0.4
  Egress Port               : 1

SwitchA#
SwitchA# show interfaces tunnel type vxlan statistics VXLAN_Tunnel02

  Tunnel Index                                 : 251658893
  Rx Packets                                   : 246
  Tx Packets                                   : 296
  Rx 5 Minute Weighted Average Rate (Pkts/sec) : 0
  Tx 5 Minute Weighted Average Rate (Pkts/sec) : 0

SwitchA#
Spoiler
SwitchB#
SwitchB# show  vxlan

  VXLAN Tunnel Information

  Status              : Enabled
  UDP Port            : 4789

SwitchB#
SwitchB#
SwitchB# show ip

 Internet (IP) Service

  IP Routing : Enabled


  Default TTL     : 64
  Arp Age         : 20
  Domain Suffix   :
  DNS server      :

                       |                                            Proxy ARP
  VLAN                 | IP Config  IP Address      Subnet Mask     Std  Local
  -------------------- + ---------- --------------- --------------- ----------
  DEFAULT_VLAN         | Disabled
  vlan_office          | Manual     10.5.12.254     255.255.255.0    No    No
  transport-ospf-vlan  | Manual     10.5.8.2        255.255.255.248  No    No
  transport-ospf-vlan2 | Manual     10.5.8.11       255.255.255.248  No    No
  camera_old_NVRN      | Manual     192.168.0.1     255.255.254.0    No    No
  VLAN333              | Manual     172.17.17.2     255.255.255.0    No    No
  ISP1_kvant           | Disabled
  ISP2_enforta         | Disabled
  nvrn-mngmtSRV-ilo... | Manual     10.5.9.1        255.255.255.0    No    No
  nvrn-mngmt           | Manual     10.5.11.1       255.255.255.0    No    No
  nvrn-printers        | Manual     10.5.22.1       255.255.255.0    No    No
  nvrn-wifi-corp       | Manual     10.5.24.1       255.255.254.0    No    No
  nvrn-wifi-Guest      | Manual     10.5.248.1      255.255.254.0    No    No



                                                                       Loopback Interface

  Loopback     | IP Config    IP Address      Subnet Mask
  ------------ + ------------ --------------- ---------------
           lo0 | Manual               10.5.0.3 255.255.255.255


SwitchB#
SwitchB# show interfaces tunnel 1

 Tunnel Configuration :

  Tunnel               : 251658894
  Tunnel Name          : VXLAN_Tunnel03
  Tunnel Status        : Enabled
  Source Address       : 10.5.0.3
  Destination Address  : 10.11.0.4
  Mode                 : VXLAN Tunnel
  TOS                  : -1
  TTL                  : 64
  IPv6                 : n/a
  MTU                  : 1450


 Current Tunnel Status :

  Tunnel State              : Up
  Destination Address Route : 10.11.0.4/32
  Next Hop IP               : 10.5.8.1
  Next Hop Interface        : vlan-95
  Next Hop IP Link Status   : Up
  Source Address            : 10.5.0.3
  Egress Port               : 1/43

SwitchB#
SwitchB#
SwitchB#
SwitchB# show interfaces tunnel type vxlan statistics VXLAN_Tunnel03

  Tunnel Index                                 : 251658894
  Rx Packets                                   : 319
  Tx Packets                                   : 245
  Rx 5 Minute Weighted Average Rate (Pkts/sec) : 0
  Tx 5 Minute Weighted Average Rate (Pkts/sec) : 0

SwitchB#

Thank you for your help.

akg7
HPE Pro

Re: 2920f vxlan

Hello @buas ,

 

VXLAN tunnel looks normal.

Is ssh with switch 2 was working earlier? 

Is it possible to do console access switch B and check 'show log' if any error related to ssh login? Check this in both switch.

Can you please share below output as well:

show ip ssh
show ip route
show version

 

Thanks!

Note: While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the companyAccept or Kudo