Switching and Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

CPU on 100% after adding mad ip addresses in IRF stack on VSR1001 (L2 loop?)

lukasn
Occasional Contributor

CPU on 100% after adding mad ip addresses in IRF stack on VSR1001 (L2 loop?)

Hello,

I am new to HPE Networking and I am labing with virtual routers we plan to deploy. I have 2 VSR1001 (cloned) in ESXi with 4 network cards attached to them:

  • Outside 
  • Internal 
  • IRF
  • BFD (VLAN 3012 - 192.168.12.0/24)

Every interface has it's VLAN in ESXi and tagging is done on vSwitch, which is connected to trunk interface on Cisco switch. 

So far I've set up IRF stack and it is working, now I am in the setting up BFD-MAD. I am following HPE VSR1000 Virtual Services Router IRF Configuration Guide with configuration. 

I've assigned routers BFD interfaces to VLAN 3012 as access ports and on Vlan-Interface3012 I've enabled mad bfd. When I set bfd ip for one member, CPU spikes to 100% until I shutdown the Vlan interface (or interfaces of router) and revert the setting. Looking at the counters of interface, there is a massive number of broadcast and multicasts, even though no devices are using these routers as gateways, so my first thought is that this is definitely causing loop in topology.

I think there might be something wrong in networking with ESXi, however I am not sure where to look. 

I've attached configuration and display interface Gi1/4/0 (BFD link)

Configuration:
#
version 7.1.059, Release R0326
#
sysname VSR1001_primary
#
irf mac-address persistent always
irf auto-update enable
irf auto-merge enable
irf member 1 priority 32
irf member 2 priority 1
#
lldp global enable
#
password-recovery enable
#
vlan 1
#
vlan 3012
description BFD_LINK
#
irf-port 1
port group interface GigabitEthernet1/2/0
#
irf-port 2
port group interface GigabitEthernet2/2/0
#
interface NULL0
#
interface Vlan-interface3012
mad bfd enable
mad ip address 192.168.12.1 255.255.255.0 member 1
mad ip address 192.168.12.2 255.255.255.0 member 2
#
interface GigabitEthernet1/1/0
port link-mode route
ip address Info Erased
#
interface GigabitEthernet1/3/0
port link-mode route
#
interface GigabitEthernet2/1/0
port link-mode route
#
interface GigabitEthernet2/3/0
port link-mode route
#
interface GigabitEthernet1/4/0
port link-mode bridge
port access vlan 3012
#
interface GigabitEthernet2/4/0
port link-mode bridge
port access vlan 3012
#
interface GigabitEthernet1/2/0
#
interface GigabitEthernet2/2/0
#
scheduler logfile size 16
#
line class aux
user-role network-operator
#
line class console
user-role network-admin
#
line class vty
authentication-mode scheme
user-role network-operator
protocol inbound ssh
#
line aux 0 1
user-role network-operator
#
line con 0 1
user-role network-admin
#
line vty 0 63
user-role network-operator
#
ip route-static 0.0.0.0 0 Info Erased
#
ssh server enable
ssh user admin service-type stelnet authentication-type password
#
domain system
#
domain default enable system
#
role name level-0
description Predefined level-0 role
#
role name level-1
description Predefined level-1 role
#
role name level-2
description Predefined level-2 role
#
role name level-3
description Predefined level-3 role
#
role name level-4
description Predefined level-4 role
#
role name level-5
description Predefined level-5 role
#
role name level-6
description Predefined level-6 role
#
role name level-7
description Predefined level-7 role
#
role name level-8
description Predefined level-8 role
#
role name level-9
description Predefined level-9 role
#
role name level-10
description Predefined level-10 role
#
role name level-11
description Predefined level-11 role
#
role name level-12
description Predefined level-12 role
#
role name level-13
description Predefined level-13 role
#
role name level-14
description Predefined level-14 role
#
user-group system
#
local-user admin class manage
password hash

Info Erased
service-type ssh terminal
authorization-attribute user-role network-admin
authorization-attribute user-role network-operator
#
cwmp
cwmp enable
#
return

display interface Gi1/4/0 (BFD link)

display interface GigabitEthernet 1/4/0
GigabitEthernet1/4/0
Current state: UP
Line protocol state: UP
IP Packet Frame Type: PKTFMT_ETHNT_2, Hardware Address: Info Erased
Description: GigabitEthernet1/4/0 Interface
Bandwidth: 1000000kbps
Loopback is not set
1000Mbps-speed mode, full-duplex mode
Link speed type is force link, link duplex type is force link
Flow-control is not enabled
The Maximum Frame Length is 16384
Allow jumbo frame to pass
Broadcast MAX-ratio: 100%
Multicast MAX-ratio: 100%
Unicast MAX-ratio: 100%
PVID: 3012
Port link-type: access
Tagged Vlan: none
UnTagged Vlan: 3012
Output queue - Urgent queuing: Size/Length/Discards 0/100/0
Output queue - Protocol queuing: Size/Length/Discards 0/500/0
Output queue - FIFO queuing: Size/Length/Discards 0/75/0
Last link flapping: 2 hours 39 minutes 34 seconds
Last clearing of counters: Never
Last 300 seconds input: 6839 packets/sec 410387 bytes/sec 0%
Last 300 seconds output: 7269 packets/sec 436161 bytes/sec 0%
Input (total): 62174151 packets, 3742887454 bytes
0 unicasts, 60116006 broadcasts, 2058145 multicasts, 0 pauses
Input (normal): 62174151 packets, 3742887454 bytes
0 unicasts, 60116006 broadcasts, 2058145 multicasts, 0 pauses
Input: 0 input errors, 0 runts, 0 giants, 0 throttles
0 CRC, 0 frame, 0 overruns, 0 aborts
0 ignored, 0 parity errors
Output (total): 64521983 packets, 3883916032 bytes
0 unicasts, 62438252 broadcasts, 2083731 multicasts, 0 pauses
Output (normal): 64521983 packets, 3883916032 bytes
0 unicasts, 62438252 broadcasts, 2083731 multicasts, 0 pauses
Output: 0 output errors, 0 underruns, 0 buffer failures
0 aborts, 0 deferred, 0 collisions, 0 late collisions
0 lost carrier, 0 no carrier

Thanks for pointers.