Switching and Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

DHCP Option 66 on 5406zl switch

 
Highlighted
Occasional Visitor

DHCP Option 66 on 5406zl switch

I am trying to setup DHCP on a HP Switch 5406zl (J8697A) running K.16.02.0026, the main part of the DHCP is working ok, the par that isn't relates to Option 66 which I need for PXE booting for WDS.

The switch can ping and trace to the server running WDS ok, but when I attempt a network boot it shows the TFTP as blank, the config section is below:

dhcp-server pool "Production"
authoritative
bootfile-name "\boot\x64\wdsnbp.com"
default-router "10.1.0.1"
dns-server "10.226.1.1,10.226.1.2"
domain-name "aaaaaa.net" (This has been amended for the purpose of this topic)
lease 07:00:00
network 10.1.0.0 255.255.254.0
range 10.1.0.50 10.1.1.230
tftp-server server-ip 10.226.1.13
exit
dhcp-server enable

This configuration was picked up from DHCP running on the Domain Controllers which are now in our Private Cloud, at the moment the local network is not seeing the DC as a DHCP server, which I will have to persue if I can't get the switch to do the job.

I have tried the IP straight and in quotes, I have also tried the Server Name all to no avail.

I read somewhere that QIP could be interferring with Option 66, but I can't find out how to change or modify these settings, of course until the switch recognises the server I won't know if the option 67 is correct having carried it over from Windows DHCP.

I am presuming that as the switch can contact the server with Ping that it must be the switch not recognising the server as opposed to a network issue. The local and Cloud networks connected through a site to site VPN setup on CIsco Firewall that should be full open.

Any ideas or suggestions appreciated.

Many thanks

Barry H

1 REPLY 1
Highlighted
Honored Contributor

Re: DHCP Option 66 on 5406zl switch

Are we sure that DHCP Option 66 is currently supported on HP ProCurve 5400 zl Switch series?

The question above should be valid also for Aruba 5400R zl2 Switch series (at least reading this and checking relevant manuals).