Switching and Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

Dead power supply and flaky j4113a on 4000m and 2424m

martyscholes
Occasional Advisor

Dead power supply and flaky j4113a on 4000m and 2424m

Hello,

 

I have a 4000m at the center of my network with dual PS and one of them appears to be dead.  I noticed it by accident when I was in the back of my rack.  Neither the web interface to the stack nor the console interface shows a problem.  Is there some alarm or logs or something that I could be looking at to detect faults?  It seems silly that the switch needs to be pysically inspected to see if the fault LED is lit.

 

At the edge of my network sits 2424m switches in every room with fiber back to the 4000m.  One of the switches has a flaky j4113b card or the switch itself has a problem.  Every few weeks I need to reseat the card and power-cycle the switch.  This happens with any of three cards I have tried in the switch.  Is there a log somewhere in the 2424m I can see which will tell me what is going on?

 

All of the manuals I have for the 2424m and 4000m hint at some logging, but do not come right out and discuss how to get to the logs.

 

Many thanks,

Marty

3 REPLIES
tschaps
Valued Contributor

Re: Dead power supply and flaky j4113a on 4000m and 2424m

If you can telnet to the 4000m, and this might be the same with the console interface, right on the main menu is "Event Log." It should show the power supply failure in there. That and a 'fault' light on the front are the only indicators I've seen. Kinda lame, but that switch is so terribly outdated, your chances of an update are nil.
The 4000m's are old, but they are workhorses and keep going. That being said, they have itty bitty backplanes compared to modern switches, so I would strongly suggest an upgrade to your core switch, especially if you notice network bottlenecks. In the telnet interface "Status and Counters - General System Information," check the number of missed packets in the lower right. If there are a substantial #, then your switch is overloaded and dropping data.
I don't have an answer for your 2424m problem, but that switch and card probably have a lifetime warranty. You might talk to HP about it, or buy replacement switch and card for a few dollars on eBay.
HP-JustinGuse
Valued Contributor

Re: Dead power supply and flaky j4113a on 4000m and 2424m

Hello martyscholes,

 

Perhaps I'm a bit late here but better than never :)

 

1) Regarding the 4000M tschaps is definitely right that you should consider upgrading sometime if your performance isn't good. However HP generally still stocks 4000M replacement parts, at least at the time of writing this. Not sure when they'll go out of stock, but you could open a support case and get that power supply replaced unter lifetime wty, regardless. The event log should indicate this failure too, as mentioned.

 

2) For the 2424M it sounds like the switch itself is faulty if you've tried 3 cards already. Have a look at the event log and such there too, it is just like the 4000M's menu interface: ftp://ftp.hp.com/pub/networking/software/59692320.pdf

Again I would recommend opening a case with support, especially for the 2424M! From personal experience exchanging these things for customers I can tell you that you might very well be eligible for a "functional equivalent" exchange, since I don't believe we have available replacements for these anymore. That means you'll get a newer model as a replacement, along with new module(s) and transceiver(s) if necessary. In that case you won't need to bother buying a new switch :)

 

Long live the true lifetime warranty, eh?

martyscholes
Occasional Advisor

Re: Dead power supply and flaky j4113a on 4000m and 2424m

Thanks so much for the responses.  Duh, the event log is option 4 on the main console menu.  I had trouble navigating it before I set the terminal type to ANSI.  It still would be nice if the switch hit me upside the head when this happens.

 

I guess I will have to get more serious and install some syslog/nagios type of alarming.  Kind of ironic that these are so reliable that you can have a problem and not even know about it.

 

Yes these are ancient switches, and that's why I bought them.  This is actually for my home and I have fiber fanning out all over the house, for very little money.  I suspect the switches will be just fine for a home setup, at least for several years.  I have to shuffle things in the rack soon.  When I do, I will put in a second switch and split the trunked copper gb links from the server across the two switches.  It should be a while before traffic becomes an issue, but watching for missed packets is good advice.

 

I just opened up a case with HP for the power supply.

 

Thanks again!