Comware Based
1753425 Members
5229 Online
108793 Solutions
New Discussion ī„‚

Link aggregation between HP 5510 and Dell Blade server M620

 
ckrishnan
Occasional Contributor

Link aggregation between HP 5510 and Dell Blade server M620

Hi

I have created two aggregation group one was connecting to san switch it was working fine and the second group was connecting to Dell blade server m620 it was not aggregating only one port was selecting remaining 3 ports was unselecting state

#
interface Bridge-Aggregation1
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 11
link-aggregation mode dynamic
#
interface Bridge-Aggregation2
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 4 192
link-aggregation mode dynamic
#

interface GigabitEthernet1/0/8
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 4 192
port link-aggregation group 2
#
interface GigabitEthernet1/0/9
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 4 192
port link-aggregation group 2
#
interface GigabitEthernet1/0/10
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 4 192
port link-aggregation group 2
#
interface GigabitEthernet1/0/11
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 4 192
port link-aggregation group 2
#

 

Server-side configuration 

!
interface Gi1/0/47
channel-group 1 mode on
switchport mode trunk
exit
!
interface Gi1/0/48
channel-group 1 mode on
switchport mode trunk

!
interface Gi2/0/47
channel-group 1 mode on
switchport mode trunk
exit
!
interface Gi2/0/48
channel-group 1 mode on
switchport mode trunk
exit
!

please tell me where was the misconfiguration

 

Regards

Gopal

5 REPLIES 5
parnassus
Honored Contributor

Re: Link aggregation between HP 5510 and Dell Blade server M620

I'm not an expert about DELL but looking at Server side NIC ports configuration (It looks like you have a switch there):

!
interface Gi1/0/47
channel-group 1 mode on
switchport mode trunk
exit
!
interface Gi1/0/48
channel-group 1 mode on
switchport mode trunk
!
interface Gi2/0/47
channel-group 1 mode on
switchport mode trunk
exit
!
interface Gi2/0/48
channel-group 1 mode on
switchport mode trunk
exit
!

four questions come to my mind:

  1. Is it a Switch configuration (if so, which Switch, Server side?) or is it a OS NIC ports configuration?
  2. Which is the configuration directive that tell your Server side NIC ports to be part of an aggregated LACP? Switch side dynamic = LACP in Comware terminology.
  3. Given the NIC Ports numbering 1/0/x and 2/0/x...are you dealing with two Switches or 2 dual ports NICs Server side?
  4. Can you provide the minimum diagnostic output Switch side for BAGGs (display ...)?

I'm not an HPE Employee
Kudos and Accepted Solution banner
ckrishnan
Occasional Contributor

Re: Link aggregation between HP 5510 and Dell Blade server M620

it's dell  PowerConnect M6348 switch

Philippe_D
Advisor

Re: Link aggregation between HP 5510 and Dell Blade server M620

Have you tried "channel-group 1 mode active" on your dell switch instead of "channel-group 1 mode on"?

Philippe_D
Advisor

Re: Link aggregation between HP 5510 and Dell Blade server M620

You need to make sure your dell switch is configured for LACP otherwise you need to remove the "link-aggregation mode dynamic" command on the HP.

As long as the other side doesn't talk lacp you will not see more than 1 interface selected on the HP.

I found this in a manual of the dell switch

ftp://ftp.dell.com/Manuals/all-products/esuprt_ser_stor_net/esuprt_powerconnect/powerconnect-m6348_user's%20guide2_en-us.pdf


Switching Configuration
Example #6: Set Group LACP Mode to Dynamic
Use the lacp auto command to set the LACP (Link Aggregation) mode to dynamic for that Aggregator
Group. This means that when more than one uplink port is in the Group, those uplink ports will be
enabled automatically with LACP.
console(config)#port-aggregator group 2
console(config-aggregator-2)#lacp auto
console(config-aggregator-2)#
 
you can find more dell manuals here:
ftp://ftp.dell.com/Manuals/all-products/esuprt_ser_stor_net/esuprt_powerconnect/

 

parnassus
Honored Contributor

Re: Link aggregation between HP 5510 and Dell Blade server M620

Hi @Philippe_D that's exactly the point I wanted @ckrishnan to undersand: a LACP port aggregation can't be setup on one side (Switch peer) without being aware that a compatible and supported configuration must be done on the other side (Server or Switch peer) in order for the logical interfaces to match and properly instaurate the aggregated link...then, only the OP, knows exactly which devices/hosts/scenario he/she is working with...so doing the right initial questions is a way to say "Pay attention that you should do things that way..." and answers should let the OP to fix the issues he/she thus discover.


I'm not an HPE Employee
Kudos and Accepted Solution banner