Switching and Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

SFP+ uplink down after firmware upgrade on JL259A (2930F)

 
Highlighted
Occasional Advisor

SFP+ uplink down after firmware upgrade on JL259A (2930F)

I have 2 2930F (JL259A). The uplink between the two is 2x SFP+ in a trunk. This worked fine with firmware 16.04.0014 on one and 16.06.0006 on the other. But after I did a firmware upgrade on the first from 16.04.0014 to 16.09.003 the link is down and does not come back. What can be the issue?

11 REPLIES 11
Highlighted
Honored Contributor

Re: SFP+ uplink down after firmware upgrade on JL259A (2930F)

Hi, please share here sanitized configurations of both involved switches...generally speaking LACP/Non-Protocol based ports aggregations should not suffer disruptions related to differences of software versions.
Highlighted
Occasional Advisor

Re: SFP+ uplink down after firmware upgrade on JL259A (2930F)

Here is the configuration of switch01 before the update. When it all worked. The trunk on the second is identical. VLAN's also. And it's the trunk that is down after the update of the second switch.

Aruba JL259A 2930F-24G-4SFP Switch
Software revision WC.16.04.0014
show tech

show time
Fri Aug 16 14:47:09 2019

show system

Status and Counters - General System Information

System Name : switch02.<domain>
System Contact :
System Location : DC

MAC Age Time (sec) : 300

Time Zone : 0
Daylight Time Rule : Western-Europe

Software revision : WC.16.04.0014 Base MAC Addr : 3821c7-243a00

ROM Version : WC.16.01.0006 Serial Number : CN8BHL00GF

Up Time : 70 days Memory - Total : 347,570,688
CPU Util (%) : 2 Free : 228,826,072

IP Mgmt - Pkts Rx : 14,257,810 Packet - Total : 6600
Pkts Tx : 12,388,582 Buffers Free : 4345
Lowest : 4221
Missed : 0
show config files

Configuration files:

id | act pri sec | name
---+-------------+------------------------------------------------
1 | * * * | config1
2 | |
3 | |


show flash _detail
Image Size (bytes) Date Version
----------------- ------------ -------- --------------
Primary Image : 28328678 04/27/18 WC.16.04.0014
Secondary Image : 28328678 04/27/18 WC.16.04.0014

Boot ROM Version
----------------
Primary Boot ROM Version : WC.16.01.0006
Secondary Boot ROM Version : WC.16.01.0006

Default Boot Image : Primary
Default Boot ROM : Primary

Primary image details:
size : 28328678
buildNum : 784
yyww : 5816
date : 04/27/18
df_version : WC.16.04
ng_version : WC.16.04.0014
vvv : WC
uu : 16
bb : 04
ffff : 0014
aaaaa :
composite : 0x1004000e
user_version : WC.16.04.0014

Secondary image details:
size : 28328678
buildNum : 784
yyww : 5816
date : 04/27/18
df_version : WC.16.04
ng_version : WC.16.04.0014
vvv : WC
uu : 16
bb : 04
ffff : 0014
aaaaa :
composite : 0x1004000e
user_version : WC.16.04.0014

show running-config

Running configuration:

; JL259A Configuration Editor; Created on release #WC.16.04.0014
; Ver #11:10.9b.3f.bf.bb.ef.7c.59.fc.6b.fb.9f.fc.ff.ff.37.ef:bc
hostname "switch02.<domain>"
module 1 type jl259a
trunk 25-26 trk1 lacp
timesync ntp
ntp unicast
ntp server 10.0.0.216 iburst
ntp enable
time daylight-time-rule western-europe
web-management ssl
ip default-gateway 10.0.0.1
interface 7
name "efw-cust"
exit
interface 12
name "free"
exit
interface 25
name "Uplink"
exit
interface 26
name "Uplink"
exit
interface 27
name "free"
exit
interface 28
name "free"
exit
snmp-server community ".......!" unrestricted
snmp-server location "..."
vlan 1
name "DEFAULT_VLAN"
no untagged 1-7
untagged 8-24,27-28
tagged Trk1
ip address 10.0.0.23 255.255.255.0
ipv6 enable
ipv6 address dhcp full
forbid 1-7
exit
vlan 10
name "ISP"
untagged 1-2
tagged Trk1
ip address 10.0.10.23 255.255.255.0
forbid 3-10,12,23
exit
vlan 20
name "DMZ"
untagged 3-6
tagged Trk1
ip address 10.0.20.23 255.255.255.0
forbid 1-2,7-10,12,23
exit
vlan 40
name "iSCSI"
tagged Trk1
no ip address
forbid 1-10,12,23
exit
vlan 99
name "MGMT"
tagged Trk1
ip address 10.0.99.23 255.255.255.0
forbid 1-10,12,23
exit
vlan 1194
name "RAB"
tagged 7,Trk1
ip address 195.1.45.23 255.255.255.0
forbid 1-6,8-10
exit
vlan 1195
name "BOELE"
tagged 7,Trk1
ip address 195.1.50.23 255.255.255.0
forbid 1-6,8-10,23
exit
spanning-tree
spanning-tree Trk1 priority 4
allow-unsupported-transceiver
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update
password manager
password operator

show config status

The running configuration has been modified and not yet saved.


show ip

Internet (IP) Service

IP Routing : Disabled

Default Gateway : 10.0.0.1
Default TTL : 64
Arp Age : 20
Domain Suffix :
DNS server :

| Proxy ARP
VLAN | IP Config IP Address Subnet Mask Std Local
-------------------- + ---------- --------------- --------------- ----------
DEFAULT_VLAN | Manual 10.0.0.23 255.255.255.0 No No
ISP | Manual 10.0.10.23 255.255.255.0 No No
DMZ | Manual 10.0.20.23 255.255.255.0 No No
iSCSI | Disabled
MGMT | Manual 10.0.99.23 255.255.255.0 No No
RAB | Manual 195.1.45.23 255.255.255.0 No No
BOELE | Manual 195.1.50.23 255.255.255.0 No No

show trunks

Load Balancing Method: L3-based (default)

Port | Name Type | Group Type
------ + -------------------------------- ---------- + ----- --------
25 | Uplink SFP+DA1 | Trk1 LACP
26 | Uplink SFP+DA1 | Trk1 LACP

Status and Counters - VLAN Information

Maximum VLANs to support : 256
Primary VLAN : DEFAULT_VLAN
Management VLAN :

VLAN ID Name | Status Voice Jumbo
------- -------------------------------- + ---------- ----- -----
1 DEFAULT_VLAN | Port-based No No
10 ISP | Port-based No No
20 DMZ | Port-based No No
40 iSCSI | Port-based No No
99 MGMT | Port-based No No
1194 RAB | Port-based No No
1195 BOELE | Port-based No No

show interfaces brief

Status and Counters - Port Status

| Intrusion MDI Flow Bcast
Port Type | Alert Enabled Status Mode Mode Ctrl Limit
------------ ---------- + --------- ------- ------ ---------- ---- ---- -----
1 100/1000T | No Yes Down 1000FDx Auto off 0
2 100/1000T | No Yes Down 1000FDx Auto off 0
3 100/1000T | No Yes Down 1000FDx Auto off 0
4 100/1000T | No Yes Down 1000FDx Auto off 0
5 100/1000T | No Yes Down 1000FDx Auto off 0
6 100/1000T | No Yes Down 1000FDx Auto off 0
7 100/1000T | No Yes Up 1000FDx MDI off 0
8 100/1000T | No Yes Down 1000FDx Auto off 0
9 100/1000T | No Yes Down 1000FDx Auto off 0
10 100/1000T | No Yes Down 1000FDx Auto off 0
11 100/1000T | No Yes Down 1000FDx NA off 0
12 100/1000T | No Yes Down 1000FDx Auto off 0
13 100/1000T | No Yes Down 1000FDx Auto off 0
14 100/1000T | No Yes Down 1000FDx Auto off 0
15 100/1000T | No Yes Down 1000FDx Auto off 0
16 100/1000T | No Yes Down 1000FDx Auto off 0
17 100/1000T | No Yes Down 1000FDx Auto off 0
18 100/1000T | No Yes Down 1000FDx Auto off 0
19 100/1000T | No Yes Down 1000FDx Auto off 0
20 100/1000T | No Yes Down 1000FDx Auto off 0
21 100/1000T | No Yes Down 1000FDx Auto off 0
22 100/1000T | No Yes Down 1000FDx Auto off 0
23 100/1000T | No Yes Up 100FDx MDI off 0
24 100/1000T | No Yes Down 1000FDx Auto off 0
25-Trk1 SFP+DA1 | No Yes Up 10GigFD NA off 0
26-Trk1 SFP+DA1 | No Yes Up 10GigFD NA off 0
27 SFP+DA3 | No Yes Up 1000FDx NA off 0
28 SFP+DA1 | No Yes Down 10GigFD NA off 0
* third-party transceiver

Spanning Tree Information

STP Enabled [No] : Yes
Mode : MSTP

show spanning-tree system-limits rapid-pvst

Spanning Tree Information


STP Enabled : Yes
Mode : MSTP
RPVST Enabled VLANs : 1,10,20,40,99,1194-1195

show lacp
LACP

LACP Trunk Port LACP Admin Oper
Port Enabled Group Status Partner Status Key Key
----- ------- ------- ------- ------- ------- ------ ------
25 Active Trk1 Up Yes Success 0 532
26 Active Trk1 Up Yes Success 0 532

 

Highlighted
Honored Contributor

Re: SFP+ uplink down after firmware upgrade on JL259A (2930F)

Can you share sanitized output of show tech transceivers Command? Are you using DAC Cables on SFP Ports? IIRC the Aruba JL259A 2930F-24G-4SFP Switch doesn't support ANY 10Gbps Transceivers/DAC...so...what is going on? but...more importantly...how was it possible a successfull connection at 10G IF both involved JL259A are not able to support SFP+/DAC Cables (independently by running software)?
Highlighted
Occasional Advisor

Re: SFP+ uplink down after firmware upgrade on JL259A (2930F)

Yes. These are DAC cables.

Transceiver Technical Information:
Port # | Type | Prod # | Serial # | Part #
-------+-----------+------------+------------------+----------
25 | SFP+DA1 | J9281D | CN91KBZ579 | 8121-1300
26 | SFP+DA1 | J9281D | CN91KBZ53R | 8121-1300
27 *| SFP+DAC | ?? | unsupported |
28 | SFP+DA1 | J9281D | CN83KBZ3RM | 8121-1300

* third-party transceivershow time
Thu Aug 29 13:27:55 2019

Highlighted
Honored Contributor

Re: SFP+ uplink down after firmware upgrade on JL259A (2930F)

Pretty strange...JL259A doesn't support SFP+/DAC Cables...so it doesn't support 10Gbps Transceivers...only 1Gbps (it means SFP Transceivers listed in its QuickSpecs).

Maybe newer system software versions fix (strictly enforce) the above restriction avoiding users to use SFP+/DAC Cables improperly on a platform marketed to not support them.
Highlighted
Occasional Advisor

Re: SFP+ uplink down after firmware upgrade on JL259A (2930F)

https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-c05235854

This article lists the option parts. And it includes the DAC J9281D cables. So why do you conclude the DAC is not supported?

Highlighted
Honored Contributor

Re: SFP+ uplink down after firmware upgrade on JL259A (2930F)

Because I've checked both Aruba 2930F Switch Series QuickSpecs and HPE PartSurfer (for JL259A)...see here:
https://partsurfer.hpe.com/Search.aspx?SearchText=JL259A&SearchText=JL259A
The page you linked is the general page for the entire Aruba 2939F Switch Series, you must go to the specific supported options for SKU JL259A to understand exactly what is supported and what's not on that specific model.
Highlighted
Occasional Advisor

Re: SFP+ uplink down after firmware upgrade on JL259A (2930F)

Also strange to see the uplink was showing 10G (!) before the upgrade. While the JL259A is SFP only. Maybe better stay on the older firmware to get this feature

Highlighted
Honored Contributor

Re: SFP+ uplink down after firmware upgrade on JL259A (2930F)

Call it feature...