HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
cancel
Showing results for 
Search instead for 
Did you mean: 

64 BIT GDB .. for 11.23?

 
SOLVED
Go to solution
rleon
Regular Advisor

64 BIT GDB .. for 11.23?

Hi

I have 32bit gdb .. but I have a developer requesting 64 bit GDB.



# file /opt/langtools/bin/gdb
/opt/langtools/bin/gdb: ELF-32 executable object file - IA64

Thanks
2 REPLIES
Steven E. Protter
Exalted Contributor
Solution

Re: 64 BIT GDB .. for 11.23?

Shalom,

http://hpux.connect.org.uk/hppd/hpux/Gnu/gdb-5.3/

That is where to get it.

Since HP-UX is 64 bit only at 11.23 I imagine that this version is 64 bit. You can check it prior to install.

As to why you want to use this on an ELF-32 binary. That is beyond me. Good luck.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com

Re: 64 BIT GDB .. for 11.23?

>I have 32bit gdb but I have a developer requesting 64 bit GDB.

HP's Integrity GDB only comes in the color black, 64 bit. This means you have an obsolete version. The latest is 6.0:
http://www.hp.com/go/wdb

>SEP: That is where to get it.

The one in /opt/langtools/ is HP's version.

>As to why you want to use this on an ELF-32 binary.

This statement wasn't made. Only that the obsolete gdb was still 32 bit.
And that could have problems with very large 64 bit apps.