System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

A bug in proliant support pack for RHEL 4??

Ben Stokes
Frequent Advisor

A bug in proliant support pack for RHEL 4??

I have a major issue with the PSP for RHEL4. The same thing happens every time if the ILO card drivers are installed, this is what I'm doing:

up2date -i -f kernel-devel
ln -s /usr/src/kernels/`uname -r` /lib/modules/`uname -r`/build
tar psp...blah blah
cd /blah/blah
./installxxx

Everything is installed OK, but the next time the server is rebooted, during startup it says device eth0 has a different mac address than expecting, ignoring. Then it becomes impossible to start up eth0 because of this problem.

It would be a quick fix to rebuild the server and just not create this symlink so that the ILO drivers are not installed, after all this is not critical for the server to run and ILO will work perfectly without it ... but I would rather get to the bottom of this. What am I doing wrong here? Or is this a problem with the PSP and RHEL4?
3 REPLIES
Jimmy Vance
HPE Pro

Re: A bug in proliant support pack for RHEL 4??

I've not seen this particular error when installing the PSP on a RHEL4 system.

Not know what server you have, my first thought is you are using iLO in the shared NIC port mode?

I don't know if iLO changes the ports MAC address when in this mode.

as a test and possible workaround in /etc/sysconfig/network-scripts/ifcfg-eth0 remark out the HWADDR line. The system will work fine without it.

I normally remove this entry as I move drives around to different servers in my test lab.








__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Ben Stokes
Frequent Advisor

Re: A bug in proliant support pack for RHEL 4??

Hi Jimmy

That didn't work - if I comment that line and restart the network I then get a message that the bnx2 device is not present.

I then tried "modprobe bnx2" and it tells me "incorrect module format".

depmod -a and then modprobe again just gives the same error.

I found another thread this morning which appears to be exactly the same problem so I'll follow up in there. Looks like this is an issue with PSP on some new systems.

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1113552
Steven E. Protter
Exalted Contributor

Re: A bug in proliant support pack for RHEL 4??

Shalom,

PSP builds its own kernel and sets it up to run in /boot/grub/grub.conf

Tehre is no reason to use it. iLo does not work with the kernel at all, it has its own mini-OS built in.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com