System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

ACPI error on redHat ES 5.3 (kernel 2.6.27.10)

 
Jens Skoglund
Occasional Visitor

ACPI error on redHat ES 5.3 (kernel 2.6.27.10)

Hi,

When I try to build ACPI for HP SIM, I get the following error:

# make install
make -C /lib/modules/2.6.27.10-grsec/build SUBDIRS=/opt/hp/hpmgmtbase/src/ACPI/dev_acpi clean
make[1]: Entering directory `/mail/src/linux-2.6.27.10-grsec'
CLEAN /opt/hp/hpmgmtbase/src/ACPI/dev_acpi/.tmp_versions
make[1]: Leaving directory `/mail/src/linux-2.6.27.10-grsec'
rm -f hpacpitree hpacpiexec
return current;
patching file fixaclinux.h
Hunk #1 FAILED at 72.
Hunk #2 succeeded at 115 (offset 10 lines).
1 out of 2 hunks FAILED -- saving rejects to file fixaclinux.h.rej
make -C /lib/modules/2.6.27.10-grsec/build SUBDIRS=/opt/hp/hpmgmtbase/src/ACPI/dev_acpi modules
make[1]: Entering directory `/mail/src/linux-2.6.27.10-grsec'
CC [M] /opt/hp/hpmgmtbase/src/ACPI/dev_acpi/dev_acpi.o
/opt/hp/hpmgmtbase/src/ACPI/dev_acpi/dev_acpi.c: In function âdev_acpi_ioctlâ:
/opt/hp/hpmgmtbase/src/ACPI/dev_acpi/dev_acpi.c:1213: error: implicit declaration of function âacpi_bus_generate_eventâ
/opt/hp/hpmgmtbase/src/ACPI/dev_acpi/dev_acpi.c: In function âdev_acpi_initâ:
/opt/hp/hpmgmtbase/src/ACPI/dev_acpi/dev_acpi.c:1890: error: implicit declaration of function âclass_device_createâ
/opt/hp/hpmgmtbase/src/ACPI/dev_acpi/dev_acpi.c: In function âdev_acpi_exitâ:
/opt/hp/hpmgmtbase/src/ACPI/dev_acpi/dev_acpi.c:1902: error: implicit declaration of function âclass_device_destroyâ
make[2]: *** [/opt/hp/hpmgmtbase/src/ACPI/dev_acpi/dev_acpi.o] Error 1
make[1]: *** [_module_/opt/hp/hpmgmtbase/src/ACPI/dev_acpi] Error 2
make[1]: Leaving directory `/mail/src/linux-2.6.27.10-grsec'
make: *** [dev_acpi] Error 2

We are runing on rx2660.
SupportPack 4.26.

ACPI works on kernel 2.6.18-128 (RedHat standard).

Jens
3 REPLIES
Steven E. Protter
Exalted Contributor

Re: ACPI error on redHat ES 5.3 (kernel 2.6.27.10)

Shalom,

Looks to me why you are not meeting the requirements of the application.

These HP tools are certified only on certain OS version and kernel combination's.

Is your combination certified?

I'm thinking not. These tools use system calls and are sensitive to that.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Jens Skoglund
Occasional Visitor

Re: ACPI error on redHat ES 5.3 (kernel 2.6.27.10)

What I can see and read this is okay.
My hardware with my OS is certified.
Can't found if the version of kerenl applicable or not. Only kerenl version 2.6.
Brem Belguebli
Regular Advisor

Re: ACPI error on redHat ES 5.3 (kernel 2.6.27.10)

Correct me if I'm wrong but 2.6.27 doesn't look like the standard RHEL 5.x shipped version which should be 2.6.18.

Have you tried building HP-Sim on the shipped kernel version ?