System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

ATI Radeon 7500 + resolution issue

SOLVED
Go to solution
Sarjerao
Frequent Advisor

ATI Radeon 7500 + resolution issue

Config - DS15, ati radeon 7500 graphics controller; 5.1B PK4;
Unable to set resolution 2048x1024 85 hz.
modify /var/X11/xserver.conf as foll...
-screen0 1280x1024
-vsync0 75

Xerrors shows.....

RADEON screen 0 invalid resolution/vsync/depth/vclass, using defaults
RADEON screen 0 set to 1024x768 depth 24 at 70 Hz
RADEON screen 0 acceleration disabled, not initializing the DRI

5 REPLIES
Ivan Ferreira
Honored Contributor

Re: ATI Radeon 7500 + resolution issue

I'm not an expert with video issues, but we used to change the file /etc/dt/config/Xservers like this:

:0 Local local@console /usr/bin/X11/X -screen0 1024x768 -vsync0 75 :0
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
AwadheshPandey
Honored Contributor

Re: ATI Radeon 7500 + resolution issue

this problem comes due to setting of proper resolution
check this:
http://lists.debian.org/debian-x/2002/11/msg00382.html

Awadhesh
It's kind of fun to do the impossible
Rick Retterer
Respected Contributor
Solution

Re: ATI Radeon 7500 + resolution issue

The radeon 7500 graphics card is capable of handling the following resolutions:

Resolution Depth Refresh Rate
==================================
640x480 8,16,24 60,72,75,85 Hz
800x600 8,16,24 60,72,75,85 Hz
1024x768 8,16,24 60,70,75,85 Hz
1152x864 8,16,24 60 Hz
1280x1024 8,16,24 60,75,85 Hz
1600x1200 8,16,24 60,65,75,85 Hz
1920x1440 8,16,24 60,75 Hz
2048x1536 8,16,24 60,65,70,75 Hz

The default resolution settings is:
1280x1024 24bit Depth @ 75 Hz.

Changes to the Xserver can be made in 3 places on the system, but the recommended place to make your changes is in /var/X11/Xserver.conf

At the bottom of the file, you will find a section that looks something like this:

!RADEON Server args start
-pn
!RADEON Server args end.

You will want to specify the settings you want after the "-pn" between the two RADEON settings...

Example:

!RADEON Server args start
-pn -bs -su
-screen0 1024x768
-depth0 8
-vsync0 85
!RADEON Server args end

***WARNING*** make sure your monitor can support the settings that you want to use, you can damage your monitor by setting your refresh rate too high.
This is particularly true of older monitors, newer monitors typically will not allow you to overdrive them.
***WARNING***

Here is a example of setup for a system that has multiple RADEON 7500 graphics cards installed:

args <
! Start Graphics ATI Radeon required Server Arguments.
-pn -bs -su -nice 2
-depth0 24
-depth1 24
-depth2 24
-screen0 1280x1024
-screen1 1280x1024
-screen2 1280x1024
-vclass0 TrueColor
-vclass1 TrueColor
-vclass2 TrueColor
-vsync0 60
-vsync1 60
-vsync2 60
! End Graphics ATI Radeon required Server Arguments.
>

I have attached the RADEON Installation PDF file for you to download and use as a reference guide.

I hope this helps you with your configuration.

Cheers,
Rick Retterer
HP Services
Tru64 Graphics Support
- Rick Retterer



Sarjerao
Frequent Advisor

Re: ATI Radeon 7500 + resolution issue

Thanks rick

I have single card, so modified xserver.conf as mentioned,

-screen0 1280x1024
-vsync0 85
but still xerrors shows same error.....
RADEON screen 0 invalid resolution/vsync/depth/vclass, using defaults
RADEON screen 0 set to 1024x768 depth 24 at 70 Hz
RADEON screen 0 acceleration disabled, not initializing the DRI

I tried other resolution setting also but giving same error.
My monitor type is P1130;
Is there any patch or any otner setting needs to do?
Rick Retterer
Respected Contributor

Re: ATI Radeon 7500 + resolution issue

Sarjerao,

You are trying to set your resolution to a unsupported value.

2048x1024 @85Hz is not a valid setting...

2048x1536 @75Hz is the largest setting you can specify.

If you aren't setting this in /var/X11/Xservers, then check for anything in these files:

/usr/dt/config/Xservers
/etc/dt/config/Xservers

If you find any -screen settings, remove them.

The line at the bottom of this file should read exactly like this:

:0 Local local@console /usr/bin/X11/X :0


Cheers,
Rick
- Rick Retterer