System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Access to SAM using your own login

Marylou Kohlmeier
Frequent Advisor

Access to SAM using your own login

I can use "sam" when I login as root but not using my own login. My current permission for /usr/sbin/sam is r-x, r-x, r-x.

I have added my login to the following group to no avail: adm, sys and bin

Please let me know if you can provide assistance.

thank you,
Marylou
HP 11.23
RX 7640 -Itanium
13 REPLIES
Roopesh Francis_1
Trusted Contributor

Re: Access to SAM using your own login


#sam -r

This activates the Restricted SAM Builder, which allows you to enable or disable selected SAM areas for users.

For each user given restricted access, SAM creates a file /etc/sam/custom/login_name.cf that defines the user's SAM privileges. SAM uses this file to give users access to the indicated areas.

When users execute SAM, they will have superuser status to the areas you defined and will only see those SAM areas in the menu. Areas that do not require superuser status (such as SD) will also appear and will execute using the user's ID. Any other area will not appear. If non-superusers without SAM privileges try to run SAM, they will receive a message that they must be superuser to execute SAM.

When running restricted versions of SAM, there are no shell escapes on terminals and the list menu is disabled. This prevents users from getting superuser access to restricted areas of SAM. You can also add your own applications to SAM and set them up for restricted access.
Thanks

Lijeesh N G_1
Respected Contributor

Re: Access to SAM using your own login

Hi,

use sam -r command, to configure non-root user to access SAM functionality.

Regards,
LIJEESH N G
Lijeesh N G_1
Respected Contributor

Re: Access to SAM using your own login

Hi,

>>Login as root Use sam -r command to enable access to Non root users.It will create a file with Non root username in /etc/sam/custom directory,confirm it.

>>Login as Non root user and use,
#/usr/sbin/sam command to access SAM or add the /usr/sbin path to PATH variable and use #sam command
Adding /usr/sbin to PATH variable,
#export PATH=$PATH:/usr/sbin


Regards,
LIJEESH N G
Marylou Kohlmeier
Frequent Advisor

Re: Access to SAM using your own login

$ sam
/bin/ksh: sam: not found

I exported PATH=$PATH: /usr/bin to my .profile but still get the error above when I tried to invoke "sam".

Marylou
Pete Randall
Outstanding Contributor

Re: Access to SAM using your own login

Try /usr/sbin.


Pete

Pete
Marylou Kohlmeier
Frequent Advisor

Re: Access to SAM using your own login

I did to no avail, still get the same error:

/bin/ksh: sam not found

MArylou
Pete Randall
Outstanding Contributor

Re: Access to SAM using your own login

As root, type "whence sam", then use the full path returned to invoke sam as a regular user. We can debug your path later.

# whence sam
/usr/sbin/sam


Pete

Pete
Marylou Kohlmeier
Frequent Advisor

Re: Access to SAM using your own login

root:/ #whence sam
/usr/sbin/sam

Then I what do I do next
Lijeesh N G_1
Respected Contributor

Re: Access to SAM using your own login

Hi,

Did you add privileges to Non root user with sam -r command? If it addedd, confirm the file with your Non root user name in /etc/sam/custom directory is exists.

Regards,
LIJEESH N G
Marylou Kohlmeier
Frequent Advisor

Re: Access to SAM using your own login

I did and the files exist, but still cannot use sam
-r-------- 1 root bin 643 Jul 22 10:20 default.tp
-r-------- 1 root other 1825 Jul 22 10:20 kohlmeim.cf
-r-------- 1 root other 1825 Jul 22 10:20 lundd.cf
Martín García
Occasional Advisor

Re: Access to SAM using your own login

Hi, try this

add the path /usr/sbin/sam to your PATH variable

PATH=$PATH:/usr/bin/sam
export $PATH

Martín García
Occasional Advisor

Re: Access to SAM using your own login

Sorry , i made a mistake

try this

add the path /usr/sbin/sam to your PATH variable

PATH=$PATH:/usr/sbin/sam
export $PATH


Dennis Handly
Acclaimed Contributor

Re: Access to SAM using your own login

>Martín: add the path /usr/sbin/sam to your PATH variable

Try again: add the path /usr/sbin
PATH=$PATH:/usr/sbin