System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

After about 5 minutes i can login to server.

 
SOLVED
Go to solution
Mousa55
Super Advisor

After about 5 minutes i can login to server.

Hi,

I've upgrade the operating system on the my server (rp8420) from 11.11 version to 11.23, And the
upgrade has been successfully but after upgrade I have a problem it’s When I try to telnet to this server
Show me a black screen and after about 5 minutes seems to me the login screen and then I can login to server.
And I can pinging, also I can login to server from the MP console. And I have checked all network configuration but
I don’t see any problem. How I can solve this problem?

root@ruxdb02 > lanscan
Hardware Station Crd Hdw Net-Interface NM MAC HP-DLPI DLPI
Path Address In# State NamePPA ID Type Support Mjr#
0/0/0/1/0 0x0017A43D1852 0 UP lan0 snap0 1 ETHER Yes 119
0/0/8/1/0/6/0 0x0016353EA05D 1 UP lan1 snap1 2 ETHER Yes 119
0/0/10/1/0/6/0 0x0016353EA193 2 UP lan2 snap2 3 ETHER Yes 119
0/0/12/1/0 0x001321EAA9DF 3 UP lan3 snap3 4 ETHER Yes 119
0/0/14/1/0 0x001321EAA93B 4 UP lan4 snap4 5 ETHER Yes 119

root@ruxdb02 > ifconfig lan3
lan3: flags=1843
inet 10.8.1.51 netmask ffffff00 broadcast 10.8.1.255

root@ruxdb02 > netstat -in
Name Mtu Network Address Ipkts Ierrs Opkts Oerrs Coll
lan3 1500 10.8.1.0 10.8.1.51 81392 0 58239 0 0
lo0 4136 127.0.0.0 127.0.0.1 50495 0 50495 0 0

root@ruxdb02 > netstat -rn
Routing tables
Destination Gateway Flags Refs Interface Pmtu
127.0.0.1 127.0.0.1 UH 0 lo0 4136
10.8.1.51 10.8.1.51 UH 0 lan3 4136
10.8.1.0 10.8.1.51 U 2 lan3 1500
127.0.0.0 127.0.0.1 U 0 lo0 0
default 10.8.1.1 UG 0 lan3 0


Thanks
17 REPLIES
Asif Sharif
Honored Contributor
Solution

Re: After about 5 minutes i can login to server.

Hi Nejad,

It is probably a DNS problem.Check your /etc/hosts also.

Regards,
Asif Sharif
Sunil Sheoran
Frequent Advisor

Re: After about 5 minutes i can login to server.

Hi

Check your /etc/resolve.conf file remove the wrong entry in case you do not have any dns server remove this file & try again.

Thanks & regards
Sunil Sheoran
DeafFrog
Valued Contributor

Re: After about 5 minutes i can login to server.

hi ,

what application on server ? what do you see in top o/p , ideal time .cpu usage in glance ? vmstat 5 5 , any page out ?

regards.

FrogIsDeaf
Mousa55
Super Advisor

Re: After about 5 minutes i can login to server.

Hi,

i don't have any DNS server, and i check the /etc/hosts file but problem is still.
/etc/resolve.conf:
No such file or directory

thanks
Sunil Sheoran
Frequent Advisor

Re: After about 5 minutes i can login to server.

Hi

Sorry for spel mistake that file name is /etc/resolv.conf.

Thanks & Regards
Sunil
Asif Sharif
Honored Contributor

Re: After about 5 minutes i can login to server.

Hi Nejad,

Did you try other services, e.g. ssh or rlogin?
are they working fine or same issue?

Regards,
Asif Sharif
Mousa55
Super Advisor

Re: After about 5 minutes i can login to server.

Hi,

the problem it's resolved when i remove the /etc/resolv.conf file i can telnet from a DOS without a problem. but it's still when using the Xmanager it's still can't connect to it


thanks
Sunil Sheoran
Frequent Advisor

Re: After about 5 minutes i can login to server.

Hi

What is the exect issue you are facing with xmanager.are you getting nay error? pls give some detaisl of issue.

thanks
Sunil
Asif Sharif
Honored Contributor

Re: After about 5 minutes i can login to server.

Check the following things,

#swlist -l product | grep -i cde
#ps -ef | grep dt
#ps -ef | grep xfs
#export DISPLAY=IP_ADDRESS
# echo $DISPLAY
#cat /etc/hosts

Regards,
Asif Sharif
Mousa55
Super Advisor

Re: After about 5 minutes i can login to server.

Hi All,

no error but only when i try to connect by xmanager, no output and give me connection failed

and this all command output

root@ruxdb02 > swlist -l product | grep -i cde
CDE B.11.23 HP-UX CDE User Interface
PHSS_31110 1.0 CDE Base Patch for Itanium - based system

PHSS_35884 1.0 CDE Base Patch
PHSS_35885 1.0 CDE Applications Patch

root@ruxdb02 > ps -ef | grep dt
root 2286 1 0 09:31:55 ? 0:00 /sbin/sh /usr/dt/bin/dtrc
root 2303 2286 0 09:31:55 ? 0:00 /usr/dt/bin/dtlogin
root 6842 6708 0 11:15:01 pts/ta 0:00 grep dt

root@ruxdb02 > ps -ef | grep xfs
root 51 0 0 09:21:48 ? 0:39 vxfsd
root 6848 6708 0 11:15:22 pts/ta 0:00 grep xfs

root@ruxdb02 > export DISPLAY=10.8.1.51
root@ruxdb02 > echo $DISPLAY
10.8.1.51
root@ruxdb02 > cat /etc/hosts
## Configured using SAM by root on Fri Jun 6 14:12:17 2008
## Configured using SAM by root on Mon Apr 5 08:16:37 2010
# @(#)B.11.11_LRhosts $Revision: 1.9.214.1 $ $Date: 96/10/08 13:20:01 $
#
# The form for each entry is:
#
#
# For example:
# 192.1.2.34 hpfcrm loghost





thanks
#
# See the hosts(4) manual page for more information.
# Note: The entries cannot be preceded by a space.
# The format described in this file is the correct format.
# The original Berkeley manual page contains an error in
# the format description.
#

127.0.0.1 localhost loopback
10.8.1.51 ruxdb02
Asif Sharif
Honored Contributor

Re: After about 5 minutes i can login to server.

DISPLAY variable must be set,

export DISPLAY=:0.0

Example
export DISPLAY=192.168.0.10:0.0

After that run the xmanager and update please.

Regards,
Asif Sharif
Mousa55
Super Advisor

Re: After about 5 minutes i can login to server.

Hi,

thanks but the problem is still.

root@ruxdb02 > echo $DISPLAY
10.8.33.57:0.0

thanks
Sunil Sheoran
Frequent Advisor

Re: After about 5 minutes i can login to server.

Hi,

Thanks for sahring the command o/p's

Please check the following command o/p

#hostname

is your o/p hostname is same as it appear in /etc/hosts in csae it is different please correct it. & do the below step also.
if it is same please the below steps & try again

#/sbin/init.d/dtlogin.rc stop
#/sbin/init.d/dtlogin.rc start

In case of any error in o/p please share.

Thanks & Regards
Sunil

Mousa55
Super Advisor

Re: After about 5 minutes i can login to server.

Hi,
thanks for replay

root@ruxdb02 > echo $DISPLAY
10.8.33.57:0.0
root@ruxdb02 > hostname
ruxdb02

root@ruxdb02 > /sbin/init.d/dtlogin.rc stop
root@ruxdb02 > /sbin/init.d/dtlogin.rc start

and it's still and please find the attached file.

thanks
Asif Sharif
Honored Contributor

Re: After about 5 minutes i can login to server.

Please check port is not blocked;

netstat -an | grep 177

Regards,
Asif Sharif
Sunil Sheoran
Frequent Advisor

Re: After about 5 minutes i can login to server.

Hi

Check for the below command & make sure your port is open .

#cat /etc/services |grep -i 177
xdmcp 177/tcp # X Display Manager Control Protocol
xdmcp 177/udp # X Display Manager Control Protocol

Thanks
Sunil
Mousa55
Super Advisor

Re: After about 5 minutes i can login to server.

Hi,

thanks for all the problem it's resolved when i remove some hostname/ip in /etc/hosts file


thanks again for all