System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

All the required rpc processes are running ?

masood bt
Regular Advisor

All the required rpc processes are running ?

have this:
hhln-b00-cie203:/ # ps -ef | grep -i rpc
root 1034 1 0 13:37:21 ? 0:00 /usr/sbin/rpcbind
root 1555 1 0 13:37:21 ? 0:00 /opt/dce/sbin/rpcd
root 6875 5866 0 10:55:25 pts/0 0:00 grep -i rpc
hhln-b00-cie203:/ #

I was trying to install a patch but it fails during analysis phase and throws up some network related errors. When I tried to see rpc I find only a couple of rpc processes running. How should I start others like rpc/lockd, rpc.statd etc

Thanks
Behind every Great fortune, there is a crime
7 REPLIES
Pete Randall
Outstanding Contributor

Re: All the required rpc processes are running ?

/usr/sbin/rpc.statd &
/usr/sbin/rpc.lockd &


Pete

Pete
masood bt
Regular Advisor

Re: All the required rpc processes are running ?

Thanks..here it is..

hhln-b00-cie203:/var/adm/sw/security # /usr/sbin/rpc.statd
hhln-b00-cie203:/var/adm/sw/security # /usr/sbin/rpc.lockd
hhln-b00-cie203:/var/adm/sw/security # ps -ef | grep -i rpc
root 1034 1 0 13:37:21 ? 0:00 /usr/sbin/rpcbind
root 1555 1 0 13:37:21 ? 0:00 /opt/dce/sbin/rpcd
root 8734 1 0 11:21:58 ? 0:00 /usr/sbin/rpc.lockd
root 8732 1 0 11:21:48 ? 0:00 /usr/sbin/rpc.statd
hhln-b00-cie203:/var/adm/sw/security #

Now any more processes needed to be present here in the list?
Behind every Great fortune, there is a crime
Pete Randall
Outstanding Contributor

Re: All the required rpc processes are running ?

Here's what I have:

# ps -ef |grep rpc |grep -v grep
root 949 1 0 Nov 25 ? 0:15 /usr/sbin/rpcbind
root 1569 1 0 Nov 25 ? 3:12 /opt/dce/sbin/rpcd
root 2008 1 0 Nov 25 ? 0:11 /usr/sbin/rpc.mountd
root 1063 1 0 Nov 25 ? 0:00 /usr/sbin/rpc.statd
root 1069 1 0 Nov 25 ? 0:00 /usr/sbin/rpc.lockd
daemon 2624 1124 0 Nov 25 ? 0:00 rpc.cmsd
root 2610 1124 0 Nov 25 ? 0:00 /usr/dt/bin/rpc.ttdbserver


The last one, I think, is the ToolTalk database, which I can't imagine you need, so that leaves rpc.cmsd which seems to be CDE related. You might want to try it:

/usr/dt/bin/rpc.cmsd &


Pete

Pete
Pete Randall
Outstanding Contributor

Re: All the required rpc processes are running ?

Oh - I missed mountd!

/usr/sbin/rpc.mountd &


Pete

Pete
masood bt
Regular Advisor

Re: All the required rpc processes are running ?

yeah..I started mountd.. here on another note here is my actual prob:

I tried to install the LDS patch (oracle Application patch)
Using this command
swinstall -x autoreboot=true -x patch_match_target=true -s hhln-mgt-ign101:/var/spool/sw/patch_OraAppServ/depot \* @ hhln-b00-lds201

After an hour of analysis, I have got the below error messages.

hhln-b00-lds201:/ # swjob -a log hhln-b00-lds201-0052 @ hhln-b00-lds201:/
======= 03/09/09 21:16:44 GMT BEGIN install AGENT SESSION (pid=19766)
(jobid=hhln-b00-lds201-0052)

* Agent session started for user "root@hhln-b00-lds201".
(pid=19766)

* Beginning Analysis Phase.
* Source:
hhln-mgt-ign101:/var/spool/sw/patch_OraAppServ/depot
* Target: hhln-b00-lds201:/
* Target logfile: hhln-b00-lds201:/var/adm/sw/swagent.log
* Reading source for product information.
ERROR: RPC exception: "Connection closed (dce / rpc)" 03/09/09
21:58:39 GMT
ERROR: Could not open remote depot/root
"/var/spool/sw/patch_OraAppServ/depot" due to an RPC or
network I/O error.
* Retry number 1 of 1 for product information.
ERROR: RPC exception: "Connection closed (dce / rpc)" 03/09/09
22:22:37 GMT
ERROR: Could not open remote depot/root
"/var/spool/sw/patch_OraAppServ/depot" due to an RPC or
network I/O error.
ERROR: Cannot open source. Check above for errors, as well as the
daemon logfile on the source host (default location:
/var/adm/sw/swagentd.log).
ERROR: Cannot continue the Analysis Phase until the previous errors
are corrected.



hhln-b00-cie203:/ # /sbin/init.d/dce start
Beginning DCE startup...
NOTE: No components of DCE are configured.

Finished DCE startup.
hhln-b00-cie203:/ #
Behind every Great fortune, there is a crime
Johnson Punniyalingam
Honored Contributor

Re: All the required rpc processes are running ?

Hi Masood,

Copy the depot to your local system and try installation.

The actual cause of the problem seems to be a loss of network communication. Looks like you were doing the install from remote Server.

Thanks,
Johnson
Problems are common to all, but attitude makes the difference
masood bt
Regular Advisor

Re: All the required rpc processes are running ?

did swcopy..
Behind every Great fortune, there is a crime