BladeSystem Forums have moved here
To make BladeSystem information easier to find, we have moved the BladeSystem forums here, to Servers and Operating Systems.
System Administration
Showing results for 
Search instead for 
Do you mean 

Autofs is not working on HP-UX 11.31

SOLVED
Go to Solution
Super Advisor

Autofs is not working on HP-UX 11.31

Hi All,

I would like to configure autofs on HP-UX 11.31.

I would like auto mount server1:/var to /data of client1.

/var of server1 has shared in /etc/dfs/dfstab.

I have done following configurations in client1

1)#more /etc/auto_master

/net -hosts -nosuid,soft,nobrowse
/- /etc/auto_direct


2)# more /etc/auto_direct

/data -nosuid server1:/var

3)# /sbin/init.d/autofs stop
# /sbin/init.d/autofs start

4)# cd /data

Here the system is hanging.

Are the above stpes correct?

How to solve this issue?



9 REPLIES
Honored Contributor

Re: Autofs is not working on HP-UX 11.31

what happens if you attempt to manually mount server11:/var someplace, does it hang or succeed?

If hangs, the problem is most likely with server1. Did share it out after updating the dfstab?
Exalted Contributor

Re: Autofs is not working on HP-UX 11.31

Shalom,

Check permissions on the configuration files for autofs.

It has been known to cause problems on this platform and OS if execute (x) permissions are on the auto* files.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Regular Advisor

Re: Autofs is not working on HP-UX 11.31

Did you happen to start/restart the nfs services on the client?

Also is NFS started on the source machine?
Super Advisor

Re: Autofs is not working on HP-UX 11.31

Hi All,

I am able to mount manually.

Is above configurations are correct?
Outstanding Contributor

Re: Autofs is not working on HP-UX 11.31

> 4)# cd /data

Try "cd /net/data" instead. Also take a look at bdf output - you should be able to see /data mounted.


Pete

Pete
Super Advisor

Re: Autofs is not working on HP-UX 11.31

Hi Pete,

I am able to access "cd /net/server1/var".

Outstanding Contributor

Re: Autofs is not working on HP-UX 11.31

That is the way automounter - sorry, autofs - works. A reference to a file system on another host causes autofs to automatically mount this file system on the mount point specified in /etc/auto_master - in your case /net.


Pete

Pete
Honored Contributor

Re: Autofs is not working on HP-UX 11.31

of course, you could simply mount it, via NFS, at boot time, if that suits our needs.
Exalted Contributor

Re: Autofs is not working on HP-UX 11.31

Seems to be working after a fashion.

did permissions on the auto* files have any impact?

Can you post the files, there may be something that we can work out for you with configuration syntax.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com