System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Automatically changed the disk device files

SOLVED
Go to solution
Narendra Uttekar
Regular Advisor

Automatically changed the disk device files

Hi,
I don't know how automatically the disk device files got changed. I am using the HP VA7100 storage and earlier my device file was /dev/dsk/c6t12d1 and /dev/dsk/c10t14d1 in VG vgdb02 and now when i am doing ioscan i am able to see the disk device file but it got changed to /dev/dsk/c9t0d1 and /dev/dsk/c18t0d1. And now i am not able to activate the VG vgdb02...Please let me know how to activtae vgdb02 and how to resolve the problem of this changed disk device files.
4 REPLIES
Sachin Kumbla
Frequent Advisor

Re: Automatically changed the disk device files

Hi

you need to import the vg on the new device path

vgimport -v vgname

vgchange -a y vgname

Rgds.,
Sachin Kumbla.
Horia Chirculescu
Honored Contributor

Re: Automatically changed the disk device files

Hello,

Yes, you must import the vgdb02 but in order to do that you must first export the same VG.

See:

strings /etc/lvmtab

Horia.
Best regards from Romania,
Horia.
Matti_Kurkela
Honored Contributor
Solution

Re: Automatically changed the disk device files

Maybe someone replaced a SAN switch and did not tell you?

The standard procedure in a situation like this:

1.) find out the minor device number of vgdb02:

ll /dev/vgdb02/group

The response will be something like:
crw-r--r-- 1 root disk 64, 0xNN0000 /dev/vgdb02/group

The minor device number is 0xNN0000, where NN can be any hex digits. Remember the correct number, you will need it later.

2.) export the VG, creating a map file that includes the VGID:

vgexport -v -s -m vgdb02.map vgdb02

3.) re-create the VG directory and the group file, because the vgexport deleted it:

mkdir /dev/vgdb02
mknod /dev/vgdb02/group c 64 0xNN0000

(Use the correct minor device number you got from step 1 instead of 0xNN0000.)

4.) re-import the VG, using the -s option to auto-find the VG disks using the VGID in the map file:

vgimport -v -s -m vgdb02.map vgdb02

Now the volume group is again in a normal state and you should be able to activate it as usual:

vgchange -a y vgdb02

(or if it's a Serviceguard cluster VG, then just start the package instead)

MK
MK
Narendra Uttekar
Regular Advisor

Re: Automatically changed the disk device files

Thanks Matti Kurkela for the excellent solution. I was able to fix the problem with your solution.