System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

B180L Browser Issues on HP-UX 11.11

 
Dan Vowell
Occasional Advisor

B180L Browser Issues on HP-UX 11.11

This legacy Visualize workstation had 11i v1 installed using the Dec2006 TCOE media with additional browsers selected.

(Mozilla, Firefox, Thunderbird).

 

The Mozilla browser launches but the terminal window in the background gets an error message:

LoadPlugin: failed to initialize shared library /opt/java1.5/jre/plugin/PA_RISC2.0/mozilla/libjavaplugin_oji.sl (Exec format error]

 

I'm guessing I need to point to some PA_RISC1.1 java1.4 stuff??

 

The Firefox browser will not launch, but gives a different error message:

/opt/firefox/run-mozilla.sh[36]: /opt/firefox/firefox-bin: Execute permission denied.

If I do a "file firefox-bin" it comes back with PA-RISC2.0 crap and this workstation is running the 32-bit OS version, that's all it's capable of.

 

The Thunderbird browser will not launch, but gives an entirely different error message as well:

/usr/lib/dld.sl: Bad system id for shared library: /opt/gtk2.6/lib/libgtk-x11-2.0.sl

/usr/lib/dld.sl: Exec format error

/opt/thunderbird/run-mozilla.sh[36]: 5677 Abort(coredump)

 

You can see that the GTK library in the above error message is PA-RISC2.0 .....again!!!   AARGGH!!!

 

What am I overlooking here, guys??   The Release Notes are not all that helpful.

 

How do I get one of these three browsers to respond correctly on this old box??

 

Kindest regards and thanks for your help

"Your mileage may vary"
3 REPLIES
Dennis Handly
Acclaimed Contributor

Re: B180L Browser Issues on HP-UX 11.11 (PA1.1)

>This legacy Visualize workstation had 11i v1 installed using the Dec2006 TCOE

 

You are out of luck, I'm not sure if B180L was even supported on 11.11?

As of 2004, it was listed as supported here:

http://bizsupport1.austin.hp.com/bc/docs/support/SupportManual/c01911869/c01911869.pdf

 

But it wasn't listed in the 2006 version. 

 

>I'm guessing I need to point to some PA_RISC1.1 java1.4 stuff??

 

If it still exists.

 

>If I do a "file firefox-bin" it comes back with PA-RISC2.0 crap and this workstation is running the 32-bit OS version, that's all it's capable of.

 

When was your firefox created?

 

>The Release Notes are not all that helpful.

>How do I get one of these three browsers to respond correctly on this old box?

 

Release Notes for what product?  The IUG says not supported in 2006.  So it is not likely that firefox RN would even mention it.

V. Nyga
Honored Contributor

Re: B180L Browser Issues on HP-UX 11.11

In general it should work:

http://www.openpa.net/systems/hp-visualize_b132l_b160l_b180l.html

11iv1 is listed there.

 

What does 'java -version' says?

 

HP has changed all sites:

http://www.hp.com/products1/unix/java/java2/jpi/downloads/index_pa-risc.html ???

 

maybe this one helps:

https://h20392.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=HPUXJAVAHOME

 

For Firefox:

>Execute permission denied

You can change permissions - if it runs then .... you have to test.

 

V.

*** Say 'Thanks' with Kudos ***
Dennis Handly
Acclaimed Contributor

Re: B180L Browser Issues on HP-UX 11.11 (PA1.1)

>>Execute permission denied

>You can change permissions - if it runs then .... you have to test.

 

Not in this case, it also likely has: /usr/lib/dld.sl: Exec format error