System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

BCH doesn't activate my Fibre Channel card's laser

SOLVED
Go to solution
mvpel
Trusted Contributor

BCH doesn't activate my Fibre Channel card's laser

Hi everyone,

I've got a situation here which I'm sure will be clear to someone who has a solid understanding of LIF/BCH/ISL mechanics.

We have a Superdome system which we just reinstalled, and which was up and running for a few days prior to a simple reboot.

When it came back up following the reboot, it was unable to find its boot hardware.

We identified that the A5158 1Gb Fibre Channel card was not active - the transmit laser was not on - and so once it got to the BCH it was unable to see any of the disks attached to that card.

However, when we boot the partition off of an Ignite DVD - the one used to install it originally - once it brings up the Ignite shell the link light turns on on the FC card and it is able to see all of the disks in the array and stands ready to install the OS.

So I'm wondering if there may be some simple configuration issue which is preventing the BCH from activating the FC card properly to allow it to be used as a boot device.

I checked the "COC" core cell setting, and it's referring correctly to cell 3 as the core cell, which has the CIO card installed.

When I do a "SEARCH," it recognizes that the adapter is present at the proper hardware path along with the random-access DVD drive:

3/0/4/0/0.0.255 FCP Protocol Adapater
3/0/5/0/0.1 Random Access Media

... but it doesn't identify any bootable disks because the fiber link is inactive.

I don't think this is an issue of a problem in the LIF of the boot disks, because in order for it to identify such a problem, it would have to turn on the laser in the A5158 card and establish a link to the disk array, which it's not doing.

Thanks for any suggestions you can offer.
5 REPLIES
Steven E. Protter
Exalted Contributor

Re: BCH doesn't activate my Fibre Channel card's laser

Shalom,

I don't think is a simple installation issue.

I think the card is defective. Try booting the system off the alternate card.

You might try a different piece of fiber cable, though why Ignite activates the laser and the boot process does not, is a mystery.

Other things to check:
1) Firmware on the HBA
2) Firmware on the switch. I ran into an issue last year where a system stopped booting because the cisco switch firmware was out of date. No explanation why this was so sudden.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
mvpel
Trusted Contributor

Re: BCH doesn't activate my Fibre Channel card's laser

HP field support was just here about 30 minutes ago and replaced the A5158 card with a new unit. We also saw the same behavior from a card we borrowed from a fully operational system - no laser, no link light.

The firmware on the HBA should not be an issue, because the system booted from and was running on the card for years prior, and for three days following the re-install.

The card is not connected to a switch, it's plugged directly into the enclosure services controller on the FC10 disk array.
mvpel
Trusted Contributor

Re: BCH doesn't activate my Fibre Channel card's laser

Okay, now I really don't understand.

I booted manually from the alternate path ("bo alt") after I noticed that it was not set to automatically boot from it, and it appears to be loading the kernel... and lo and behold the system is coming up.

And what is mystifying me now is why this target 5 didn't appear as a bootable path in the search command...

Let me check out the mirror status when things come back online and see what's what.
chris huys_4
Honored Contributor
Solution

Re: BCH doesn't activate my Fibre Channel card's laser

Hi,

On BCH level, the fibercards are still not logged in into the fabric, and the search on bch level on a pa-risc system, will also not make the fibercard to log in into the fabric, due to concerns of a sansearch from the bch level, creating to much overhead on the san..

So a search at the bch level, will never reveal a "bootdisk" behind a fc hba.

NOTE: with itanium, its possible, , to list the "san", from the efi-level, but also this is not standard and needs to be enabled.

So to check what is going on with the "primary path" bootdisk, just check from the "booting" alternate bootpath, if the "primary bootdisk bootpath" you are trying to boot from, is actually a bootpath that contains a bootdisk , through f.e. importing the "vg00 bootdisk of the primary bootpath" as a datavolumegroup on the "bootdisk of the alternate bootpath" and trying to mount the / and /stand directories of the "bootdisk of the primary bootpath" "on" f.e. /primarybootroot and /primarybootstand and check if its contents looks "ok"..

Greetz,
Chris



mvpel
Trusted Contributor

Re: BCH doesn't activate my Fibre Channel card's laser

Chris,

Thanks, that's just the information I needed to get a better handle on what's going on with the system. I didn't realize that the lack of a boot disk on FC with a BCH search was normal.

It appears that the LIF on the primary path was bad, and after I ran a new mkboot on it the system was able to boot normally.

Thanks, I appreciate it!