cancel
Showing results for 
Search instead for 
Did you mean: 

Bastille issue

maxell_1
Frequent Advisor

Bastille issue

Hi,

I am having problem to launch Bastille on my Itanium 11iv3 platform as below. Any help appreciated. Thanks

******************************************
# bastille
NOTE: Valid display found; defaulting to Tk (X) interface.
NOTE: Using Tk user interface module.
NOTE: Only displaying questions relevant to the current configuration.
NOTE: Bastille is scanning the system configuration...
WARNING: An attempt to get the network host entry for "svr10g1" failed.
This may result in denial of access to users and agents at
this host. Check the spelling of this name, then your
"/etc/hosts" file, or your "/etc/resolv.conf" file and DNS
resolver configuration. The nslookup program may be helpful
in isolating this problem.
WARNING: An attempt to get the network host entry for "testSvr1" failed.
This may result in denial of access to users and agents at
this host. Check the spelling of this name, then your
"/etc/hosts" file, or your "/etc/resolv.conf" file and DNS
resolver configuration. The nslookup program may be helpful
in isolating this problem.
NOTE: No pre-existing config-file found at:
/etc/opt/sec_mgmt/bastille/config Bastille will set answers to default
values.
40aa4374 is not a hash at /opt/perl_32/lib/site_perl/5.8.8/IA64.ARCHREV_0-thread -multi/Tk/MainWindow.pm line 55.
/opt/sec_mgmt/bastille/bin/bastille[390]: 23393 Abort(coredump)

******************************************
7 REPLIES
Jestin John Chacko
Regular Advisor

Re: Bastille issue


Dear,
Please go through this link
http://www.docs.hp.com/en/5992-3373/ch08s04.html
Steven E. Protter
Exalted Contributor

Re: Bastille issue

Shalom,

Key issue: An attempt to get the network host entry for "svr10g1" failed.

nslookup svr101g1
ping svr101g1

There is an inconsistency between the hostname and perhaps the DISPLAY variable.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Basheer_2
Trusted Contributor

Re: Bastille issue

echo $DISPLAY

if it is not set properly, then set it using export DISPLAY=your-IP-ADDr:0.0

try again

what does ping xvr10g1 reports
Torsten.
Acclaimed Contributor

Re: Bastille issue

Check "nslookup svr10g1" and see what it returns, if you get no or incorrect results, correct this first.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
maxell_1
Frequent Advisor

Re: Bastille issue

Hi Guys, thanks for the beautiful answers.

FYI, the server's hostname that Iam running Bastille is "svr10g4", why is it looking for "svr10g1" which is another server in my network?

Thanks
maxell_1
Frequent Advisor

Re: Bastille issue

This is the update. Have updated my /etc/hosts to have an entry for 'svr10g1'. I am trying to run Bastille through a X client on my laptop (192.168.1.159), thus have also set the DISPLAY variable. But still not able to launch Bastille. Below is the complete output. Appreciate your help. Thanks.

****************************************
# ping svr10g1
PING svr10g1: 64 byte packets
64 bytes from 192.168.1.201: icmp_seq=0. time=0. ms
64 bytes from 192.168.1.201: icmp_seq=1. time=0. ms

----svr10g1 PING Statistics----
2 packets transmitted, 2 packets received, 0% packet loss
round-trip (ms) min/avg/max = 0/0/0
# export DISPLAY=192.168.1.159:0.0
# xhost +
access control disabled, clients can connect from any host
# bastille
NOTE: Valid display found; defaulting to Tk (X) interface.
NOTE: Using Tk user interface module.
NOTE: Only displaying questions relevant to the current configuration.
NOTE: Bastille is scanning the system configuration...
NOTE: No pre-existing config-file found at:
/etc/opt/sec_mgmt/bastille/config Bastille will set answers to default
values.
40aa4374 is not a hash at /opt/perl_32/lib/site_perl/5.8.8/IA64.ARCHREV_0-thread-multi/Tk/MainWindow.pm line 55.
/opt/sec_mgmt/bastille/bin/bastille[390]: 22904 Abort(coredump)

****************************************

Paolo Del Monte
Occasional Visitor

Re: Bastille issue

Hi Maxell
I've the same problem starting bastille:

40dae868 is not a hash at /opt/perl_32/lib/site_perl/5.8.8/IA64.ARCHREV_0-thread-multi/Tk/MainWindow.pm line 55.
/opt/sec_mgmt/bastille/bin/bastille[390]: 26022 Abort(coredump)

Have you found a solution?
Thanks
Paolo