System Administration

Big problems with Compaq Deskpro 4000

 
Nabil A
New Member

Big problems with Compaq Deskpro 4000

Hi all,

I have a big problem with my Compaq Deskpro 4000 5200MMX.

It first runned Windows, then I installed Linux (deleted old windows and did some partitioning) now I can't get into the BIOS.

I can't boot into Linux because my user/pass are not O.K. so I wan't to install a new OS (RedHat 9). The problem is I need to change the boot sequence that it will boot from CD, but like I sayd I can't get into the BIOS.

Ive tried downloading Computer Setup/VP and PC Diagnostics on my other PC, but it doesn't do anything if I press the space bar.

So what I exactly need is some files or something which I can copy to a floppy so that the system will boot from floppy and will install the BIOS interface somehow or let me access the BIOS settings.

That's not my only problem, the second problem is that I need the server running within 2 days!

Help would be great!!

Thanks in advance,
Nab
4 REPLIES 4
Huc_1
Honored Contributor

Re: Big problems with Compaq Deskpro 4000

Usualy F2 or del key get you into bios, but I do not know hos this Deskpro 4000 does it but !

if you have linux installed you can boot into single user from the console if it start with grub or lilo.

at grub will highligh the kernel is is booting

type the letter e

this will get you into edit mode go to the end of the second line enter 1 followed by a carriage return this will get you out of edit mode

type the letter b to boot linux

the letter 1 in the above example means single user mode

so you will boot up to the root promtp
and no password will be ask for

from there just type in

#passwd

and give it a password that you remenber you
can then reboot or just do a ^d to continue the boot process.

if you boot from lilo you type a just after lilo prompt appears and then you type
linux 1 followed by enter

this will also get you into single user mode
so same as above from here on


once into your linux you will have no problem installing and partitioning for this new linux.

Jean-Pierre
Smile I will feel the difference
Steven E. Protter
Exalted Contributor

Re: Big problems with Compaq Deskpro 4000

If there is no way to beat the bios password then you have little choice but the following:

1) boot of a bios flash disk made to reset the bios. Consult the website in compaq for that. I doubt such a thing actually exists.

2) Replace the bios chip.

I don't think either thing can be accomplished in two days unless Compaq built a backdoor.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Sยภเl Kย๓คг
Respected Contributor

Re: Big problems with Compaq Deskpro 4000

Nabil

1.See you can use the bios flash floppy to boot in to BIOS and make the changes.
2. If u are not able to do that
create a instllatin floppy disk for linux.Then boot through that install the os from the cd

regards
SK
Your imagination is the preview of your life's coming attractions
Nabil A
New Member

Re: Big problems with Compaq Deskpro 4000

First of all, thanks for the replies! You guys are great.

I have downloaded the 3-floppies-set and tried to install the BIOS which didn't work, but opening the BIOS actually worked, so i've installed my new operating system and everything goes fine now.

Sorry I didn't reply sooner..

Anyway, thanks for the help!!

Greetings,