cancel
Showing results for 
Search instead for 
Did you mean: 

Booting Using Genvmunix

Alice Daniel
Frequent Advisor

Booting Using Genvmunix

I've added new hardware and am using the following cmd to try to get to the generic boot but am having problems getting the gen boot to complete:
The env vars are:
auto_action HALT
boot_osflags ""
boot_reset OFF

"Shutdown -h now"

P00>>> "boot -fl s -fi genvmunix"

GET the FOLLOWING MSGS:

INIT: SINGLE-USER MODE
#

at the # prompt, typed exit Then get:

halted CPU0
CPU1 is not halted
halt code = 6
double error halt
PC = fff...0026c580
P00>>>
halted CPU1
halt code = 5
halt instruction executed
PC = fff...0026cf80
P00>>>

This is on an ALPHA DS20E TRU64 4.0f

Why won't the genvmunix complete the boot?

What(if any) sys envars are not set correctly?

Thanks for any help

4 REPLIES
Abdul Rahiman
Esteemed Contributor

Re: Booting Using Genvmunix

System is booting to single user mode because of the boot flag that was used (-fl s) and this would override the SRM variable boot_osflags.

I think, you should press Ctrl/D tp to get continue to multiluser mode.

btw, you should improve your point assignement ratio to attract more repsonses..

regds,
Abdul.
No unix, no fun
Ralf Puchner
Honored Contributor

Re: Booting Using Genvmunix

"fl -s" means single user mode.

A "double error halt" means an error occured in low level code while an error was being processed/handled/logged. It is another indication of BAD HARDWARE.

So please open a call within the HP support center to check hardware (and please don't post the binary.errlog - it is useless without deep knowledge of the Alpha CPU/hardware registers - thanks!)


Help() { FirstReadManual(urgently); Go_to_it;; }
Michael Schulte zur Sur
Honored Contributor

Re: Booting Using Genvmunix

Hi,

I hope, you did not add the hardware while the machine was running.
What was it? A new cpu?
Usually boot_osflag is set to A.
Any reasons, your's is empty?

greetings,

Michael
Ravi_8
Honored Contributor

Re: Booting Using Genvmunix

Hi,

the command "boot -fl s -fi genvmunix"

boots the machine in single user mode using genvmunix file as kernel.

at the # prompt to get into multiuser mode(complete the boot, what is you are saying)you have to specify "init 3". so the machine will get into run level 3 from single user mode.
"exit" wouldn't bring the machine higher run level from single user mode.
never give up