System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Booting an rp3410 from an EMC VNX5300

Tom Dawson
Regular Advisor

Booting an rp3410 from an EMC VNX5300

Hi,

This not was originally prepared for EMC's support. I apologize if it uses some EMC vocabulary cryptically.

We are unable to get a HP9000 running HP-UX v11.23 to boot from an EMC
VNX5300. I think the VNX models are a CLARiiON replacement. We are connected across a fabric with two Cisco MDS-C9148
switches. There is one A6795A 2Gbs HBA in the server yielding two
paths to the one disk we have assigned on the VNX5300.

While booted to an internal disk, we can see boths paths to the
disk. We have succesfully performed an Ignite install to the disk
on the VNX5300. But when the server reboots after the install,
the boot process hangs at the "Boot IO Dependent Code (IODC) revision 8"
message.

Below I have listed all the items we've verified to ensure our
configuration is correct. There are only three items I'm not sure
of. They are footnotes 55, 58, and 60 on pages 192 - 194 of the
Support Matrix.

Does anyone know which "firmware" EMC may be referring to? And how I check the level from HP-UX?

These are the documents we are using and the items I think pertain
to our environment:

EMC Support Matrix
HPQ HP-UX
June 2011
P/N 300-000-166
ECO 80650 Rev C22

Page 147, Item 55:

Hewlett Packard
HP 9000: rp3410-021, 2, 3; rp3440-041, 3,

Hewlett Packard PCI-X HP-UX 11i v2 (HP-UX 11.23)50

Hewlett Packard
A6795A -- 20, 21, 43, 44, 45, 46, 47, 48, 49

FC-AL, FC-SW

EMC Unified Storage VNX5100/5300/5500/5700/7500 (Block)

External Boot: Y
23,24,
25, 27, 29,
30, 31, 32,
33, 34, 37,
38, 51, 52,
53, 54, 55,
56, 57, 58,
59, 60, 61,
62, 63, 64,
65, 66, 67,
68,69

- - - - - - - - - - - - - - - - - - - - - - - - - - - - -

A6795A Footnotes: ( Pages 192 - 194 )

20: FC-AL and FC-SW cannot co-exist on the same HBA. FC-SW Only
21: Auto-sensing capability on the HBA is permanently enabled. There is no option to disable auto-sensing on the HBA.
43,44,45,46,47,48,49: Driver is at Version 11.23.0803 ( The latest available for HP-UX 11.23 )

External Boot Footnotes: ( Pages 192 - 194 )

23: rp7400/N4000 -- N/A
24: Requires minimum PDC firmware 42.06. We are at 44.11.
25: rp8400/rp7410 -- N/A
27: AB465A -- N/A
29: FC-AL -- N/A ( We are FC-SW )
30: AB465A -- N/A
31: Rp7420/Rp8420 -- N/A
32: Requires minimum PDC firmware 42.09. We are at 44.11.
33: AB465A -- N/A
34: The rp4440/rp34x0 server models require PDC firmware 44.06 or higher to support external boot. We are at 44.11.
37: FC-SW 2-Gbit boot and/or dump using A6795A requires Auto-Negotiation flag to be enabled on the switch port the HBA is attached to.
Auto-Negotiation is set on the switch port.
38: AB465A -- N/A
51: Rx5670 -- N/A
52: Rx7620/Rx8620 -- N/A
53: A6826A -- N/A
54: The A6795A EFI driver must be upgraded to version 1.10 to support boot. We are at version 1.17.
55: Requires minimum system firmware 2.03 or higher. I'm not sure to what firmware this is referring.
56: Rx4640-8 -- N/A
57: AB465A -- N/A
58: HP Minimum System fw 1.9.0 required. I'm not sure to what firmware this is referring.
59: NEC NX7700i 3080A/3020A -- N/A
60: HP Minimum System fw 2.21 required. I'm not sure to what firmware this is referring.
61: NEC i-PX9000/A,i-PX9000/S -- N/A
62: HP Rx7620/Rx8620 -- N/A
63: HP-UX Rx2620 -- N/A
64: HP Rx1600/Rx2600 -- N/A
65: HP-UX Rx2620 -- N/A
66: AB465A -- N/A
67: NEC i6010/9010/9510/6510/3020M-8/3040H-16/3040M-16/3080H-32 -- N/A
68: HP Requires minimum EFI driver version 1.10 or Higher to support external boot with the A6795A. We are at version 1.17.
69: HP Integrity Superdome -- N/A

- - - - - - - - - - - - - - - - - - - - - - - - - - - - -

EMC Host Connectivity Guide
for HP-UX
P/N 300-000-614
REV A34
Published February, 2011

Model: VNX5300
Serial Number: APM00111401883
Software Version: 05.31.000.5.008

Write Cache: Enabled
Initiator Type: HP No Auto Trespass
Failover Mode: 0 -- Legacy failovermode; Native LVM PV Links failover, paths to both SPs

Both Initiator records are "Registered".
ArrayCommPath: Enabled
Unit Serial Number: Array

Unishpere Agent is installed.
We have "NoMegaPoll" at the start of the agent.config file.

ISL Revision A.00.44 Mar 12, 2003

- - - - - - - - - - - - - - - - - - - - - - - - - - - - -

While booted to an internal disk ( 0/1/1/1.2.0 ) we can see both paths to
the disk on the VNX5300:

flo1cswtst /homeroot # ioscan -fnC disk
Class I H/W Path Driver S/W State H/W Type Description
=============================================================================
disk 0 0/0/2/0.0.0.0 sdisk CLAIMED DEVICE _NEC DVD+-RW ND-6650A
/dev/dsk/c0t0d0 /dev/rdsk/c0t0d0
disk 1 0/1/1/1.2.0 sdisk CLAIMED DEVICE HP 36.4GST336754LC
/dev/dsk/c3t2d0 /dev/rdsk/c3t2d0
disk 2 0/4/1/0.49.0.0.0.0.0 sdisk CLAIMED DEVICE DGC VNX5300WDR5
/dev/dsk/c6t0d0 /dev/rdsk/c6t0d0
disk 3 0/4/1/0.49.1.0.0.0.0 sdisk CLAIMED DEVICE DGC VNX5300WDR5
/dev/dsk/c7t0d0 /dev/rdsk/c7t0d0
flo1cswtst /homeroot #

And, as stated earlier, when we try to boot to the VNX5300 disk,
we get hung up here:

Main Menu: Enter command or menu > bo 0/4/1/0.49.0.0.0.0.0
Interact with IPL (Y, N, or Cancel)?> n

Booting...
Boot IO Dependent Code (IODC) revision 8

- - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Any suggestions on what I can do from the HP-UX side to determine why we are not booting?

Thanks,
Tom Dawson
4 REPLIES
Rita C Workman
Honored Contributor

Re: Booting an rp3410 from an EMC VNX5300

Hello Tom,

Did you run an emcgrab and send it off to get a HEAT report?

Just recently did somethings on an rp4440 running 11.23 using the A6795A Tachyon HBA heading to a VNX (can't remember the version).
The following are the firmware versions allowed:
11.23.03
11.23.0512
11.23.0709
11.23.0712
11.23.0803
11.23.0903
11.23.0909

Now when you go out to HP to download firmware you will not find all these versions. You can download from here:

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=311422&prodTypeId=329290&prodSeriesId=311420&swLang=13&taskId=135&swEnvOID=7


Hope this helps,
Rita
Tom Dawson
Regular Advisor

Re: Booting an rp3410 from an EMC VNX5300

Rita,

Thank you. I found that page and downloaded and installed the 11.23.0803 firmware. That was the latest available for 11.23.

I also downloaded a newer version of the EFI Driver. But I haven't installed it yet. Do you happen to know where I could find instructions for installing the EFI Driver?

Thanks,
Tom
Torsten.
Acclaimed Contributor

Re: Booting an rp3410 from an EMC VNX5300

The EFI driver is not relevant, because your system has no EFI at all.

Only PDC firmware of the server and firmware of the HBA are important here.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Tom Dawson
Regular Advisor

Re: Booting an rp3410 from an EMC VNX5300

Torsten,

Thank you for verifying that. I had suspected that was the case. But over the years I've learned that there's always something else I don't know.

Tom