HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Buffer cache/UFC does not grow

 
SOLVED
Go to solution
Emil Velez
Honored Contributor

Buffer cache/UFC does not grow

I have a unusal situation with my 11.31 RX system

Normally when I copy files over and over the file is cached in the buffer cache and the cache grows.

On my rx2600 the filecache stays at 200MB and my buffer cache is 32k.

The filecache_min=5%
filecache_max=50%

but it does not grow and copying files are always the same speed ?

Am I missing a tuneable to turn on caching or is there a patch to make buffer cache work.

Points will be provided.
Thanks for all help
5 REPLIES
Don Morris_1
Honored Contributor

Re: Buffer cache/UFC does not grow

There's no option to turn on caching, no. It is simply on.

Additional data would help here:

1) The filecache stays at 200Mb... out of? [Is this 5%? 50%?] How did you determine this (what tool, exact output preferably)

2) How many files / size of files? (Are the files perhaps just already in the cache in the first place? Is there so much file data that you always push the pages from the first set of files out from the cache by the time you get to the last set?)

3) What's the memory pressure on the rest of the system, anyway? min/max means that the File Cache will try to grow from min to max -- but it does not do so [and will release memory] if there is memory pressure.
Emil Velez
Honored Contributor

Re: Buffer cache/UFC does not grow



I copied the kernel file about 4 or 5 times

timex cp /stand/vmunix /tmp/file1
5 seconds
timex cp /stand/munix /tmp/file2
5 seconds
timex cp /tmp/file1 /tmp/file2
5 seconds

This should be very very very fast

The system is in idle
It has 4 GB of memory 2.5 GB of which is unused.
Don Morris_1
Honored Contributor
Solution

Re: Buffer cache/UFC does not grow

Is /stand VxFS (and /tmp as well)?

If so -- check the VxFS direct I/O tunable( 'vxtunefs /stand |grep discovered_direct_iosz'). That tunable sets the size that VxFS doesn't use the file cache and instead does unbuffered direct I/O... and since I'm sure your vmunix is more than 256Kb, that's almost certainly over what appears to be the default.

Example of effect:

[{root}3227]$ vxtunefs /tmp |grep discovered_direct_iosz
discovered_direct_iosz = 262144
[{root}3230]$ vxtunefs /stand |grep discovered_direct_io>
discovered_direct_iosz = 262144

[{root}3231]$timex cp /stand/vmunix /tmp/file1;timex cp /stand/vmunix /tmp/file2;timex cp /tmp/file1 /tmp/file2

real 3.34
user 0.00
sys 0.18


real 2.88
user 0.00
sys 0.16


real 5.28
user 0.00
sys 0.06

Setting discovered_direct_iosz to 536870912 (512Mb) gives:
real 0.28
user 0.00
sys 0.22


real 0.26
user 0.00
sys 0.24


real 0.27
user 0.00
sys 0.27

Note, this is after I had already done this once -- my first run, the original copy took 0.93 real / 0.0 / 0.29 sys... and since I haven't really generated any memory pressure, those pages were very likely hanging around the file cache still, hence the copies all used those pages and got the faster times.
Emil Velez
Honored Contributor

Re: Buffer cache/UFC does not grow

Now that JFS filesystem paramater snuck up on me.

Thank you very very much for this highlight on this parameter.. It must be a new 11.31 parameter.
Emil Velez
Honored Contributor

Re: Buffer cache/UFC does not grow

Thanks again for the info