cancel
Showing results for 
Search instead for 
Did you mean: 

CIM server error

 
DuKul
Regular Advisor

CIM server error

Hi all,

I am not able to start parstatus. because it cannot connect to local cim server. So I have tried to restart the CIMserver but I have got another error message:

sapdbs1:/root/home/root#parstatus
Note: No action specified. Default behavior is display all.
Error: Failed to connect to target partition or complex.
Cannot connect to local CIM server. Connection failed.
sapdbs1:/root/home/root#/sbin/init.d/cim_server stop
sapdbs1:/root/home/root#/sbin/init.d/cim_server start
PGS10021: CIM server error: PGS00604: Attribute value on line 44 is not valid.
ERROR CODE 1

any idea?

Dukul
18 REPLIES
Fabio Ettore
Honored Contributor

Re: CIM server error

Hi,

never seen this error before, it sounds something bad is into the rc script.

Run the cim_server rc script with set -x:

- open /sbin/init.d/cim_server and put set -x on the first line;

- /sbin/init.d/cim_server start
and report the output;

- attach the /sbin/init.d/cim_server here.

Best regards,
Fabio
WISH? IMPROVEMENT!
DuKul
Regular Advisor

Re: CIM server error

)(root)# /sbin/init.d/cim_server start
+ PATH=/sbin:/usr/sbin:/usr/bin:/opt/wbem/bin:/opt/wbem/sbin
+ export PATH
+ rval=0
+ [ -f /etc/rc.config.d/cimserver ]
+ . /etc/rc.config.d/cimserver
+ CIMSERVER=1
+ [ 1 -eq 1 -a -x /opt/wbem/sbin/cimserver ]
+ + ps -e
+ grep cimserver$
+ 2>& 1
junk=
+ [ 1 -ne 0 ]
+ /opt/wbem/sbin/cimserver
PGS10021: CIM server error: PGS00604: Attribute value on line 44 is not valid.
+ set_return
ERROR CODE 1
+ exit 1
DuKul
Regular Advisor

Re: CIM server error

I have even tried to copy the rc script from the another node (same version of HP-UX, patchlevel etc.) - but same results.
Jupinder Bedi
Respected Contributor

Re: CIM server error

I believe there is problem in the line no. 44 of the script . can you please paste the whole script here.
All things excellent are as difficult as they are rare
DuKul
Regular Advisor

Re: CIM server error

(root)#cat -n /sbin/init.d/cim_server
1 #!/sbin/sh
2 set -x
3 #
4 # @(#) $Revision: 78.1 $
5 #
6 # NOTE: This script is not configurable! Any changes made to this
7 # scipt will be overwritten when you upgrade to the next
8 # release of HP-UX.
9 #
10 # WARNING: Changing this script in any way may lead to a system that
11 # is unbootable. Do not modify this script.
12 #
13
14 #
15 # Start WBEM/cimserver
16 #
17
18 PATH=/sbin:/usr/sbin:/usr/bin:/opt/wbem/bin:/opt/wbem/sbin
19 export PATH
20
21 rval=0
22 set_return() {
23 x=$?
24 if [ $x -ne 0 ]
25 then
26 echo "ERROR CODE $x"
27 rval=1
28 fi
29 }
30
31 case $1 in
32 start_msg)
33 echo "Start CIM cimserver subsystem"
34 ;;
35
36 stop_msg)
37 echo "Stop CIM cimserver subsystem"
38 ;;
39
40 'start')
41 if [ -f /etc/rc.config.d/cimserver ]
42 then
43 . /etc/rc.config.d/cimserver
44 else
45 echo "ERROR: /etc/rc.config.d/cimserver defaults file MISSING"
46 fi
47
48 if [ "$CIMSERVER" -eq 1 -a -x /opt/wbem/sbin/cimserver ]
49 then
50 junk=$(ps -e | grep cimserver$ 2>&1 )
51 if [ $? -ne 0 ]
52 then
53 /opt/wbem/sbin/cimserver && echo "CIM cimserver started"
54 set_return
55 else
56 echo "CIM cimserver is running"
57 fi
58 else
59 rval=2
60 fi
61 ;;
62
63 'stop')
64 #
65 # Shut down the cimserver process if it is running
66 #
67 junk=$(ps -e | grep cimserver$ 2>&1 )
68 if [ $? -eq 0 ]
69 then
70 /opt/wbem/sbin/cimserver -s
71 set_return
72 else
73 rval=0;
74 fi
75 ;;
76
77 *)
78 echo "usage: $0 {start|stop}"
79 ;;
80 esac
81
82 exit $rval
Fabio Ettore
Honored Contributor

Re: CIM server error

Hi,


....
+ [ 1 -ne 0 ]
+ /opt/wbem/sbin/cimserver
PGS10021: CIM server error: PGS00604: Attribute value on line 44 is not valid.
+ set_return
ERROR CODE 1
+ exit 1


I see the script /opt/wbem/sbin/cimserver calls then the binary executable /opt/wbem/lbin/cimserver, maybe there's something wrong with that.

Next step is to put set -x on the first line of the following script: /opt/wbem/sbin/cimserver. Then run /sbin/init.d/cim_server start again and please report output here.

Best regards,
Fabio
WISH? IMPROVEMENT!
DuKul
Regular Advisor

Re: CIM server error

still the same error

(root)#/sbin/init.d/cim_server start
+ export _M_ARENA_OPTS=1:8
+ export _M_SBA_OPTS=512:100:16
+ /opt/wbem/lbin/cimserver
PGS10021: CIM server error: PGS00604: Attribute value on line 44 is not valid.
ERROR CODE 1
Jupinder Bedi
Respected Contributor

Re: CIM server error

can you please comment out the set -x and than try and let me know the output.


All things excellent are as difficult as they are rare
DuKul
Regular Advisor

Re: CIM server error

(root)#/sbin/init.d/cim_server start
PGS10021: CIM server error: PGS00604: Attribute value on line 44 is not valid.
ERROR CODE 1
Fabio Ettore
Honored Contributor

Re: CIM server error

Hi Dukul,

the set -x was not suggested to solve the problem, it just was to get more info about where the problem is.

(root)#/sbin/init.d/cim_server start
+ export _M_ARENA_OPTS=1:8
+ export _M_SBA_OPTS=512:100:16
+ /opt/wbem/lbin/cimserver
PGS10021: CIM server error: PGS00604: Attribute value on line 44 is not valid.
ERROR CODE 1

This means the problem starts into /opt/wbem/lbin/cimserver. Now we are stuck because /opt/wbem/lbin/cimserver is a binary executable and we cannot see inside.
I'd proceed as follows:

- save current /opt/opt/wbem/lbin/cimserver:

mv /opt/wbem/lbin/cimserver /opt/wbem/lbin/cimserver.ORIG

- copy it from another machine with the same OS (and the same WBEM Services version).

If the problem is still not solved then use tusc, to begin just

tusc /opt/wbem/lbin/cimserver

and report here the output.
tusc is available from Porting:

http://hpux.connect.org.uk/hppd/hpux/Sysadmin/tusc-7.10/

Best regards,
Fabio




WISH? IMPROVEMENT!
DuKul
Regular Advisor

Re: CIM server error

Hi all,

still the same error, so here is the output of tusc.

Dukul
Fabio Ettore
Honored Contributor

Re: CIM server error

Hi,

I see something strange.

I'm comparing your tusc output with a my working system. Next questions:

- post contents of /var/opt/wbem/cimserver_current.conf and /var/opt/wbem/cimserver_planned.conf;

- ps -ef |grep -i 3864
(I see this pid in tusc output)

- which OS and WBEM services version do you have?
An idea could be to reinstall the latest version of WBEM Services, it seems that something is dirty on the system. However please report the answers to the above questions.

Best regards,
Fabio
WISH? IMPROVEMENT!

Re: CIM server error

>here is the output of tusc.

It doesn't have the details needed. Please use:
tusc -fp -ea -o tusc.out /opt/wbem/lbin/cimserver
DuKul
Regular Advisor

Re: CIM server error

Hi Dennis,
here is the output again.
Dukul
DuKul
Regular Advisor

Re: CIM server error

Hi Fabio,

==> so both conf files seems to be emtpy:

(root)#cat /var/opt/wbem/cimserver_planned.conf
########################################################################
## ##
## CIM Server configuration file ##
## ##
########################################################################

########################################################################
# #
# This is the configuration file for the CIMOM. The configuration #
# properties in this file are loaded in to CIMOM at startup. #
# CIMOM updates this file with the changes in the configurations. #
# #
# It is recommended that user do not edit this file, instead use #
# CIMConfigCommand to make any changes to the CIMOM configurations. #
# #
########################################################################

(root)#cat /var/opt/wbem/cimserver_current.conf
########################################################################
## ##
## CIM Server configuration file ##
## ##
########################################################################

########################################################################
# #
# This is the configuration file for the CIMOM. The configuration #
# properties in this file are loaded in to CIMOM at startup. #
# CIMOM updates this file with the changes in the configurations. #
# #
# It is recommended that user do not edit this file, instead use #
# CIMConfigCommand to make any changes to the CIMOM configurations. #
# #
########################################################################

The system is HP-UX sapdbs1 B.11.23 U ia64.

The software version is:
(root)#swlist WBEMServices
# Initializing...
# Contacting target "sapdbs1"...
#
# Target: sapdbs1:/
#

# WBEMServices A.02.05.08 WBEM Services CORE Product
WBEMServices.WBEM-CORE A.02.05.08 WBEM Services CORE Fileset for hp Integrity servers
WBEMServices.WBEM-CORE-COM A.02.05.08 WBEM Services COM Fileset for hp Integrity servers and hp 9000 servers
WBEMServices.WBEM-MAN A.02.05.08 WBEM Services MAN Fileset
WBEMServices.WBEM-MX A.02.05.08 WBEM Services MX fileset

Re: CIM server error

>here is the output again.

Not sure where the error is.
/var/opt/wbem/repository/root#PG_InterOp/qualifiers/Values
/opt/wbem/share/locale/ICU_Messages/pegasus/pegasusServer_en.res
/opt/wbem/share/locale/ICU_Messages/pegasus/pegasusServer_root.res
/etc/default/syslogd
DuKul
Regular Advisor

Re: CIM server error

Hi all,

well, perhaps the reinstalation of WBEMServices should take place.

Dukul
Fabio Ettore
Honored Contributor

Re: CIM server error

Hi Dukul,

yes, try to install the latest version for HP-UX 11.23. You get it from here:

https://h20392.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=WBEMSvcs

Let me know the results.

Best regards,
Fabio
WISH? IMPROVEMENT!