HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

CPU reverts to original number after vparmodify

 
SOLVED
Go to solution
Victor Sien
Advisor

CPU reverts to original number after vparmodify

Hi,

I recently ran across this situation where whenever I remove CPU from one vpar (vpar1) and add it to vpar2, it succeeds but shortly after that, vpar2's CPU count reverts back to the original CPU count prior to the change.

So what I did was put the static attribute to "Static". That worked, the CPUs that were added stayed. But then I notice from syslog that a process attempts to revert it back to original number (of course it failed because I set it to static). What's going on there?

Here's a log:

Virtual Partition Name State Attributes Kernel Path Opts
============================== ===== ============ ======================= =====
vpar1 Up Stat,Auto,Nsr/stand/vmunix
vpar2 Up Stat,Auto,Nsr/stand/vmunix

[Virtual Partition Resource Summary]
CPU Num Num Memory Granularity
Virtual Partition Name Min/Max CPUs IO ILM CLM
============================== ======= ==== ==== ========== ==========
vpar1 4/ 24 4 5 128 128
vpar2 4/ 24 24 5 128 128

1. From that output, vpar1 has 4 CPUs, vpar2 has 24 CPUs.

2. I removed 20 CPUs from vpar2:
vpar1> vparmodify -S dynamic -p vpar2 -d cpu::20 -S static

3. there are now 20 available CPUs:
vpar1> vparstatus -A | grep "Available CPUs"

[Available CPUs]: 20

4. I added those 20 CPUs to vpar1:

vpar1> vparstatus -S dynamic -p vpar1 -a cpu::20 -S static

5. That worked, vparstatus now shows vpar1 has 24 CPUs.

6. But look at vpar1's syslog.log. Every second, something's trying to put it back to 4! What process is doing that? Of course that fails because I set it to static, but when I previously ran vparmodify when the vpars were dynamic, that command succeeds and reverts the CPU count right away after a successful add. And what's vparmodify -t? I dont see that option in the man page.

Any ideas?? Thanks in advance.

vpar1> model
ia64 hp superdome server SD32B
vpar1> uname -a
HP-UX vpar1 B.11.31 U ia64 1708439072 unlimited-user license


vpar1> tail /var/adm/syslog/syslog.log
Jun 24 03:49:07 vpar1 vparmodify[14265]: user root: /usr/sbin/vparmodify -t -p vpar1 -m cpu::4
Jun 24 03:49:07 vpar1 vparmodify[14265]: exit status 1
Jun 24 03:49:08 vpar1 vparmodify[14266]: user root: /usr/sbin/vparmodify -t -p vpar1 -m cpu::4
Jun 24 03:49:08 vpar1 vparmodify[14266]: exit status 1
Jun 24 03:49:08 vpar1 vparmodify[14267]: user root: /usr/sbin/vparmodify -t -p vpar1 -m cpu::4
Jun 24 03:49:08 vpar1 vparmodify[14267]: exit status 1

4 REPLIES

Re: CPU reverts to original number after vparmodify

is The node part of a WLM or gWLM configuration? If it's managed by gWLM then the command:

gwlmstatus

should give you an indication of that

If WLM, then look for the wlmd or wlmpard process.

In either case, if WLM or gWLM is responsible for managing the node, you shouldn't be adjusting CPU entitlements manually.

HTH

Duncan

HTH

Duncan
Victor Sien
Advisor

Re: CPU reverts to original number after vparmodify


There's no gwlm but there's WLM. How do I go about verifying what are the restrictions imposed?


vpar1> gwlmstatus
Product Name: null
License Status: Unknown. Please check any CMS associated with agent.

Status of gwlmagent on host vpar1: Not running
SRD: No SRD deployed on host vpar1.
vpar1> ps -ef | grep wlm
root 5806 1 0 05:50:08 ? 0:00 /opt/wlm/bin/wlmcomd
root 5803 1 0 05:50:08 ? 0:08 /opt/wlm/bin/wlmpard -a /etc/wlm_par.conf
root 5786 1 0 05:50:07 ? 0:17 /opt/wlm/bin/wlmd -a /etc/wlm.conf
root 5791 5786 0 05:50:08 ? 0:29 /opt/wlm/lbin/wlmparc -i1 -z1052672 -Pvpar1
root 16985 13664 1 13:31:36 pts/1 0:00 grep wlm
Solution

Re: CPU reverts to original number after vparmodify

If you don't know WLM you should probably review the documentation before changing anything:

http://docs.hp.com/hpux/netsys/index.html#HP-UX%20Workload%20Manager

There's a Java based X-Windows GUI that should make things a little simpler to follow. Set your DISPLAY variable appropriately and run:

wlmgui



HTH

Duncan

HTH

Duncan
Victor Sien
Advisor

Re: CPU reverts to original number after vparmodify


Thanks guys. It was indeed due to WLM. I disabled it and the problem went away. It was actually the default config. I find it strange though no where in the documentation does it explain what vparmodify -t is.