System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Can I update 11.11 December 2003 to 11.31 March 2009 using update-ux.

 
SOLVED
Go to solution
Narendra Thapa
Frequent Advisor

Can I update 11.11 December 2003 to 11.31 March 2009 using update-ux.

Hi,

I am trying to upgrade 11.11 December 2003 to 11.31 March 2009 using update-ux but its throwing error.

Can I update 11.11 December 2003 to 11.31 March 2009 using update-ux or not?


Following errors were observed during update-ux.

(host1) /{1}swlist | grep -i oe
HPUX11i-OE B.11.11.0312 HP-UX 11i Operating Environment Component


(vcshp020) /{12}/usr/sbin/update-ux -s vcshi024:/March09.11.31/0903_LR_DCOE HPUX11i-DC-OE


======= Wed Aug 5 12:28:08 IST 2009 BEGIN update-ux


NOTE: Output is logged to '/var/adm/sw/update-ux.log'
* Obtaining some information from the source depot.
* Copying an SD agent from the source depot
* Installing the Update-UX product
Current update-ux version: 11.31.20
Source depot update-ux version: 11.31.20
* Installing the SW-GETTOOLS product
* Configuring the SW-GETTOOLS product
* Installing the SD filesets to be used for the update
* Installing the SWM filesets needed to perform OE update
ERROR: The command: '/usr/sbin/swinstall -x reinstall=true -x
autoselect_dependencies=false -x enforce_dependencies=false -x
mount_all_filesystems=false -x defer_configure=true -s
ignite123:/March09.11.31/0903_LR_DCOE SWMTRANS' failed. Output
follows:
ERROR: Could not apply the software selection "SWMTRANS" because
there are no product variations that are compatible with the
destination host(s).
ERROR: No software has been selected.
ERROR: Cannot continue the "swinstall" task.
For more information, see /var/adm/sw/swagent.log
NOTE: One or more errors encountered. Take appropriate corrective action
and re-run update-ux to complete the update.

======= Wed Aug 5 12:30:38 IST 2009 END update-ux





"Study as if you were going to live forever; live as if you were going to die tomorrow."
6 REPLIES
Torsten.
Acclaimed Contributor

Re: Can I update 11.11 December 2003 to 11.31 March 2009 using update-ux.

What server model do you have?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Narendra Thapa
Frequent Advisor

Re: Can I update 11.11 December 2003 to 11.31 March 2009 using update-ux.

I have PA machine.
#model
9000/800/rp3440
"Study as if you were going to live forever; live as if you were going to die tomorrow."
Torsten.
Acclaimed Contributor
Solution

Re: Can I update 11.11 December 2003 to 11.31 March 2009 using update-ux.

So your server is supported to run 11.31.

But you must be on 11.23 to use update-ux, see

http://docs.hp.com/en/5992-5795/ch03s02.html#d0e2742

Consider to do a cold-install.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Narendra Thapa
Frequent Advisor

Re: Can I update 11.11 December 2003 to 11.31 March 2009 using update-ux.

Thanks Torsten for your help.


I have got the answer now.
I need to upgrade 11.11 to 11.23 and then 11.23 to 11.31 if i want to upgrade from 11.11 to 11.31.

Quite a long process but I need to perform these steps if I want to update the OS. :)


Thanks again.
"Study as if you were going to live forever; live as if you were going to die tomorrow."
Narendra Thapa
Frequent Advisor

Re: Can I update 11.11 December 2003 to 11.31 March 2009 using update-ux.

I got my answer.

Closing the thread.
"Study as if you were going to live forever; live as if you were going to die tomorrow."

Re: Can I update 11.11 December 2003 to 11.31 March 2009 using update-ux.

>I need to perform these steps if I want to update the OS.

You can cold install directly.