cancel
Showing results for 
Search instead for 
Did you mean: 

Can not install the patch

SOLVED
Go to solution
M. Farrokhi
Occasional Visitor

Can not install the patch

Hi,

We are trying to patch HPUXv 11.11 machine with an LVM patch PHKL_35742 that has the following dependencies: PHCO_21187, PHCO_23651, PHCO_23791, PHKL_18543, PHKL_19202, PHKL_20016, PHKL_22589, PHKL_27980, PHKL_28766

We created a bundle per instruction noted on README_hp-ux file step by step.

But when running swinstall given the source, we got the following error.

Can anyone tell me what we can do at this point?

Below is the verbose of installation. The swagent.log will be also attached.

# swinstall -s /var/LVM-Patch/depot \*

======= 07/31/09 13:26:48 PDT BEGIN swinstall SESSION
(non-interactive) (jobid=hpl10001-0051)

* Session started for user "root@hpl10001".

* Beginning Selection
* Target connection succeeded for "hpl10001:/".
* Source connection succeeded for
"hpl10001:/var/LVM-Patch/depot".
ERROR: Could not apply the software selection "*" because there are
no product variations that are compatible with the destination
host(s).
* Software selection failed for "hpl10001:/var/LVM-Patch/depot".
ERROR: No software has been selected.
ERROR: Cannot continue the "swinstall" task.
* Selection had errors.



======= 07/31/09 13:26:50 PDT END swinstall SESSION (non-interactive)
(jobid=hpl10001-0051)

# pwd
/var/LVM-Patch
# ll
total 81824
-rw-r--r-- 1 21164 12753 1779 Jan 13 2009 README_hp-ux
-rwxr-xr-x 1 21164 12753 5761 Jul 31 12:45 create_depot_hpux.11.00
drwxr-xr-x 14 root sys 8192 Jul 31 13:12 depot
-rwxrw-r-- 1 root sys 41858560 Jul 31 13:07 hpux__11.00_07310745.tar
-rw-r--r-- 1 21164 12753 657 Jul 31 12:45 patch_manifest
# cd depot
# ll
total 96
dr-x------ 2 root sys 96 Jul 31 13:12 BUNDLE
dr-x------ 7 root sys 8192 Jul 31 13:10 PHCO_21187
dr-x------ 3 root sys 96 Jul 31 13:10 PHCO_23651
dr-x------ 5 root sys 96 Jul 31 13:10 PHCO_23791
dr-x------ 13 root sys 8192 Jul 31 13:11 PHKL_18543
dr-x------ 4 root sys 96 Jul 31 13:11 PHKL_19202
dr-x------ 4 root sys 96 Jul 31 13:11 PHKL_20016
dr-x------ 6 root sys 96 Jul 31 13:11 PHKL_22589
dr-x------ 5 root sys 96 Jul 31 13:11 PHKL_27980
dr-x------ 6 root sys 96 Jul 31 13:11 PHKL_28766
dr-x------ 6 root sys 96 Jul 31 13:12 PHKL_35742
dr-x------ 14 root sys 8192 Jul 31 13:12 catalog
-rw-r--r-- 1 root sys 23516 Jul 31 13:26 swagent.log
#
9 REPLIES
Prashanth Waugh
Esteemed Contributor

Re: Can not install the patch

Hi,

Try using only swinstall then text window will open navigate select the hsotname and give the absolute path for depot.

Regards
Prashant
For success, attitude is equally as important as ability
Patrick Wallek
Honored Contributor

Re: Can not install the patch

Patch Name: PHKL_35742
Patch Description: s700_800 11.00 LVM Cumulative Patch
Creation Date: 06/12/05
Post Date: 06/12/08
Hardware Platforms - OS Releases:
s700: 11.00
s800: 11.00

Patch PHKL_35742 is for HP-UX 11.00 and NOT 11.11.

The patches you mention are ALL for HP-UX 11.00 and will ABSOLUTELY POSITIVELY NOT WORK on HP-UX 11.11.

The latest LVM cumulative patch for HP-UX 11.11 is:

Patch Name: PHCO_35955
Patch Description: s700_800 11.11 LVM commands cumulative patch
Creation Date: 07/03/20
Post Date: 07/05/16
Hardware Platforms - OS Releases:
s700: 11.11
s800: 11.11
http://www13.itrc.hp.com/service/patch/patchDetail.do?patchid=PHCO_35955&sel={hpux:11.11,}&BC=main|search|
Lijeesh N G_1
Respected Contributor

Re: Can not install the patch

Hi,

Below the dtails of the patches,


PHCO_21187 GS 3 21466 2000-06-15 s700_800 11.00 cumulative SAM/ObAM patch
PHCO_23651 GR C 3 Y 512 2001-03-23 s700_800 11.00 fsck_vxfs(1M) cumulative patch
PHCO_23791 GS C 3 Y 2334 2001-04-16 s700_800 11.00 LVM commands cumulative patch
PHKL_18543 GR C R SI 3 Y 12148 1999-06-28 s700_800 11.00 PM/VM/UFS/async/scsi/io/DMAPI/JFS/perf patch
PHKL_19202 GR C R 3 27 1999-08-05 s700_800 11.00 fsadm panic if extending root on 11.x
PHKL_20016 GR R SI 3 Y 35 1999-10-05 s700_800 11.00 2nd CPU not recognized in G70/H70/I70
PHKL_22589 GS R SI 3 Y 439 2000-11-06 s700_800 11.00 LOFS, select(), IDS/9000 and umount race fix
PHKL_27980 GS C R SI 3 Y 444 2002-11-13 s700_800 11.00 VxFS 3.1 cumulative patch: CR_EIEM
PHKL_28766 GS C R SI 3 Y 1888 2003-04-02 s700_800 11.00 Probe,IDDS,PM,VM,PA-8700,AIO,T600,FS,PDC,CLK

I could see all are applicable to the 11.00 OS, not 11.11. This could be the reason.

Refer below link for more details about patches,

http://www13.itrc.hp.com/service/patch/mainPage.do



Reagrds,
LIJEESH N G
Lijeesh N G_1
Respected Contributor

Re: Can not install the patch

Hi,

The lates LVM cumulative patch for 11.11 is,

PHKL_35970 - s700_800 11.11 LVM Cumulative Patch

Refer below link for more details about this patch and its dependencies,


Reagrds,
LIJEESH N G
Patrick Wallek
Honored Contributor
Solution

Re: Can not install the patch

>>I could see all are applicable to the 11.00 OS, not 11.11. This could be the reason.

There is no "could be the reason!" That DEFINITELY is the reason.

>>PHKL_35970 - s700_800 11.11 LVM Cumulative Patch

You're right, I missed this one. Here is the link to the patch:
http://www11.itrc.hp.com/service/patch/patchDetail.do?patchid=PHKL_35970&sel={hpux:11.11,}&BC=main|search|

NOTE -- PHKL_35970 also needs PHKL_35955 and PHKL_30607
M. Farrokhi
Occasional Visitor

Re: Can not install the patch

Patrick,

Thanks so much for the quick response. Sorry for the late acknowledgment. It seemed we already had this Patch installed. Thanks for letting us know the patch we were using was the wrong one.
M. Farrokhi
Occasional Visitor

Re: Can not install the patch

LIJEESH N G,

We'll use your recommanded patch. Thanks very much for the correction.

Regards,
M. Farrokhi
Lijeesh N G_1
Respected Contributor

Re: Can not install the patch

Hi,

Before installing, check its dependecies and read all special installation instructions of the patches.

It is recomended to take ignite backup before installing any patch.

Regards,
LIJEESH N G
Lijeesh N G_1
Respected Contributor

Re: Can not install the patch

Hi,

You may assign points if your question is answered.

Regards,
LIJEESH N G