System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't install PSP: C-class 460 blade, RHEL4U4 64-bit

Don Vanco - Linux Ninja
Regular Advisor

Can't install PSP: C-class 460 blade, RHEL4U4 64-bit

[root@hpblade1 linux]# ./install780.sh
Saving user-defined agent thresholds...[ Done ]

Checking system for required packages...[ Done ]

****************************************************************
HP ProLiant Deployment Utility for Linux
Copyright 2003-2007 Hewlett-Packard Development Company, L.P.
****************************************************************
../hpplduioss: error while loading shared libraries: libXi.so.6: cannot open shared object file: No such file or directory
The current log file name is now /var/log/hppldu.log

After waiting for a minute or so, I use Ctrl-C to abort the run:

Restoring user defined agent thresholds...[ Done ]

Restarting SNMP Daemon...[ Done ]

Restarting HP System Management Homepage...[ Done ]

Restarting HP System Management Drivers and Agents...[ Done ]

Terminated!

[root@hpblade1 linux]# find /usr -name libXi.so.6 -print
/usr/X11R6/lib64/libXi.so.6

Nothing gets written to the log in question.

I can't find any other information on this error. I tried dropping back to 7.7, same result. I saw an older issue with the contents of /etc/redhat-release so I tried that as a longshot - same issue

Have never had this issue with other C-class hardware.

4 REPLIES
Steven E. Protter
Exalted Contributor

Re: Can't install PSP: C-class 460 blade, RHEL4U4 64-bit

Shalom,

Your other systems without troubles are the same OS, 64 bit? Then perhaps the packages already installed are different.

I recommend checking the logs for more information and posting it back here.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Don Vanco - Linux Ninja
Regular Advisor

Re: Can't install PSP: C-class 460 blade, RHEL4U4 64-bit

Problem is, as stated, there's nothing in the logs. I have not looked at the script to see how it's calling the shared object in question, but my guess is that it's looking for a 32-bit version that is not on this system (I cannot look at that server at the moment)
Michael Garner_1
Honored Contributor

Re: Can't install PSP: C-class 460 blade, RHEL4U4 64-bit

Don,
To run the PSP in GUI mode, you'll need to ensure the following libraries are in the /usr/X11R6/lib directory:

libXi.so
libXext.so
libX11.so

You can install a single RPM that will contain all the 32-bit library requirements that the PSP needs for GUI mode. The file you need to install is "xorg-x11-libs-6.7.1-23.EL.i386.rpm".

You are correct in your assumption that these need to be in the 32-bit directory, through I think you can use the x86_64 versions of the files as they are just linked to.

If you don't want to go through the hassle, you can also install the PSP in console mode by using the /nui switch. This will bypass the requirement on those libraries. If you want the capability to select which components to install in console mode, you can also include the /y switch (ie ./install780.sh /nui /y) and you will be prompted for each component.

Let me know if you have additional issues.

Regards,
Michael Garner
HP Linux PSP Developer
Don Vanco - Linux Ninja
Regular Advisor

Re: Can't install PSP: C-class 460 blade, RHEL4U4 64-bit

Thanks Michael! Have not tested it yet, but have no doubt it should address the issue.

I must admit that I'm puzzled - I did a RHEL4U5 install and it installed the 32-bit & 64-bit libs "automagically", but on this RHEL4U4 install it only installed the 64-bit libs......