System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't see ultrium 960 tape drives in msl6030 on RHEL 4 IA64 even though the medium changer shows

 
SOLVED
Go to solution
Trever Furnish
Regular Advisor

Can't see ultrium 960 tape drives in msl6030 on RHEL 4 IA64 even though the medium changer shows

Hello,

We recently installed RHEL4 U6 IA64 on an Integrity rx2660 with an attached MSL6030 containing two u960 tape drives. The HBA seems to work -- Kudzu sees the medium changer -- but I can't see any sign that the tape drives are present. (They are however physically connected, showing the correct blinking lights, and were working fine before we nuked HPUX.)

A sales support engineer told us the HBA isn't supported under RHEL4, but given that he's only looking at a list of part numbers and sometimes HP uses different part numbers for the same card, we're wondering if our problem is really an unsupported card or something else. Again, the medium changer shows up fine behind the card -- only the tape drives are missing.

The card is HP part number AB378B. It shows up in the lspci output as:
04:01.0 Fibre Channel: QLogic Corp. ISP2422-based 4Gb Fibre Channel to PCI-X HBA (rev 03)

And it shows up in dmesg detecting the medium changer like so:

qla2400 0000:04:01.0: Found an ISP2422, irq 61, iobase 0xc0000000f0040000
qla2400 0000:04:01.0: Configuring PCI space...
qla2400 0000:04:01.0: Configure NVRAM parameters...
qla2400 0000:04:01.0: Verifying loaded RISC code...
qla2400 0000:04:01.0: Allocated (1061 KB) for firmware dump...
qla2400 0000:04:01.0: Waiting for LIP to complete...
qla2400 0000:04:01.0: LIP reset occured (f8f7).
qla2400 0000:04:01.0: LIP occured (f8f7).
qla2400 0000:04:01.0: LOOP UP detected (4 Gbps).
qla2400 0000:04:01.0: Topology - (Loop), Host Loop address 0x0
scsi6 : qla2xxx
qla2400 0000:04:01.0:
QLogic Fibre Channel HBA Driver: 8.01.07-d4
QLogic HP AB378-60101 -
ISP2422: PCI-X Mode 2 (133 MHz) @ 0000:04:01.0 hdma+, host#=6, fw=4.00.150 [IP]
Vendor: HP Model: MSL6000 Series Rev: 0520
Type: Medium Changer ANSI SCSI revision: 02

Any ideas on how to get the tape drives to show up? (BTW, we also did apply the latest Integrity Essentials firmware updates before the OS install.)

Hockey PUX?
2 REPLIES
Steven E. Protter
Exalted Contributor
Solution

Re: Can't see ultrium 960 tape drives in msl6030 on RHEL 4 IA64 even though the medium changer shows

Shalom,

Suggestions:
1) Install a drivers for the changer that match the OS. Just because the OS sees the drive does not mean the drivers have enough code to talk to it and manipulate it.

2)Check for termination issues and SCSI ID on the fiber network. See if there are conflicts.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Trever Furnish
Regular Advisor

Re: Can't see ultrium 960 tape drives in msl6030 on RHEL 4 IA64 even though the medium changer shows

D'OH!!!

I hate when I search for something and find a post where the person responding clearly solved the problem but wasn't awarded points...and then I look up and realize that I was the original poster.

Ten points for you, SEP, sorry it took so long.
Hockey PUX?