HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot change kernel tunable: [Auto] filecache_max and min

 
SOLVED
Go to solution
TwoProc
Honored Contributor

Cannot change kernel tunable: [Auto] filecache_max and min

This value is currently set to 1/2 of system memory for both max and min, and its an "auto" tunable. I can't change anything about it, except set it, once again, to "Auto" . Anyone can give me hand with this? I don't want it this high as the Oracle DB will be doing my caching for me, and I need the ram space for that.
We are the people our parents warned us about --Jimmy Buffett
2 REPLIES
Don Morris_1
Honored Contributor
Solution

Re: Cannot change kernel tunable: [Auto] filecache_max and min

You'll have to give more details.

Why can't you change these tunables? Is there an error when you attempt it? What's the exact command you issue? What's the exact result/output?

Also -- what do you want to set these _to_?

It should be fairly simple -- if you want to lower from the default 5%/50% to 2%/10% for example:

kctune filecache_min=2% filecache_max=10%
TwoProc
Honored Contributor

Re: Cannot change kernel tunable: [Auto] filecache_max and min

Thanks Don. I had solved it about 2 hrs ago, but got dragged off to a meeting immediately after and before I could update that I resolved it.

kctune is new to me, and I didn't understand why it wouldn't let me change params, until I realized that I couldn't change these two related kern parames one at a time, I had to change them both at once (just like you did).

When I tried to change one, it would complain about the other. So, I had to just get the syntax for doing both at once, and what I was doing was putting a comma between the param settings, for some dumb reason.

Closed: reason; hardheadedness(primary), unknown structure, and syntax issues. :-)
We are the people our parents warned us about --Jimmy Buffett