System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot see XP1024 LUNS on reboot without performing an hp_rescan

 
SOLVED
Go to solution
jmazzaro
Occasional Contributor

Cannot see XP1024 LUNS on reboot without performing an hp_rescan

Hi all,

We have a DL585 running Red Hat AS4 UP5 64Bit
Our FC cards are: Qlogic 2340's.

We can't see certain luns attached to our XP1024 after a reboot. They disapear. Yet, when we perform an hp_rescan, they show up. We have 600 Luns assigned to this server, but only 435 show up after a reboot. Any ideas why?
4 REPLIES
Steven E. Protter
Exalted Contributor

Re: Cannot see XP1024 LUNS on reboot without performing an hp_rescan

Shalom,

Perhaps you have exhausted resources on the system. Check the kernel and whether update 5 of RH 4 is certified with the hardwware.

In my opinion its either kernel or drivers.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Ivan Ferreira
Honored Contributor
Solution

Re: Cannot see XP1024 LUNS on reboot without performing an hp_rescan

From "Using the QLogic HBA driver for
single-path or multipath failover mode
on Linux systems"

If you have trouble detecting these devices, run the /opt/hp/hp_fibreutils/probe-luns script during system boot.

â ¢ Enter the following commands to install the probe-luns startup code:
# cd /opt/hp/hp_fibreutils/pbl
# ./pbl_inst.sh -i
â ¢ Enter the following commands to remove the probe-luns startup code:
# cd /opt/hp/hp_fibreutils/pbl
# ./pbl_inst.sh -u
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
jmazzaro
Occasional Contributor

Re: Cannot see XP1024 LUNS on reboot without performing an hp_rescan

I ran this command and rebooted the system but it sill only sees 432 disks.

jmazzaro
Occasional Contributor

Re: Cannot see XP1024 LUNS on reboot without performing an hp_rescan

OK,


I checked the startup script(/etc/rc.d/rc.sysinit)
and noticed that it added a probe-luns -d, which doesn't do the job, even from the command line. I'm going to modify the script to do a probe-luns -a to see if it resolves it.

It works. We now have the proper number of LUNS after a reboot.
We have a call into HP to see if this can be the permanent solution, or if there is a driver or kernel parameter that needs to be changed so this can be native to reboot behavior.