cancel
Showing results for 
Search instead for 
Did you mean: 

Collect -p problem

Collect -p problem

When I use collect -p file1 -p file2 -f newfile to combine .cgz files, collgui won't open them. Says it can't read the file.
6 REPLIES
Johan Brusche
Honored Contributor

Re: Collect -p problem


Yes, I have been wishing for some time now that our engineering would cure that problem too... but it does not seem to be very high on their prioriy list.

JB.

_JB_
Venkatesh BL
Honored Contributor

Re: Collect -p problem

1) Are you able to playback the new file with collect?
2) When using "-p" and "-f", the file that was created first should be passed first.
ex:
a) collect -p file1 -p file2 -f new => collgui will open.
b) collect -p file2 -p file1 -f new => collgui will not open.

This is because, the timestamp in records of the file will not be in sequence.

rgds,
blv

Re: Collect -p problem

That helped. I did again and made sure that the input files were in chronological order and now I can open the output file. I am still getting the error

Time: Set: Error in time format

But it is working better.
Venkatesh BL
Honored Contributor

Re: Collect -p problem

Ok...this is a known problem...

...setting the TZ environment variable to EST5EDT will solve the problem, for eg.
if the shell being used is ksh:
# export TZ=EST5EDT
should allow the files to be opened by collgui.

Re: Collect -p problem

I spoke too soon. It worked once, butnow is doing the same thing. Here is the output of an env when logged in as root. I set the TZ variable in the root .profile. Was that the wrong place?

# env
DISPLAY=10.206.201.57:0.0
GWSOURCE=telnet
HOME=/
LOGNAME=root
PATH=/temp/jre131/bin:/sbin:/usr/sbin:/usr/bin:/usr/ccs/bin:/usr/bin/X11:/usr/lo
cal
SHELL=/bin/sh
TERM=vt300
TZ=EST5EDT
USER=root
VISUAL=emacs

Re: Collect -p problem

Given up on collgui.