HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Could not open connection to the host, on port 50060

 
Viney Kumar
Regular Advisor

Could not open connection to the host, on port 50060

Hi All,

I am facing one problem in HP-UX. I have edit /etc/services files with following entry
GMD_RRS1 50060/tcp

and refresh inetd services.

Now im trying to telnet and getting following error:-
C:\Documents and Settings\vineykumar3>telnet 10.0.4.10 50060
Connecting To 10.0.4.10...Could not open connection to the host, on port 50060
: Connect failed

kindly suggest
20 REPLIES
sen_ux
Valued Contributor

Re: Could not open connection to the host, on port 50060

Check the same command from the HP-UX box itsef.If it is getting connected, it would be ok from server end.Might be a firewall block in your network.

Thanks
Viney Kumar
Regular Advisor

Re: Could not open connection to the host, on port 50060

Already checked

Trying...
telnet: Unable to connect to remote host: Connection refused

same error
Prashanth Waugh
Esteemed Contributor

Re: Could not open connection to the host, on port 50060

Hi,

do the nslookup from hpunix box.

Regards
prashant

For success, attitude is equally as important as ability
Torsten.
Acclaimed Contributor

Re: Could not open connection to the host, on port 50060

What application is listening to that port? Is inetd.conf configured?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Viney Kumar
Regular Advisor

Re: Could not open connection to the host, on port 50060

Hi

Application is midation

and as per application no need to configured inetd.conf files

Torsten.
Acclaimed Contributor

Re: Could not open connection to the host, on port 50060

A port is "open" or better listening if something is running and listening to that port, either inetd or another application.

You should use "lsof" and check.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Steven Schweda
Honored Contributor

Re: Could not open connection to the host, on port 50060

> [...] I have edit /etc/services [...]
> and refresh inetd services.

"/etc/services" is not magical. Assuming
that I can guess what "refresh inetd
services" means, these actions don't run any
new software which might be listening on port
50060 (or anywhere else).

What, exactly, are you trying to do?

> You should use "lsof" and check.

Or "netstat -a".
Tingli
Esteemed Contributor

Re: Could not open connection to the host, on port 50060

Seems to be a firewall issue. Try to run

# telnet 10.0.4.10

to see whether port 23 is open.

No matter what, talk to your network guys about it.
Steven Schweda
Honored Contributor

Re: Could not open connection to the host, on port 50060

> Seems to be a firewall issue. [...]

Or a no-program problem.

> Application is midation

What's that? Where's that?

> and as per application no need to
> configured inetd.conf files

I can't see what you're reading, but if you
don't use inetd.conf, then I'd guess that you
need to run some program ("midation"?) in
some other way. Even the best operating
systems can't read your mind, so they may not
run your application unless you tell them to
do it. inetd.conf is one way, and there are
others, but you need to do something, and,
from what you've told us (which is not much),
you haven't done it.
Viney Kumar
Regular Advisor

Re: Could not open connection to the host, on port 50060

Hi All,

We are using HP-UX 11.11i and losf command not working.Getting following error

bash1-2.04# lsof -i -n -P | grep 50060
bash1: lsof: command not found
bash1-2.04#

and In netstat,

No status for 50060/tcp


Steven, I knew, may be we have to edit inetd.conf files but application didn't suggest.........

there some other way to check whether is port listing or not?????

if its not then how we can enable it

thanks

Re: Could not open connection to the host, on port 50060

lsof isn't installed by default - you have to download and install it if you want it - but I don't think you actually need it...

>> there some other way to check whether is port listing or not?????

There sure is:

netstat -an | grep 50060

If that returns nothing then no process is listening on port 50060

You have *started* you "midation" application haven't you???

HTH

Duncan

HTH

Duncan
Steven Schweda
Honored Contributor

Re: Could not open connection to the host, on port 50060

> bash1: lsof: command not found

lsof does not come with HP-UX. A Web search
should find it. The source seems to be
available from:

http://freshmeat.net/projects/lsof/

I suspect that a depot is available, too.

> [...] but application didn't suggest [...]

If I knew what the application was, then I
might be able to suggest something specific.
But I know nothing about the application,
and you don't seem to be saying much about
it.

> there some other way to check whether is
> port listing or not?????

If netstat doesn't show it, then no one is
listening.

If you didn't add anything to inetd.conf, and
you didn't run any program, then whom do you
_expect_ to be listening?
Viney Kumar
Regular Advisor

Re: Could not open connection to the host, on port 50060

Hi


if it possioble we can use my GMD_RRS1 with two diffrent port like in /etc/services

GMD_RRS1 9057/tcp
GMD_RRS1 50060/tcp

it is work or conflict

Prashanth Waugh
Esteemed Contributor

Re: Could not open connection to the host, on port 50060

Hi Viney,

I think It will conflict. the request will confuse regarding which port I have to select.

Reagrds,
Prashant

For success, attitude is equally as important as ability
Viney Kumar
Regular Advisor

Re: Could not open connection to the host, on port 50060

Hi Prashant


Thanks 4 reply.............


I had already disabled the prot
#GMD_RRS1 9057/tcp

And I have compare /etc/hosts, services and inetd.conf files with working server...........


no gap found............


kindly suggest/////////////
Torsten.
Acclaimed Contributor

Re: Could not open connection to the host, on port 50060

You already have suggestions - netstat and lsof! Check if application is running and listening.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Steven Schweda
Honored Contributor

Re: Could not open connection to the host, on port 50060

> I had already disabled the prot
> #GMD_RRS1 9057/tcp

Editing /etc/services is not the same thing
as "enabling" or "disabling" a port. Many
IP applications never look at /etc/services.

> And I have compare [...]

What about all the "rc" files?

> kindly suggest/////////////

Provide some information. Answer questions.
Torsten.
Acclaimed Contributor

Re: Could not open connection to the host, on port 50060

Let's compare /etc/services with /etc/hosts.

Both are for looking up, the first for application and port, the second for host and IP. The main idea is almost the same - looking up (what service is using which port // which host has which IP and vice versa).

So adding an entry in /etc/services does really not "open" a port or something ... you just add an entry to the "dictionary".

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Viney Kumar
Regular Advisor

Re: Could not open connection to the host, on port 50060

After edit the services file its working
Viney Kumar
Regular Advisor

Re: Could not open connection to the host, on port 50060

After edit the services file its working