cancel
Showing results for 
Search instead for 
Did you mean: 

Curl 7.15.3 FTP problem

SOLVED
Go to solution
Lucy2009_1
Frequent Advisor

Curl 7.15.3 FTP problem

Hi,
I installed curl 7.15.3 from 2006 iExpress
from HP to our PA-RISC/N-class hpux 11.11 box.
Test failed to put a file to an external ftp
site. Here is the output. Do I need a newer
verion of CURL?

> /usr/bin/curl -v -3 -B --cacert --ftp-ssl --socks proxy2.xyz.com --proxy-user joe:aabbxx -u testuser:testpass --request ftp -T /home/joe/test-dev --url ftp://www.zzz.com/testfile


* About to connect() to proxy proxy2.xyz.com port 1080
* Trying 123.234.345.1... connected
* Connected to www.zzz.com (123.234.345.1) port 1080
* Server auth using Basic with user 'FTPtst'
> ftp test%2Ddev HTTP/1.1
> Authorization: Basic RlRQdHN0OnRlc3RGVFA=
> User-Agent: curl/7.15.3 (hppa2.0w-hp-hpux11.11) libcurl/7.15.3 OpenSSL/0.9.7i zlib/1.2.3
> Host: www.zzz.com:21
> Accept: */*
> Content-Length: 36
> Expect: 100-continue
>
220 ProFTPD 1.3.0 Server ready.
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 69 0 33 0 0 172 0 --:--:-- --:--:-- --:--:-- 17250 0 FTP not understood
500 AUTHORIZATION: not understood
500 USER-AGENT: not understood
500 HOST: not understood


Any input is appreciated and I will sign points.

Thanks,

LH
4 REPLIES
Steven Schweda
Honored Contributor
Solution

Re: Curl 7.15.3 FTP problem

I know nothing, and I'm working from newer
stuff, but doesn't "--cacert" take an
argument?

--cacert
[...]

"--request ftp"? Why?

-X/--request

(FTP) Specifies a custom FTP command to
use instead of LIST when doing file
lists with FTP.

You seem to be telling it to send "ftp"
when it would normally send "LIST". That
could explain this complaint near the
beginning of the transaction:

[...] FTP not understood

I suspect that this option was intended to
let you specify something like "LIST -A" or
"ls -A", or some such thing so that you could
see the "hidden" (".name") files which the
FTP server might not normally show you. I
don't know what you're trying to do with it.
(And I suspect that you don't know, either.)

> 500 AUTHORIZATION: not understood
> 500 USER-AGENT: not understood
> 500 HOST: not understood

You seem to have it sending a bunch of fancy
stuff which is not understood by the FTP
server. Perhaps related to "--ftp-ssl"?

I doubt that I ever tried to use a proxy, so
I know even less about that part. I did get
a simpler "put" (STOR) operation to work on
my (VMS) system using only "-u user:pass",
"-T file.name", and
"--url ftp://host/file.dest".

If you were to do this task manually, what
would the session look like?

I'd start (as I did start) with a simpler
command, perhaps talking to a local server.
Then, when that works, start adding the
complications, preferably ones which make
more sense than "--request ftp".
Lucy2009_1
Frequent Advisor

Re: Curl 7.15.3 FTP problem

Thanks for checking...
I removed --request ftp and --cacert
and the result is the same. It complained not
understood PUT. Someone told me that the old version of curl on Linux had same same problem until he installed a newer version,
this command worked. I can't seem to find
a newer version from iExpress bundle from HP.
I need newer curl for PA-RISC hpux 11.11.
Any idea?

Thanks,

LH
Patrick Wallek
Honored Contributor

Re: Curl 7.15.3 FTP problem

From http://hpux.connect.org.uk

Curl 7.19.3 (Jan. 23, 2009)
http://hpux.connect.org.uk/hppd/hpux/Networking/WWW/curl-7.19.3/

Curl 7.19.2 (Dec. 2, 2008)
http://hpux.connect.org.uk/hppd/hpux/Networking/WWW/curl-7.19.2/

For both version pay VERY CLOSE ATTENTION to the build-time and run-time dependencies. The list is QUITE extensive.

I don't find anything on HP's site for curl for 11.11.
Lucy2009_1
Frequent Advisor

Re: Curl 7.15.3 FTP problem

I compiled CURL 2.19 on a Linux machine and
was able to send files out.

Thanks everyone!