cancel
Showing results for 
Search instead for 
Did you mean: 

DL380 G5 bond0 [RHEL 5.1]

 
WW74407
Occasional Contributor

DL380 G5 bond0 [RHEL 5.1]

Does anybody have an example of configuration for 1Gb/s.

Thanks
4 REPLIES
Alexander Chuzhoy
Honored Contributor

Re: DL380 G5 bond0 [RHEL 5.1]

You didn't say what mode you want to work in. For active-backup mode with 2 network cards, static IP:

/etc/sysconfig/network-scripts/ifcfg-bond0
DEVICE=bond0
BOOTPROTO=static
NETMASK=x.x.x.x
ONBOOT=yes
TYPE=Ethernet
IPADDR=x.x.x.x

/etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=none
MASTER=bond0
SLAVE=yes

/etc/sysconfig/network-scripts/ifcfg-eth1
DEVICE=eth1
ONBOOT=yes
BOOTPROTO=none
MASTER=bond0
SLAVE=yes

/etc/modprobe.conf
alias bond0 bonding
options bonding miimon=100 mode=active-backup
WW74407
Occasional Contributor

Re: DL380 G5 bond0 [RHEL 5.1]

Hi There,
I have done the same exact configuration as yours but I want to force the link to be 1Gb/s with autoneg off.
Do you know how to do that?

Thanks again.
Steven E. Protter
Exalted Contributor

Re: DL380 G5 bond0 [RHEL 5.1]

Shalom,

Auto negotiation should be on for all GB NIC cards.

Whats missing is you also need some card specific configuration in /etc/modprobe.conf

alias bond0 bonding
# options bond0 miimon=200 mode=active-active
options bond0 miimon=200 mode=0
alias eth0 e1000
alias eth1 e1000
alias eth2 tg3
alias scsi_hostadapter ata_piix
alias usb-controller ehci-hcd

That works for Intel.

You need to replace tg3 for broadcom and not try active active because it won't work with broadcom.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Matthew Ghofrani
Regular Advisor

Re: DL380 G5 bond0 [RHEL 5.1]

I think you need to change the Type=Ethernet in cfg-bond0 to Type=Bonding and include the Type=Ethernet in the other two ETHs.

Life is full of bugs