System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

DS20 problem , booting not possible

DERAR
Occasional Visitor

DS20 problem , booting not possible

dear all,

i have an alphaserver DS20, which is not capable of booting after a problem occured with Power System. Now , the server is starting until the P0>>, and when i run the test command , i get the message :

Hard Error – Error #5
Error in read of 0 Bytes at location 00002A00 from device dra0.0.0.8.1

Diagnostic Name = exer_kid
ID = 000002c1
Device = dra0.0.0.8.1
Pass = 0
Test = 0
Hard / Soft = 1/0


What does this mean ?

how can i solve it ?


Regards
6 REPLIES
Steven Schweda
Honored Contributor

Re: DS20 problem , booting not possible

> Error in read [...]

> What does this mean ?

Sounds like a read error on dra0. From the
device name, I'd guess that this is a disk on
some RAID adapter about which I know nothing.

> [...] when i run the test command [...]

Why not the "boot" command?

While you're waiting for a response from
someone who knows something, you might
provide the output from

>>>show config
>>>show device
Rob Leadbeater
Honored Contributor

Re: DS20 problem , booting not possible

Hi,

dra0 is a RAID disk device provided by a KZPAC card, sometimes known as a SWXCR.

What happens when you try to boot ?

Do any of the hard drives show a yellow light ?

As Steven suggests, a "show dev" will probably yield some useful information.

You will probably want to hunt out the floppy that contains the RCU (RAID Configuration Utility) for the KZPAC.

Cheers,

Rob
DERAR
Occasional Visitor

Re: DS20 problem , booting not possible

SOME TESTS ON THE DS20 system :
+++++++++++++++++++++++++++++++


1) When trying the command show Bios I noticed the system hangs for 2-3 minutes and then gives a 3-lines output :
Dra.0.0.8.1 â Mylex DAC960
Vga0.0.0.7.0 â ELSA
Pka0.7.0.6.0 â Adaptec AIC â 7895

2) When trying to boot normally either to single mode or multi user mode, I get the following error message:

Hard Error â Error #5
Error in read of 0 Bytes at location 00002A00 from device dra0.0.0.8.1

Diagnostic Name = exer_kid
ID = 000002c1
Device = dra0.0.0.8.1
Pass = 0
Test = 0
Hard / Soft = 1/0

3) When typing the command (show bootdef_dev) I get:
Dra0.0.0.8.1

4) When trying the command (show d) I get :

Dra0.0.0.8.1 DRA0 1 member JBOD
Dra1.0.0.8.1 DRA1 3 member RAID 5
Dra2.0.0.8.1 DRA2 3 member RAID 5
Dra3.0.0.8.1 DRA3 3 member RAID 5
Dra4.0.0.8.1 DRA4 3 member RAID 5

5) Version of alpha Bios is (ALPHABios 5.71-R1)

6) When checking system configuration and HDD configuration using the command alphabios â g I get :

⠦⠦.. Initializing Adaptec Storage #0
⠦⠦.. Initializing Adaptec Storage #1
⠦⠦.. Initializing Mylex Storage #0

No disks found under Adaptec Storage #0 and #1

Following disk are found under Mylex Storage #0:

Disk 0 Mylex Storage #0 SCSI ID 383 Size 0 MB ***off-line***
Disk 1 Mylex Storage #0 SCSI ID 384 Size â ¦.. MB
Disk 2 Mylex Storage #0 SCSI ID 385 Size â ¦.. MB
Disk 3 Mylex Storage #0 SCSI ID 386 Size ⠦⠦ MB
Disk 4 Mylex Storage #0 SCSI ID 387 Size â ¦.. MB



++++++++++++++++++++++++++++++++++++++++

REGARDS

DERAR
Rob Leadbeater
Honored Contributor

Re: DS20 problem , booting not possible

Hi,

> When typing the command (show bootdef_dev) I get:
> Dra0.0.0.8.1

> When trying the command (show d) I get :
> Dra0.0.0.8.1 DRA0 1 member JBOD

OK, your boot device is DRA0 which is Just a Bunch Of Disks (JBOD) and it looks to have failed. JBODs provide no resilience, so using one as a boot device is not a good idea.

Disk 0 Mylex Storage #0 SCSI ID 383 Size 0 MB ***off-line***

Having said that the SCSI ID above looks wrong, so this could be an issue with the disk, the Mylex controller or both.

Cheers,

Rob
DERAR
Occasional Visitor

Re: DS20 problem , booting not possible

Dear Rob,

what does it mean when saying (disk is off-line) ???

and why is the SCSI ID wrong ?

i have 7 disks inside the DS20 enclosure ? the 3rd from left is blinking red-orange .

i wonder that i can see only 5 disks :

1 is JBOD
4 are members of RAID 5,


and the other 2 are not showing here.


How can i interpret this ?


Thanks alot
DERAR
Rob Leadbeater
Honored Contributor

Re: DS20 problem , booting not possible

Hi,

> what does it mean when saying (disk is off-line) ???

Offline means that the RAID controller can't see the disk - either it has failed or there's something else wrong.

If you do only 7 physical disks, then this looks more likely to be an issue with the RAID controller itself. That seems to think that there are 13 physical disks (the JBOD and 4 x 3 Disk RAID 5s).

Either way, I hope you have good backups of this system.

Cheers,

Rob