HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Deleting account on trusted system

 
SOLVED
Go to solution
placitasmd
Frequent Advisor

Deleting account on trusted system

When trying to delete an account on a trusted system running 11.11 a message stating "Login currently in use" is returned. Have tried with both SAM and command line using 'userdel -r loginname'. User has not logged in for several months and the system has been rebooted numerous times over the last month. Any ideas on what might be causing this and how to get around it? I know the recommendation is to disable the account instead of removing it, but we would like to get it deleted.

Mark E Duhamel
3 REPLIES
Solution

Re: Deleting account on trusted system

Have you tried running who(1) to see if it thinks the login is in use?

 

Or do you have the same UID for two users and one is still in use?

Bill Hassell
Honored Contributor

Re: Deleting account on trusted system

As Dennis mentioned, you may have two logins with the same UID. Use this command

 

    logins -d

 

to verify that there are no duplicate UIDs.

 

Check that there are no processes running as this user:

 

    ps -f -u username

 

You may have cron jobs or other jobs that use su or other run-as tools like sudo that are running as this user.



Bill Hassell, sysadmin
placitasmd
Frequent Advisor

Re: Deleting account on trusted system

Who does not show the user logged in. Have not checked for duplicate UIDs but will. I don't have access to the server right now, but will check to see if the user may have some processes running under su.

Mark E Duhamel