System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Disable the Autonegotiation in the lancard

SOLVED
Go to solution
joseph51
Regular Advisor

Disable the Autonegotiation in the lancard

Hi,
I am trying to disable the Autonegotiation .But I am getting error while disabling it .
lanadmin -x 3
Speed = 1000 Full-Duplex.
Autonegotiation = On.

# lanadmin -X auto_off 3
ERROR: This option is applicable to 1000Base-SX only.

I tried to do the same using SAM also .But I am getting the error that Not able to set it with the speed of 1000.
Please someone tell me how to do it
8 REPLIES
R.K. #
Honored Contributor

Re: Disable the Autonegotiation in the lancard

Hi Binu,

What driver is used by card (ioscan -fnC lan) and what is your OS version?
Don't fix that what ain't broke
joseph51
Regular Advisor

Re: Disable the Autonegotiation in the lancard

Here is the ioscan output

ioscan -fnC lan
Class I H/W Path Driver S/W State H/W Type Description
===================================================================
lan 0 0/1/2/0 iether CLAIMED INTERFACE HP AB352-60003 PCI/PCI-X 1000Base-T Dual-port Core
lan 1 0/1/2/1 iether CLAIMED INTERFACE HP AB352-60003 PCI/PCI-X 1000Base-T Dual-port Core
lan 2 0/2/1/0 iether CLAIMED INTERFACE HP AD331-60001 PCI/PCI-X 1000Base-T Adapter
lan 3 0/5/2/0 iether CLAIMED INTERFACE HP AD331-60001 PCI/PCI-X 1000Base-T Adapter

the OS version is 11.11
Here I am trying to disable auto nego for the lan3
Torsten.
Acclaimed Contributor
Solution

Re: Disable the Autonegotiation in the lancard

For gigabit speed autoneg is the only option.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Johnson Punniyalingam
Honored Contributor

Re: Disable the Autonegotiation in the lancard

Hi Binu,

lanadmin -x speed 3


Thanks,
Johnson
Problems are common to all, but attitude makes the difference
R.K. #
Honored Contributor

Re: Disable the Autonegotiation in the lancard

Hi Binu,

Check for this file:
/etc/rc.config.d/hpietherconf

See what the below line says:
HP_IETHER_AUTONEG[3]=

Don't fix that what ain't broke
R.K. #
Honored Contributor

Re: Disable the Autonegotiation in the lancard

Hi Binu,

As said earlier in this thread, looks like Auto Neg is required for gigabit speed.

Although auto-negotiation can be disabled for 100BaseTX or 10BaseT connectivity, it is always required for normal 1000BaseT operation.

Check following for more information:
http://kc.forticare.com/default.asp?id=3780

Regds..
Don't fix that what ain't broke
joseph51
Regular Advisor

Re: Disable the Autonegotiation in the lancard

Now I understood that ..Thank you verymuch for all
joseph51
Regular Advisor

Re: Disable the Autonegotiation in the lancard

Thank you very much