System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Disks not visible in HP-UX 11iv3

suvy12
Frequent Advisor

Disks not visible in HP-UX 11iv3

Our Storage team has assigned 58 Luns from Hiatachi Box to HP-UX 11iv3 . But the problem is that these disks are not visible in the OS even i run the insf . According to storage team there is not any problem from their side but disks are not showing in ioscan output.
Can anyone help me in sort out this problem.
7 REPLIES
Torsten.
Acclaimed Contributor

Re: Disks not visible in HP-UX 11iv3

Did you run "ioscan"?


Ask the storage team if zoning is correct and if the LUNs are presented in "hp-ux" mode!

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
suvy12
Frequent Advisor

Re: Disks not visible in HP-UX 11iv3

Yes i ran the ioscan.
And accoding to storage team Zoning is correct.
Is there any other way in HP-UX 11iv3 than the 11iv2
Torsten.
Acclaimed Contributor

Re: Disks not visible in HP-UX 11iv3

It is different if you have already a LUN assigned, you unassign this LUN and assign a different LUN with the same number.

Then you need to work with scsimgr.


But if you don't do this, "ioscan" should be enough.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Uday_S_Ankolekar
Honored Contributor

Re: Disks not visible in HP-UX 11iv3

If zoning is correct and wwn is right then ioscan/insf should show you the disks.

Reboot and see if it helps,
Sounds strange, may be worth trying,
Good Luck..
Rita C Workman
Honored Contributor

Re: Disks not visible in HP-UX 11iv3

Check your HBA' that are in use...

fcmsutil /dev/fcd<#>

Make sure that it comes back and shows:
Driver state=ONLINE

If it shows Disabled or No_Light then you have a problem with the connection from the host.

Not sure if your hard or soft zoned. In fact, use that terminology when you go back and talk to your SAN folks.
The first line N_Port Node WWN would be the # used for hard zoning. But I'm banking they are soft zoned, so the second line N_Port Port WWN is for soft.
Write those numbers down for both and ask them to confirm them for you.

FYI - hard zoning is done for greater security, but makes changing anything more difficult-only large security required shops tend to use this; soft zoning is what most shops use. Knowing this will keep the SAN folks on their toes!

If you're dual fabrics you'll have to do this for each used HBA.

Just a thought,
Rita
Rita C Workman
Honored Contributor

Re: Disks not visible in HP-UX 11iv3

One more thing, not sure if anyone mentioned.

Did the remember to map and mask the disk to the host after they zoned them?

Rita
Robert_Jewell
Honored Contributor

Re: Disks not visible in HP-UX 11iv3

How are you running 'ioscan'? If you are running something like 'ioscan -fnkC disk' then you wont see the new disks. Likely you have done this type of work before and this is not the problem here, but... Just to check, be sure you are not using the -k option so that a new hardware scan is performed.

-Bob
----------------
Was this helpful? Like this post by giving me a thumbs up below!